Linksys Wireless Adapter Unidentified Network No Internet

#1
I have a Linksys Wireless-G PCI Adapter, Model WMP54G in my desktop. It works on XP 32 and 64 bit. However on Windows 7 64 bit, it will connect to my modem, but it will not connect to the internet, and it states Unidentified Network. Any assistance will be greatly appreciated.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#2
I have the same thing and I posted this answer in another similar post but this work around works for me.

When my computer boots... I have to go to the Network Sharing Center.
Next click on Change Adapter Setting.
Disable the Local Area Network by right clicking on it and selecting disable.
Next run the Diagnose the Connection utility.

It will tell you that the connection is disabled.
Tell it to fix it.

It will go through the process and it will work until the next time I shut down.

I have been looking for several days but have not found a permanent solution to this but many people are running into this so someone will figure it out soon I hope.

Mike
 


#3
I figured it out! All this time I've been trying to get it to work using the drivers Windows Update had installed, then I tried working with the Vista 64 bit drivers. I decided to try using the XP 64 bit drivers and those worked. Hopefully anyone else having a similar problem will read this and get it to work for them too.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.