locked out of C: drive please help

Discussion in 'Windows 7 Help and Support' started by ezonhold, May 17, 2009.

  1. ezonhold

    ezonhold New Member

    Joined:
    May 17, 2009
    Messages:
    2
    Likes Received:
    0
    Hello, i was trying to setup a homegroup between a few computers all running windows 7. Somehow during the process i managed to get my hard drive locked.. now whenever i do anythingi get a message telling me i dont have admin rights or something like that.. below are some of the messages i get.. Please help.. I have a lot of business data on this drive. I even tried to take the drive out and put it in another computer but it says reserved.

    if i try and double click on the "C" drive i get this message.. "C:\ is not accessible Access is denied

    even if i try and set my clock i get the following message.. "unable to continue" you do not have permission to perform this task. Please contact your computer administrator for help"

    i cant get into system restore or any controls.. i have tons of data on this comupter that i cannot lose..

    jeff
     
  2. thimiost

    thimiost New Member

    Joined:
    May 25, 2009
    Messages:
    2
    Likes Received:
    0
    i have the same problem

    I have a lot of important files there
    is there anything that can happen?
     
  3. tmac

    tmac New Member

    Joined:
    Aug 19, 2009
    Messages:
    2
    Likes Received:
    0
    same problem

    I have the same problem. Did you find a solution?
     
  4. AndyOoi

    AndyOoi New Member

    Joined:
    Aug 19, 2009
    Messages:
    8
    Likes Received:
    0
    Bump this...

    I have the same problem, and it is a serious problem! It is part of the core process of Windows, and I'm surprised there is not more information on it. Back in May, MS released a fix for this problem for the 32bit version but it hasn't been carried on to the 64bit edition, as it was assumed that there was no issues.
     
  5. michdl

    michdl New Member

    Joined:
    Aug 20, 2009
    Messages:
    4
    Likes Received:
    2
    hi guys, I seem to have solved my "C:\ Access denied" problem in a fairly simple way.

    if you do a search of this forum this topic is covered several times. some mention this patch, but it was released this spring, and here we are still having the same problem. ( I am running 32 bit) I assume that you would get this automatically from windows update, but maybe you dont get it if you only do express updates... I haven't tried that yet.

    The problem seems to be very much related to setting up home groups and then changing stuff around or leaving the group.
    I have had this problem two or three times and have always resorted to reinstalling or reimaging with Acronis. I have had windows restore fail when i tried to use it for this, probably due to access rights.

    The solution that worked for me was something I found on a previous post on this forum detailing how to use safe mode with command prompt to grant permissions on your c drive again. it is not to terribly difficult, but I have also followed the adivce given in another post about how to set the Administrator Account as usable (this is the Official Admin account) that supersedes any user account (with admin rights or otherwise) so that WHEN this happens again because I messed around with my homegroup shares That I can just log on as administrator and fix it.
     
  6. AndyOoi

    AndyOoi New Member

    Joined:
    Aug 19, 2009
    Messages:
    8
    Likes Received:
    0
    Hi michdl, thanks for your reply.

    Personally, I have checked numerous threads on ways that people have circumvented this problem, including methods of booting in safe mode and then using the 'net user' commands in the command prompt to activate the admin account. In my case the account was activated, but still didn't have the necessary permissions to grant me access to c:\. It seems that some people experience various levels of restricted access.

    I hope it's because I'm doing something wrong, though. If you could point me towards the particular thread that worked for you, I would greatly appreciate it, thanks!
     
  7. AndyOoi

    AndyOoi New Member

    Joined:
    Aug 19, 2009
    Messages:
    8
    Likes Received:
    0
    After some more hours of searching, I finally found a solution!

    It refers to a post on the Microsoft TechNet forums; Access Denied

    The solution involves editting the registry to turn off UAC control temporarily in order to gain access to the Security tab of the locked c:\ and then change the permissions.

    Hope this works for the others that have this problem!
     
  8. michdl

    michdl New Member

    Joined:
    Aug 20, 2009
    Messages:
    4
    Likes Received:
    2
    Hi again,

    Actually activating the administrator account was not what solved my problem, I activated it after the problem was solved in the hopes that it would make solving the problem in the future easier.

    steps:
    Logging on in safe mode (with command prompt)
    ctrl+Alt+Del
    starting the task manager
    starting a new task
    hitting browse
    selecting C:
    then properties
    then permissions
    adding a new object with permissions to access the c drive
    I manually entered my user name

    that was what actually solved my problem. I have not yet tried to use the administrator account to solve this problem. then once the problem was solved it was easy to activat the admin account in the normal way, no netuser commands at all.

    There may be Different levels of lockout, I can only relate my experience as I am by no means a techie. I belive my problem came from changing the homegroup sharing to much possibly by leaving my own group in an effort to solve a different problem. If you think that might have been what caused yours then maybe this will work for you.

    anyway, happy testing.
     
    #8 michdl, Aug 20, 2009
    Last edited: Aug 20, 2009
    textureDnB and (deleted member) like this.
  9. WindowsXpExpert

    WindowsXpExpert New Member

    Joined:
    Jun 25, 2011
    Messages:
    2
    Likes Received:
    0
    Hello Everybody. It turns out that some things did work. I tried some steps to guide me back into my Person Settings and give me full control of everything on my PC. Here are the steps I took:

    1. Shut off your computer.

    2. When the computer's manufactor's Logo appears, press F8 repeatedly.

    3. When it gives you about 5-6 options, choose "Safe Mode with Command Prompt.

    4. Log on to your account or the Administrator account.

    5. Press "Control, Alt, and Delete", one at a time. (Remember, push them together)

    6. When the task manager appears, click on the "Browse" button below.

    7. If you are not already on it, go to "My Computer on the Right Hand Side.

    8. When you see "Local Disk: C", right click on it.

    9. Click on "Properties".

    10. Click on "Security".

    11. Click on " Owner".

    12. Select your user account.

    13. Check the check box.

    14. Click the OK Button.

    15. Good. Now you have full control. It may take about 20 minutes if you have medium files, 1 hour for large files, and 5 minutes for short files.

    WindowsXpExpert
     

Share This Page

Loading...