Windows 7 Lost virtual memory / paging file on upgrade

Discussion in 'Virtualization' started by EyeDoc, Jan 15, 2009.

  1. EyeDoc

    EyeDoc New Member

    Joined:
    Jan 15, 2009
    Messages:
    2
    Likes Received:
    0
    I upgraded to the beta from Vista. In Vista, I never had any memory related problems. Since starting with the beta, I began getting out of memory errors. I looked into it, and realized that for some reason, there is no longer any paging file in use. The problem is that I can't do anything to get the paging file activated.

    I go into the Virtual Memory dialog box in the control panel, and I see that the "Automatically manage paging file size..." box is cleared, and each of my hard drives has a Paging File Size of "None". No matter *what* options I select here - whether I tell it to automatically manage, whether I tell it various custom sizes for the paging files on different drives, no matter what I do, when I reboot, everything is back to the way it was, with no paging files in use.

    Searching online, I see that people had similar problems with previous windows versions (although I never had this problem before). I've ensured that I'm running an administrator account, and I tried manually putting values into the registry, but this still doesn't help.

    Any help would be appreciated!
     
  2. spook84

    spook84 Honorable Member

    Joined:
    Feb 19, 2009
    Messages:
    7
    Likes Received:
    0
    i have a similar problem. i can enter the values i want but after i set them and click ok it freezes up. i can still open other programs at that point but the process just hangs.

    dont know what to do. i understand its beta(lab rat) but i hope its fixed when its released later this year. or in a patch
     
  3. ZeNeece

    ZeNeece New Member

    Joined:
    May 10, 2009
    Messages:
    2
    Likes Received:
    0
    I'm having the same problem. The paging file size is set to none. If I change it it just clears itself out again. I'm getting low memory warnings if I do too much. Is there a fix or a way to work around this until it's fixed?

    Other than that windows 7 is working great. It's really the only issue I have.
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    That's strange, it usually gives a warning.

    Does anyone had a second drive installed where you could set the paging file to.

    Check the root of the C: drive, right-click on pagefile.sys and let me know the size.
     
  5. Storytell

    Storytell New Member

    Joined:
    Nov 3, 2009
    Messages:
    6
    Likes Received:
    0
    Join me to the list

    I have tried everything except going blind into the registry. Nothing will give me a pagefile and since I am running Win 7 32bits I am limited to 2 G of Memory Grrr!!!:mad:
     
  6. Storytell

    Storytell New Member

    Joined:
    Nov 3, 2009
    Messages:
    6
    Likes Received:
    0
    I have tried various external HD and no luck, I don't find a pagefile.sys on C: or I do not know where to look for it....not on root
    Thanks
     
  7. Storytell

    Storytell New Member

    Joined:
    Nov 3, 2009
    Messages:
    6
    Likes Received:
    0
    I discovered that pagefile.sys had the same date as when I insalled Rollback RX. I removed that and all is well!!
     

Share This Page

Loading...