Windows 10 Memory leak on Windows 10 - Solved

johncoool2

Honorable Member
A memory leak started a few days ago. It is happing while the system is on idle. Even after rebooting the computer.

The increased memory is not reflecting in the task manager. I have 6GB of total RAM, it starts at 50% and then it just keeps going up until it reaches 95%. It might not be releasing it from the system memory. I left the system totally idle for 16 hours and it still happened.

There might be some RAM tools to get it to go back down, but that is not a proper solution. I need to find out what is causing it or how to release the memory instead of it getting stuck.

Can anyone give tips on this? Are there tools that will show more details of the programs that will log the RAM Usage so that I see if it is a particular one that I can deal with?
 

johncoool2

Honorable Member
I do have AVG antivirus installed and I did enable some of the Windows defender features just for testing. However, I did disable it yesterday. Now I noticed that the "Microsoft Windows malicious software removal tool" has normal RAM and CPU usage but the disk usage is high. I am not sure if it was installed with the latest Windows update or if got enabled with the other feature a few days ago.

Can someone give me more tips on it and if I can disable it?
 

johncoool2

Honorable Member
Here is a new update on the issue.

I reinstalled the USB Network Gate to do further testing.

I got BSOD a couple of times while installing / uninstalling it. On an older and the latest version.

However, that is not the big issue.

I have it installed on several devices. On 3 Windows 10 computers and one Windows 8.1 PC.

The above mentioned issue is occurring on one of the Windows 10 PCs along with a memory leak. I also tried disabling the service but the memory leak still happened. Even If I leave the computer on idle for around 16 hours I come back to find that it has reached 95% and then it requires to be rebooted. This stops if I uninstall the program. I also tried in the Client only version and it still happened.

I noticed that it is conflicting with another program called "Fences". Fences is made by stardock. I did not try to uninstall Stardock to see if it still occurs. However, I noticed that I cannot open Fences while USB Network Gate is installed.

I have the same programs installed on Windows 8.1 and no issues are occurring there.

I sent an email to the support team of USB Network Gate. I think that the program may need to be updated or that it is not compatible with a driver on my old laptop. I will update here if I get any useful feedback from them.
 
Top