My New Headset is Constantly muted

Discussion in 'Windows 8 Help and Support' started by AlexT11, May 24, 2015.

  1. AlexT11

    AlexT11 New Member

    Joined:
    May 24, 2015
    Messages:
    5
    Likes Received:
    0
    I recently bought my new Raptor HS40. But I soon realised that the microphine is muted. I've talked to Corsair support and they think its my PC. Its a USB headset and the volume works perfectly. I personally think it may be the driver. HELP!!!
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Hi Alex,
    which apps have you tried to use the Microphone with? Some applications you need to actually configure which device to use as default. Also make sure the Mic isn't turned off via a little switch actually on the USB cable itself.
     
  3. AlexT11

    AlexT11 New Member

    Joined:
    May 24, 2015
    Messages:
    5
    Likes Received:
    0
    I've tried using Fligh Simulator X and I've tried configuring it. There's a mute button on the USB cable but it doesn't change anything.
     
  4. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Have you tried using the headset with skype or even on a different machine. Another thing you could try is a different USB port as not all are the same and if your using a front panel port try one round the back.
     
  5. AlexT11

    AlexT11 New Member

    Joined:
    May 24, 2015
    Messages:
    5
    Likes Received:
    0
    I tried round the back and still the same. I took it to PC world and thay plugged it into their pc and it came straight on.
     
  6. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    What is your machine please also check Audio devices when it's plugged in. Look via Control panel, Hardware and sound, Sound and then manage audio devices. You might have to enable the mic but in any case check your audio devices and see what it says.
     
  7. AlexT11

    AlexT11 New Member

    Joined:
    May 24, 2015
    Messages:
    5
    Likes Received:
    0
    I have a Cyberpower Elite gaming PC. I've tried in the control panel and it says its enabled and everything but its just muted. I tried unmuting it via the control panel but it just shoots right back down to mute.
     
  8. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Ok if the headset comes with drivers and a configuration panel of some type is the mic enabled via that? Also did you have anything else installed prior to this headset?
     
  9. AlexT11

    AlexT11 New Member

    Joined:
    May 24, 2015
    Messages:
    5
    Likes Received:
    0
    I installed a control panel from the corsair website but i tried unmuting it via that but the same still happenend, it just stayed muted. But i also tried a non USB microphone and that still is always muted
     
  10. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,836
    Likes Received:
    1,566
    Have you tried installing the corsair drivers as administrator? If not uninstall them, reboot and the re-install them but this time right click on the start up exe and run as admin. Once installed pop back into the sound devices particularly microphone as windows will mute the mic by default. I own a very cheap headset but essentially it's a USB connection like yours. Here are some screenshots of connections you can check once it's plugged in:
    mic1.
    Go via the control panel to Sound devices, highlight the mic and hit configure: mic2.
    You can then set up the mic. If the mic is still muted then try clicking on Properties and checking the settings along the top:
    mic3.

    Lastly what Sound drivers do you use any idea?
     

Share This Page

Loading...