Naming files the same in the same folder is not possible

Discussion in 'Windows 7 Help and Support' started by noface, Dec 27, 2011.

  1. noface

    noface New Member

    Joined:
    Dec 27, 2011
    Messages:
    4
    Likes Received:
    0
    I have 2 files with different extensions, they must reference each-other with the same name but windows 7 renames the files because they are the same. How to disable this setting? Thanks.
     
  2. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    By Windows default, that should not be happening. Waht are the extensions of each file?
     
  3. noface

    noface New Member

    Joined:
    Dec 27, 2011
    Messages:
    4
    Likes Received:
    0
    .vtf and .vmt
    In windows explorer I can't see the extensions, but I know they are those. However, I do have 'hide known extensions' unchecked.

    It renames the files like this: file and: file (2)
     
  4. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Sorry. Googled and found no help. I can see that they are new game formats. But I downloaded one or two that I found and had no problem (same name) copying to the same folder. Wild thought - I wonder if your antivirus isn't messing with them in some way?
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I was thinking possibly if the file extensions were associated with the same program it might be a problem, but I saved two notepad files with different extensions and it did not cause a name change.

    All I could suggest is to change one of the extensions to see if it still does that. Maybe there is something in the file that makes Windows think it is the same file.
     
  6. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    What's strange to me is that you can't see the file extension even though you have 'hide known extensions' unchecked. I suspect that this is what you should be looking into. If the extension is not being applied to the file name, you won't be able to name both files the same. Go to the CMD window and check the file names via dir.

    Do you see the file extension on other files?
     
  7. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,045
    Likes Received:
    300
    Hi

    I've seen this happen at times when working in Photoshop.
    I just tried it and I was able to save the same file with the same name as .jpg, .psd and .png format with no problems.

    But I have had times when it would rename files either Sprite (copy).xxx or Sprite (1).xxx.

    I have never really thought about why it was doing this or that it wasn't the usual behavior.

    Try and pick some other file and place it in a folder, i.e. a .jpg file and then save it again with another extension in the same folder i.e. .tif and see if this happens.

    Determine if what you are observing happens with all files, or just the ones with the particular extension you are working with.

    You should be able to see all the extensions for all the file types, if you can't there is some kind of error that should be addressed.

    I did find someone who can't get rid of the file extensions... they received this information.

    The "Hide extensions for known file types" option only applies to file types that are registered on the system.
    If you have not installed the program that uses this file type, this could be the source of the problem that you are seeing.
    Try installing that program that uses those files and this should register that .pes file extension.

    And this article that may relate...

    Geekdeep's Haven: FILE EXTENSIONS NOT SHOWN IN WINDOWS

    I just noticed for the first time that there is a option under View that hides all file names.
    Why would anyone want to do that?
    I have enough trouble finding what I want with everything showing!

    Mike
     

Share This Page

Loading...