.NET framework 3.0

#1
'ello

so, I installed windows 7 two days ago and am trying to get aion to work and currently the launcher is giving me

Could not load type
'System.Windows.Forms.WebBrowserDocumentCompletedEventHandler'
from assembly 'System.Windows.Forms, Version=2.0.0.0,
Culture=neutral, PublicKeyToken=b77a5c561934e089'.

anyways, all threads I've read aswell as NCsoft's tech support says it's because .Net framework 3.0 needs to be installed but when I try to install it then it says that a newer version of this application is allready installed on this computer and that I need to remove it first. And there are no .Net installs under the programs and features and it returns an error message when I try to turn 3.5 off with "Turn windows features on or off".
 


reghakr

Essential Member
#2
Try this :

Microsoft .NET Framework 2.0 Service Pack 1 (x86)
Download details: .NET 2.0 SP1 (x86)

Some older apps require >NET Framework 2.0.

If the above doesn;t fix the problem after rebooting, give this a try:
Microsoft .NET Framework 2.0 Service Pack 1 (x86)
Download details: .NET 2.0 SP1 (x86)

What program are you trying to instll?
 


#3
I just tried running that one and got the following error:

You mush use "Turn windows Features on or off" in the control panel to install or configure microsoft .Net Framework 2.0 SP1.

I've been in this "Turn windows Features on or off" and there are only 3.5.1 there and it's currently set to on. Trying to turn it off or turning any or both of its suboptions on gives an error message telling me that not all of the requested changes could be made and when I've restared the computer as it asks everything in there is back the way it was.

And I'm not trying to instal anything, I'm trying to get AION's (new mmo) Launcher to work... instead of just crashing :p
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.