Netowrk driver fails to install even in safe mode

#1
Network adapter in question is Intel PRO\1000 PL
Here's how it went everything has been fine for awhile then I rebooted my machine today and then I had a red X on the network icon in the systray and no internet. So I rebooted my router then my machine and still had the red X on the network icon in systray but now had internet working. So I went threw windows help and 1 solution said to uninstall hardware threw device manager and reinstall, well this is were everything went to crap. Now it will not install/load the driver back to complete reinstalling the hardware everything time I try I get Windows failed to load driver and when I look why it says "the parameter is incorrect". I tried downloading the windows 7 driver from intel for my network adapter and it fails, I tried the driver on the resource cd for my pc and it fails, I try to let windows pick it's default driver and it fails. Always the same thing so now I can't get the thing to even install back to even get internet. It's not a hardware problem because on the same pc I have dual boot running with XP and everything is fine with the XP as always. Like I said before everything was fine until today and I have no idea what else to try other than reinstalling the OS which I can't afford for it to come to that nor should it have to. Any help would be appreciated to get this issue resolved thanks
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.