Network breaks down after period of satisfactory running

Discussion in 'Windows 7 Networking' started by barrykensett, Jul 27, 2015.

  1. barrykensett

    barrykensett New Member

    Joined:
    Jul 27, 2015
    Messages:
    5
    Likes Received:
    1
    I have a networking problem which has persisted for many weeks no matter what I try to fix it. The basic setup has been running for 7 years without this issue.
    The network is a Flight Simulator with a main Windows 7 PC driving the Flight Sim software and also acting as a server for another four PC's, one Windows 7, the rest XP. When the sim is running there are about 30 programs across the PC's, many of them sending data to one another across the network.
    On short flights say up to half an hour everything works fine but on longer flights the network breaks down. The manifestation of the problem is that the flight management computer cannot access the server PC and error messages pop up like "Runtime Error" or "file can't be found" but these are almost certainly effects, not cause.
    When in this condition I cannot access the shares on the Flight Sim computer from any satellite and if I try to view the total network I am told I cannot access the Workgroup or don't have permissions. If I try to access individual shares from the satellite PC's to the server PC I cannot get access yet all of the satellites can see one another. The overall effect is that the server PC has "shut the door". However I can see all the shares from the server to the satellites and many services continue to run across the network.
    From windows I can get the classic message "Not enough server storage is available to process this command"
    The problem started when I upgraded a version of the Simulator software but this my be coincidence, not cause.
    Things I have tried:
    1.Increase IRPStackSize progessively up to max of 50 with no effect.
    2.Reverted to earlier version of Simulator software.
    3.Total reload of PC from Windows 7 up.
    4.Tried separate PCI LAN card.
    5.Swapped cables.
    6.Removed AV software (AVG)
    7.Checked and triple checked shares and permissions.
    8.Sought advice from Server software writer who says LAN traffic very low.
    Rebooting the server PC fixes it.
    I don't think it is temperature related, I am well cooled.
    All power saving options are off.
    UAC is off.
    Simulator PC's are all connected to one hub which is then connected to the router. Internet speed is 70mb.
    Any suggestions to check would be welcome. I am not a computer expert - I just make things so idiot's language would be appreciated.
    Thanks in anticipation of getting fault free flights again.
    Barry
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    Have you tried IRPStackSize set at 18 instead of 50 on the Windows 7 machine? Remember to reboot after modifying the key.

    Also AVG has been known to cause this, did you remove it entirely (use their removal tool as well not just the uninstaller, that way no drivers are still loading in your system for sure)?

    Do you happen to have Acronis TrueImage or Seagate DiscWizard installed on the Windows 7 machine?

    Are there any other errors in the windows event viewer (on the "server" machine) that happen when this error occurs?
     
  3. barrykensett

    barrykensett New Member

    Joined:
    Jul 27, 2015
    Messages:
    5
    Likes Received:
    1
    Thank you for your interest.
    I started stack size with 20 and went up to 50 in 5's. I will try 18.
    I will look for AVG tool as I used regular uninstaller. I have used AVG for years on this PC with no problems but perhaps latest version is an issue.
    I do not use Acronis or Seagate software.
    I will test more and report back including event viewer results.
    Thanks again, good to find someone to talk to, it has been a lonely journey!
    Barry
     
  4. barrykensett

    barrykensett New Member

    Joined:
    Jul 27, 2015
    Messages:
    5
    Likes Received:
    1
    Stack size 18 tried, still failed, tried 25, still failed.
    AVG removed with tool.
    Event Viewer says "server unable to allocate from the server unpaged pool because the server reached the limiut for non paged pool allocations. Event ID 2017 Source srv"
    I think this is what we know.
    So no further on, any more ideas?
    Barry
     
  5. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    There's a few things you can try, I would suggest creating a System Restore point first.

    You can find more information on these changes using the following links:

    https://support.microsoft.com/en-us/kb/232271
    LargeSystemCache: Core Services

    Set this to 1:
    HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

    Set this to 3:
    Changed: HKLM\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters\Size

    I have more things you can try if those don't seem to help.
     
  6. barrykensett

    barrykensett New Member

    Joined:
    Jul 27, 2015
    Messages:
    5
    Likes Received:
    1
    Well something has changed! I set the changes you suggested above and carried out a test flight. Usually when I get the failure I get a message in the Flight Management Computer and I lose acces to the shares on the server PC. This time I got a failure of the FMC after about 1 hour of flying but I got a different message "Runtime error 5, invalid procedure call or argument" but more significantly I could still access all the shares so the changes seem to have stopped the server "shutting the door" and maybe the error message is something different, I am going to put the point to the author of the software to see what the message may mean, I will report back when I have news.
    Whilst going through this optimisation the other half of my brain says "why has this problem appeared when I have been running the software combination mainly unchanged since 2007 and on this main computer for over two years?" Yes there have been upgrades to the main Flight Simulator program but these have generally gone in without problems. I had heard that AVG 2015 could cause trouble but I have removed that. The weather depiction program is a bit sensitive but I get the problem if I fly without it. Maybe some Windows update has changed things. I have put a PCI network card in to negate any hardware failure. I monitor the forums for the main software packages and nobody else is reporting my problem. I keep thinking that there is something simple somewhere but in the meantime I will try and tune it out.
    Thanks again for your interest.
    Barry
    PS you can see my sim on www.a320sim.com
     
  7. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    That run time error would most certainly point to an issue in the software itself. Your simulator looks nice, you should find a way to mass produce and kickstart it :D
     
  8. barrykensett

    barrykensett New Member

    Joined:
    Jul 27, 2015
    Messages:
    5
    Likes Received:
    1
    Two more long flights and still looking good.
    Cleared the runtime error.
    Barry
     
    Josephur likes this.
  9. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    If it continues to work can you use the "Best Answer" option to mark the question answered? Thanks.
     

Share This Page

Loading...