No Audio Device is installed

Discussion in 'Windows 7 Help and Support' started by steveysteve, Sep 13, 2011.

  1. steveysteve

    steveysteve New Member

    Joined:
    Sep 13, 2011
    Messages:
    8
    Likes Received:
    0
    I have a HTPC in my living room which since updating on the weekend now has no sound :mad:

    I have found similar issues and posts on various forums from searching all afternoon Sunday but none with a solution (that works for me) other than a full Windows 7 reinstall.

    I will explain the issue and what I have tried thus far:-

    I have a PC running onboard realtek (ASRock ConRoe 745 DVI), which was working perfectly until Service [pack one update and two other updates this Sunday.

    I unfortunately discovered for some reason the System Restore on this machine was set to off so that is not an option :(

    The audio symbol bottom right says there is no audio device installed, however if you look in the device manager there is the correct Realtek device installed with no exclamation mark and it is reporting as working correctly.

    If you right click on the red cross and click playback devices it takes you to the realtek device properties and it is set as default. (In fact if you unplug the speaker jack the PC advises you of this even though it says no audio device installed).

    If you click on the red cross it launches the fault detection wizard and returns


    "Audio Device is Disabled - Not Fixed"

    I have tried uninstalling the device - scanning for changes - reinstall

    Repeated the above but deleted the device drivers

    Tried a SFC scan and a Chkdsk Scan (No errors)

    Tried with the Microsoft default high definition audio drivers and the latest (and not latest) realtek drivers

    Tried disabling in the BIOS uninstalling and reinstalling after re-enabling

    Tried uninstalling the updates and repeating the above

    Tried uninstalling the service pack and repeating the above

    Finally unenabled the onboard card and installed a PCI soundblaster Audigy - Same problem :mad:

    ----Driving me mad----
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Does you system just plug into speakers and you have checked that connection? I suppose it you added a card, the connection was checked and at the speakers also, but make sure the audio cable is good. The fact the audio is inoperable on two different audio devices, seems to lead to a problem past your system. Have you tried a headset?

    You appear to be looking at the Realtek icon, what if you right click the speaker icon and select playback devices. Does "Speakers" show as an option and set as default?

    If they show, maybe some setting in the configure or properties area might help.
     
  3. steveysteve

    steveysteve New Member

    Joined:
    Sep 13, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks for the post, although (with either sound Card) by red cross I mean the speaker symbol with a red circle and a white cross through it. I am not clicking a realtek icon, when I right click the speaker icon and go to playback devices yes the Speakers do show under the playback device with a default tick on them.

    Unfortunately if you click on the configure button nothing loads also due to note that if you click the properties tab and then levels the sheet is blank (when using either sound card).

    The PC is connected via a stereo cable to my TV normaly, however I have also tried pluging in headphones directly instead to eliminate a cable issue and experienced the same behaviour.

    :grey:
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Sort of sounds like some primary driver is not where it needs to be. Possibly a Windows Component.

    So first I would suggest you open an administrative command prompt and type SFC /scannow to see if your system files check out. Possibly an update left your system is some type of degraded state. If it comes back with a could not fix type of message, let us know. Sorry, I see you already tried this, so it must not be that type of problem.

    If that doesn't help, I would probably remove the Realtek drivers and use the remove all instances option. Maybe a previous driver has been corrupted and is not being replaced. If you already used the remove all instances option, it may not help to use it again.

    When you added the sound card, did you disable the onboard sound in the bios? On that same note, have you checked to see if you bios is up to date? I am not suggesting you need to update it, but if you are several updates behind, it might help.

    I suppose it would make sense to try to get the speaker properties and configuration dialogs back, hopefully it is related to a system file and can be fixed. Do you have any other audio software on your system?
     
    #4 Saltgrass, Sep 13, 2011
    Last edited: Sep 13, 2011
  5. steveysteve

    steveysteve New Member

    Joined:
    Sep 13, 2011
    Messages:
    8
    Likes Received:
    0
    Ok so tried another sfc scan for good measure but no joy.

    Re-removed all drivers and let windows install the default ones.

    When I was using the creative card I did disable the sound card in the bios. Bios appears to be up to date.

    Added a screen in case it adds clarity/gives anyone any ideas. (was in work when posting the original post or would have done it then).
    screen grab.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I checked your motherboard and it shows the following for an audio component.

    You now show a Microsoft audio, which might be because you removed the earlier driver.

    You only have a Realtek Network Adapter and not a sound device. Don't know why you mention you see Realtek when you click the audio.

    I check the ASRock site and there do not seem to be any Windows 7 drivers for that motherboard. Windows 7 drivers may work, but they are usually vanilla drivers and may not have some capability. The ASRock site does show some Vista Drivers, so if you can't get it to work, you might try those.

    Edit: I just realized when I searched for a 745 I got a 945. I do not seem to be able to find the 745 version of the ASRock site here. Hopefully your board is close.
     
    #6 Saltgrass, Sep 13, 2011
    Last edited: Sep 13, 2011
  7. steveysteve

    steveysteve New Member

    Joined:
    Sep 13, 2011
    Messages:
    8
    Likes Received:
    0
    Firstly Apologies the 745 was a typo, the board is a ConRoe945G-DVI so your comments are valid for the right board. Drivers for which are vista drivers for Realtek high definition audio driver ver:R1.53.

    When these are installed then I see a realtek device when I click the audio, at time of the screenshot these drivers aren’t installed and the generic windows drivers are which is why you don’t see any realtek audio in that screen shot.

    As stated I have tried many combinations of drivers and have tried the ones from the motherboards support site as the first port of call.

    All drivers report the same error now although the system worked perfectly happily with either the Microsoft drivers or the realtek drivers before this weekend (I installed the realtek ones from the ASrock website but originally windows picked up the standard drivers as shown in screenshot and there was sound then).

    I don’t see a solution other than a fresh install, problem is that if I don’t identify the root cause at least I run the risk of this happening again.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Seems a little strange the website says it is a Vista sound system but your owner's manual says Realtek.

    I was looking at the Realtek site and saw some Windows 7 HD codecs for download. They warn the drivers my not give the same capability as the manufacturers drivers.

    This Realtek link does not seem to work the same every time, but it should lead to a multiple OS download page which included drivers for Windows 7 32 and 64 bit. If it doesn't then look for a download for the HD Audio Codecs. The version is R2.65 which seems to be newer than the ones you tried.
     

Share This Page

Loading...