No Internet Access, ping general failure after upgrade from Vista Ultimate (32-bit)

Discussion in 'Windows 7 Installation' started by chopsuei3, Nov 12, 2009.

  1. chopsuei3

    chopsuei3 New Member

    Joined:
    Nov 12, 2009
    Messages:
    12
    Likes Received:
    0
    I'm working on upgrading a Dell Latitude D830 from Vista Ultimate (32-bit) to Windows 7 Ultimate (32-bit) retail. I opted to do an upgrade instead of a clean install for the sake of time.

    The system has 2 network adapters installed, a Dell 1390 WLAN mini-PCI adapter and a Broadcom NetLink 57xx adapter.
    Before the upgrade, there were no internet access problems and both adapters worked as expected. They both were able to obtain an IP address automatically, connect to the internet, and ping and tracert.

    During the Windows 7 upgrade (instead of the clean install), I selected the option to download new updates during the install, but couldn't due to some connectivity issue (probably some firewall, although I disabled/uninstalled any and all security applications). Therefore, the installation continued without downloading the most recent updates, not a big deal, but the standard W7 drivers were probably used during the upgrade.
    After the upgrade, the system appeared to operate normally; no issues cropped up as I booted the system, no error messages, etc.

    I realized after booting from complete that I was having a connectivity issue, and then Network and Sharing Center reported "No Internet Access".
    I noticed as I disabled each adapter and re-enabled them, there was a significant delay when "identifying the network" and each time, the system decided I was on an "unidentified network". In addition, when I went in to each adapter's details, I noticed neither adapter had a valid IP address, and both continually revert to the system default of 169.x.x.x.

    I tried the following steps to resolve the issue:
    - I reinstalled each adapter's W7 driver from their respective websites, to no avail.
    - I tried using the standard W7 driver included with W7, to no avail.
    - I uninstalled each adapter and restarted the computer. The adapter would reinstall, but the problem persisted.
    - I disabled each adapter and re-enabled each adapter, to no avail.
    - I checked DHCP was enabled on each adapter and the DHCP service was Started, still no IP address.
    - I set each adapter's IP address to a valid static address. I was then able to Identify the network as a Home network, but I still had "No Internet Access" showing.
    - I disabled IPv6 on each adapter by unchecking the box under the adapter properties
    - I disabled IPv6 by adding a registry entry, DisableComponents set to decimal 255 under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip6\Parameters
    - I disabled the Apple Bonjour service to no avail
    - I disabled the Windows firewall entirely
    - I double-checked there were no firewall/security applications installed or running, both via TaskMgr and Services
    - I ran the command "netsh int ip reset reset.txt" and it completed successfully, but after the restart, still "No Internet Access"
    - I ran the command "netsh winsock reset" and it completed successfully, but after the restart, still "No Internet Access"
    - I tried these steps for each adapter with the other adapter disabled to prevent conflicts
    - I tried a new adapter, Netgear WNDA3100, which installed fine, but the same problem still persisted, "No Internet Access" and no IP address assigned
    - I tried upgrading my WRT54G to a new WRT160N. Everything set up correctly, the router got a WAN IP address, but the laptop still reported "No Internet Access" after reconnecting to the new router
    - When attempting to ping or tracert, with either adapter enabled, and the IP address set to DHCP or static, I receive the error "General failure" on every ping attempt

    Please help as I am still unable to access the internet via both a wireless adapter AND a wired adapter!

    - I believe the issue is NOT driver related as the problem exists for both adapters
    - I have 2 other laptops that can connect to the internet without a problem, via the same router. They both obtain an IP address from the router, and can also be set to static.
    - I have another laptop, a Dell Inspiron 1525, that I also upgraded from Vista Ultimate (32-bit) to Windows 7 Ultimate (32-bit) at the same time, and it is NOT experiencing ANY of these issues. It connected to the internet before AND after the upgrade successfully, and is still working right now. Under W7, it can obtain an IP address automatically and can also be set to static, both still allow the system to reach the internet.

    Is it possible to reinstall the TCP/IP components via Add/Remove Windows Features?
    Would running sfc /scannow possibly repair a corrupted TCP/IP stack or TCPIP.sys?
    Can I try repairing the installation using the W7 disk?

    Please let me know if you have any ideas on how to resolve this issue.

    Thanks so much, I'm very much looking forward to a response.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would start by disabling one of your network adapters, probably the wireless one.

    There are trouble shooters on the Network and Sharing Center.

    Are you using Homegroups?

    Does you network show as Home Network with a House in Network and Sharing Center?

    Can you ping 127.0.0.1?
     
  3. chopsuei3

    chopsuei3 New Member

    Joined:
    Nov 12, 2009
    Messages:
    12
    Likes Received:
    0
    Information update - ping general failure

    See my resposnes in red. Thanks for the quick response!

    I would start by disabling one of your network adapters, probably the wireless one.
    I have disabled each adapter separately, and run through each of the previously posted troubleshooting steps.
    For simplicity, I will focus just on the wired adapter, the Broadcom NetLink 57xx, and will disable the Dell WLAN 1390 adapter. So far, still the same issue after going through the troubleshooting steps again.

    There are trouble shooters on the Network and Sharing Center.
    I have tried using the built-in troubleshooting guides, but they are unable to determine or resolve the problem. I think this is most likely because the issue seems to be related to the inability of Windows 7 to correctly obtain an IP address, both when set to DHCP and static.

    Are you using Homegroups?
    No, I am not using Homegroups. In fact, I am unable to use Homegroups successfully due to a couple of different error messages:
    - no IPv6 installed, re-enable and try again --> resolved the issue but still not successful
    - inability to successfully get a valid IP via DHCP
    - static IP appears to have the correct settings, but ping still errors with "General failure" and no other information (DNS servers, etc.) populate once the static IP is entered

    Does you network show as Home Network with a House in Network and Sharing Center?
    Using DHCP, the network is shown as "Unidentified network", I believe because no IP address is assigned, and therefore, the system is unable to determine what kind of network it is on.
    Using a static IP address, I can then designate my network as a Home or Work network. I selected Home network and ran through the lists of troubleshooting steps, still "No Internet Access".

    Can you ping 127.0.0.1?
    Pinging any address, 127.0.0.1, google.com, 192.168.1.1, etc. all report the same error, "General Failure". I am not at the machine right now, but I believe pinging localhost reports a different error, from what I recall, something that lead me to believe the system was trying to get an IPv6 IP address via DHCP or static vs an IPv4 IP address.

    Thanks again for your tips/help!
     
  4. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    I mean no disrespect chopsuei, but let's see how long you spend here trying to find a solution.:)

    My thinking is that a "clean" install is the only way to go as an upgrade leaves hundreds of useless files left on your system and cause conflicts
     
  5. chopsuei3

    chopsuei3 New Member

    Joined:
    Nov 12, 2009
    Messages:
    12
    Likes Received:
    0
    reghakr,

    I agree that a clean install is preferred over an upgrade, in fact, I originally had planned a clean install, but due to the time it would take to reinstall all the applications and user data files, I decided to attempt an upgrade first.

    I am not against doing a clean install; I have all the data backed up on an external hard drive, and at this point, my only options are:
    1. Clean install
    2. Repair using Windows 7 boot cd (possibly corrupt TCPIP.sys?)

    Unfortunately, after researching the problem yesterday, I have found a number of posts by people with a very similar problem, but for some, a clean install still did not resolve the issue.
    So although I agree that a clean install would be best to rule out problems caused by leftover files and misconfigured settings, I am hesitant to invest the time required to reinstall all applications and data, especially if this may not even resolve the original issue.

    Do you have any other suggestions?
    Have you seen/heard of other Windows 7 upgrades that have had certain system components not function correctly?
    What's more is that all other features and components of the system appear to be working without any problems whatsoever.
     
  6. chopsuei3

    chopsuei3 New Member

    Joined:
    Nov 12, 2009
    Messages:
    12
    Likes Received:
    0
    Additional steps tried

    Apologies, but I forgot to mention these other steps I tried while trying to resolve the "No Internet Access" problem:

    - I disabled all Dell Power Management features included disabling the NIC when using the battery or no network cable is present. The issue still persisted and reported "No Internet Access"
    - I looked through the event viewer and found a lot of "information" entries, especially under the Broadcom adapter. Most of these though were related to the WLAN adapter logging on and off of the wireless network, none were related to obtaining an IP address, and most importantly, there were no "errors" that occurred after the upgrade that would cause the problem of "No Internet Access" that I am seeing
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It seems like you have done most of the things I could suggest. Maybe try a system file check by opening a Admin command prompt and typing sfc /scannow .

    A startup repair might help and it may take more than one run if it finds something.

    The lights on your network adapter are blinking as you might expect?

    Go into the hosts file and remove the # in front of 127.0.0.1 and try pinging it again.

    But you are sure there are no other firewalls/anti-virus programs, even in the router?
     
  8. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    As I stated, I meant no disrespect.

    Try downloading this freeware utility that you can compare with your network settings

    AdapterWatch displays useful information about your network adapters: IP addresses, Hardware address, WINS servers, DNS servers, MTU value, Number of bytes received or sent, The current transfer speed, and more. In addition, it displays general TCP/IP/UDP/ICMP statistics for your local computer.

    [​IMG]

    AdapterWatch v1.05
     
  9. chopsuei3

    chopsuei3 New Member

    Joined:
    Nov 12, 2009
    Messages:
    12
    Likes Received:
    0
    Thanks everyone

    No worries reghkr, thanks for taking the time to help me out, I greatly appreciate it :p

    As for your suggestion, I will give it a go and see what that application tells me about the adapters.

    I checked around some more and have found only 1 person who posted a problem with exactly the same symptoms as mine (the link escapes me right now, ugh, apologies) and their only solution, after attempting pretty much the exact list of steps I took, was to do a clean install, as you suggested.
    I have decided to image the drive, in the event that the clean install doesn't resolve the issue, and am going to embark on a clean install of Windows 7 to try to alleviate the "No Internet Access" problem with any and all network adapters. I will post back with the result...fingers crossed.

    And once again, thanks all for the help... I had a feeling an upgrade just wouldn't cut it, so in the end, thanks for taking the time to help me resolve a problem i inevitably created in the first place, haha.
     
  10. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Good luck to ya:)

    Just write down the list of 3rd party programs you have installed so you know what to re-install.
     
  11. chopsuei3

    chopsuei3 New Member

    Joined:
    Nov 12, 2009
    Messages:
    12
    Likes Received:
    0
    [SOLVED] Internet Access!

    Okay, so after imaging the drive, I decided to give it one more shot. I remembered that I attempted to remove Norton Ghost (version 12.0) just for kicks upon the first go-round of troubleshooting, but was met with an error, "Internal error 2343".

    So I went over to Norton, grabbed the Norton removal tool from Ghost, ran it, and voila!

    It was like magic, the exclamation point disappeared as soon as the removal was complete, and I had full internet access, an IP address and everything!

    I'm not sure why Norton Ghost causes Windows 7 to not be able to talk to any DHCP server, or so it seems, but the point is moot as this is probably the reason it is marked as INCOMPATIBLE with Windows 7, hah.

    Good luck to all those with similar issues, again, thanks for all the help!
     
  12. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Thanks for posting back with the solution.:)

    yes, it may help other people.
     

Share This Page

Loading...