Not connected - connections are available

Discussion in 'Windows 7 Networking' started by doesitoffendyou, Nov 1, 2010.

  1. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    Well I browsed through the other threads on this topic, but nothing worked for me.

    I bought the compaq Presario cq56 yesterday. The laptop came with a lot of crap on it from HP so I decided to install Windows 7 Ultimate on it, to have a clean Windows, wifi worked fine with the pre-installed Windows. After I installed Windows 7 Ultimate, I was not able to see the other wi-fi netwoks (usually around 40). Fair enough I though, let's download the newest driver for the network card (Realtek PCIe FE Family Controller). I did that, but it still didn't work so I uninstalled it again.

    I still kept the old windows in the windows.old folder so I searched for the driver files, copied them into a new WIN folder and installed that driver over the Device Manager. Still doesn't work, the Laptop does seem to have a key to turn wi-fi on or off, I tried both (LED red and white) but nothing seems to work.

    I'd be glad if someone could give me advice on what to do next
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Return to your system manufacturer's website and complete a comprehensive driver update for your specific model and operating system, paying paticular attention to chipset, and bios updates but you may as well get them all while you're about it. While windows 7 may include some of these drivers natively and device manager may not be indicating any problems with the devices in some cases the manufacturers drivers may support more complex hardware inter-dependency and provide more robust solutions than native drivers.
     
  3. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Yes, I understand, but there may be an issue with other hardware devices that may be required to support the proper functioning of the network adapter (like the chipset driver).
    There are also some other support software packs that include things like Quick Launch Buttons, I don't know if the function of the wireless adapter on/off button is incorporated into this software or not. There is also a Operating System Enhancements pack that seems to include fixes and enhancements specific to your computer for Windows 7, "These fixes and enhancements are required to improve the performance of these notebook/laptop models". That's why I suggested you might want to do a comprehensive upgrade from their support site.
     
  5. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    Yes I just thought the same, I now installed the audio, graphics, chipset, keyboard and OS enhancement driver, every key works fine now, but there is still the x above the wifi symbol

    edit: and the quick launch button software. Would it make sense to installe the BIOS update?
     
    #5 doesitoffendyou, Nov 1, 2010
    Last edited: Nov 1, 2010
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    When you open the network and sharing center, do you see your wireless connection? How is it defined? Have you attempted to run the network troubleshooter to see if that provides any insight?
     
    #6 Trouble, Nov 1, 2010
    Last edited: Nov 1, 2010
  7. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    If I try to connect to a network, it doesn't show any networks at all and the troubleshooter just claims that there is no ethernet cable plugged in.

    edit: I'm pretty sure the problem can't be the drivers, since I installed all. Also not the firewall because I didn't install any anti-virus software yet...
     
    #7 doesitoffendyou, Nov 1, 2010
    Last edited: Nov 1, 2010
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If you type ncpa.cpl into the search box and hit enter, do you see both your wired and wireless adapters present?
    Open a command prompt and type ipconfig /all copy and paste the results into the next post.
    Open device manager expand network adapters, right click the problem wireless adapter and choose properties, select the details tab change the drop down to Hardware Ids, right click in the Value box and choose select all, right click again and choose copy, paste the results into your next post also.
     
  9. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    When I type that in I see two things, a Braodband Connection icon which says disconnected (WAN Miniport PPPOE) and a Local Area Connection icon which just says Network cable unplugged. Here the other stuff

    [​IMG]

    Code:
    PCI\VEN_10EC&DEV_8136&SUBSYS_1605103C&REV_02
    PCI\VEN_10EC&DEV_8136&SUBSYS_1605103C
    PCI\VEN_10EC&DEV_8136&CC_020000
    PCI\VEN_10EC&DEV_8136&CC_0200
    
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    OK, it seems that one of us is confused. It doesn't seem that you have a wireless card installed at all. So in device manager do you actually see under network adapters, something that references a wireless network adapter. Or do you see any Yellow Exclaimation Marks or other symbols that might indicate a problem device, specifically something like "Other Devices". The hardware IDs you provided is for a realtek fast ethernet controller, not a wireless controller. Re-checking you computer specs. I think you've missed a driver, it seems you have potentially one of two wireless adapters either a RaLink RT3090 or an Intel PRO/Wireless, the realtek drivers are actually for your wired connection.
     
  11. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    ok the confused one was obviously me, thank you for clearing that up. And yes, now that you mention it, there is a yellow exclamation mark for other devices, I'll try to find a driver for my wireless adapter.
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    The link you provided in an earlier post has both potential drivers, I'm just not sure which one is installed, my guess would be the intel, but I could be wrong. Is there any documentation or stickers on the computer, box or paper work that may give you a clue.
     
  13. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Chances are the driver install will determine if there are any supported devices and will just fail to install if no devices are found.
     
  14. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    It seems like this happened, is there any other way to install the driver manually (if I do it through the device manager I have to provide the path of the drivers WIN7 folder)

    edit: hm strange, if I view the physical devices in Everest it only shows the Realtek RTL8139 Ethernet Adapter and a Network Controller but nothing that would implicate the Intel PRO or Ralink wireless adapter..
     
    #14 doesitoffendyou, Nov 1, 2010
    Last edited: Nov 1, 2010
  15. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Yes, typically you will want to download the software package to a folder on your computer and then use a utility like 7zip to unzip it's contents.
    Then in device manager, right click the problem device and choose update driver software, then click browse my computer, then choose let me pick, then click the have disk button, then browse to the folder where you have download and extracted the driver files.
     
  16. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    Ok, I tried to unzip the .exe from the Intel PRO driver, it didn't had any useful files...there are a lot of other files in the folder but I don't know which ones to use (tried to search for a couple in windows.old folder). The other driver (Ralink) has two .rar files which I both can't access, neither with 7zip nor with WinRar. Is there any other way then with Everest to find out my wireless adapter and download the WIN7 folder off the internet?

    edit: here is a screenshot of Everest and the Intel PRO driver folder
    [​IMG]
     
    #16 doesitoffendyou, Nov 1, 2010
    Last edited: Nov 1, 2010
  17. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    I also tried running the BIOS update, that didn't help either. Also there seems to be no product information out there that specifies the wireless adapter. I can't get the information out of Everest or the Windows 7 system information. Furthermore I tried to copy the xx64.cat, xx64.sys, xx64.inf and xx64.dll files out of the Intel PRO wireless driver folder into a new WIN/64 folder and use this folder as the the option for the manual update via the device manager...that didn't work either. I don't know what to do any more...I probably try to reinstall Windows again tomorrow but I don't think that's gonna solve anything...
     
  18. TorrentG

    TorrentG Banned

    Joined:
    May 31, 2010
    Messages:
    7,814
    Likes Received:
    372
    Right click it in device manager. Properties. Details tab. Change dropdown to hardware ids. Copy/paste the 4 lines of results below to here.
     
  19. doesitoffendyou

    doesitoffendyou New Member

    Joined:
    Nov 1, 2010
    Messages:
    26
    Likes Received:
    0
    I suppose you mean the hardware ids of the unknown network controller. Is there any possibility to boot the pre-installed version of Windows 7 back?

    Code:
    PCI\VEN_10EC&DEV_8171&SUBSYS_1467103C&REV_10
    PCI\VEN_10EC&DEV_8171&SUBSYS_1467103C
    PCI\VEN_10EC&DEV_8171&CC_028000
    PCI\VEN_10EC&DEV_8171&CC_0280
     

Share This Page

Loading...