ODBC32.dll is either not designed to run on Windows or it contains an error. and also several other

So today my laptop could not start up for some reason. I had to make a restore CD from my desktop (also a windows 7) and use it to repair my laptop. After it repaired my laptop, when I log in i get this ODBC32.dll error. This also occurs when i try to run certain programs, how do i repair this? For example one program i use called ultrasurf (web surfing proxy) no longer works after this startup repair and i get the error stated in the title.

Another problem i have is that the wireless network i have has now became limited access for no reason? I am still able to use the internet but for some reason it is limited access.

A third problem that has also occured is that i can no longer print things from my printer (since it is connected to my network). In my network and sharing center it says "the dependency service or group failed to start." This is in the spot where it would normally have the network map.

i would like to do a system restore, but there are only 3 restore points all of which are after the problem started occurring, so i cant even do a system restore.
For some reason I can still use the internet even though it says im not connected and my wifi network is "limited access". I will be heading to college next year, so im worried that i may not be able to connect to other wifi networks, and would like to get this "limited access" issue resolved before then.

Also I only want to do a factory setting restore as a last resort, any idea how to fix these problems, or even how to attempt a proper system restore (without losing all my files).



Excellent Member
Microsoft Community Contributor
Have you tried running a System File Check? I think that is normally done during a Startup Repair, but you might try to see if it will repair those files. If it gives you a files could not be repaired type message, let us know.

Also, since you seem to have corrupted files, running a Chkdsk would not hurt.

To run an SFC, open an Administrative Command prompt window and type SFC /scannow and let it finish.

Hi Saltgrass,
Thank you for your response. I have attempted running the SFC /scannow command on my administrator command prompt however when I click enter after typing it in, the cmd displays an error message saying "Windows Resource Protection could not start up the repair service".
I ran the chkdsk and it didn't find any "bad files" however it did mention something about some orphaned files but it automatically closed out after the chkdsk finished so I was unable to write it down.
Is there anything else I can do?



Excellent Member
Microsoft Community Contributor
The only time I have seen the SFC not run was when the TrustedInstaller had been removed. You might check the Task Manager, or even better, the services.msc and see if it is listed and if it can be started.

If your system has been corrupted, the TrustedInstaller may have been involved, but you might also have a virus. You can run the SFC from offline so it will check the drive. See the link to show how to do this. If you cannot get into the WinRE command prompt, we will have to find a way for you to do so. And you can check just the TrustedInstaller to start if it seems to be a problem.

How to Run the System File Checker (Sfc.exe) Offline in Windows 7 and Vista - The Winhelponline Blog

The CBS.log in the c:\Windows\Logs\CBS folder contains log entries about the failed attempt to run the SFC, but it is a large file and you may not be able to pinpoint the problem.

I have checked the services.msc (well i believe its the services.msc, I simply searched services and a program came up called "Services". I did not see anything called "TrustedInstaller".
I also looked at the link you provided, but I can't find my Windows 7 setup disk, are there any other ways to run the WinRE command prompt if I don't have the setup disk?



Excellent Member
Microsoft Community Contributor
The TrustedInstaller is referenced that way in the Task Manager, but shows as Windows Modules Installer in Services.msc.

If you do not have a Repair CD, you can download the Windows 7 .iso file from this link.

Download Windows 7 ISO (Official 32-bit and 64-bit Direct Download Links) « My Digital Life

None of this might help. You may still have to re-install because of the corruption.

First of all, I am sorry if this counts as gravedigging. I encountered the same problem two days ago and was fortunate enough to solve it today. Here is what I did:
1) I downloaded ODBC32.dll from odbc32.dll free download - DLL-files.com.
2) After performing a backup of my own ODBC32.dll, I copied and pasted the ODBC32.dll I downloaded into the System32 directory.
3) A message now began to appear whenever I executed an application such as Microsoft Paint: "The ODBC resource DLL (c:\windows\system\odbcint.dll) is a different version than the ODBC driver manager (c:\windows\system\odbc32.dll)." I downloaded the latest version of Microsoft Data Access Components (MDAC) from Microsoft's official website, which was 2.8 SP1: MDAC Downloads
4) I unpacked the archives contained within the downloaded file (MDAC_TYP.exe) into a new folder and began to install each .inf by right clicking them and then selecting "Install".
5) I rebooted my PC and the problem was gone.
I hope this helps anyone who might experience this or a similar issue.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.