One or more activex controls could not be displayed because either

Discussion in 'Windows 7 Help and Support' started by IT Fachbereich, Nov 2, 2010.

  1. Nathan Johnson

    Nathan Johnson New Member

    Joined:
    Jan 26, 2011
    Messages:
    2
    Likes Received:
    0
  2. Palindrome

    Palindrome New Member

    Joined:
    Feb 10, 2011
    Messages:
    4
    Likes Received:
    0
    Absolutely accurate and correct, thanks for sharing Snoggins. Deleting the invalid "L" zone from the registry will fix the ActiveX error. I'm also unsure if it was created by updating Adobe's Flash Player plugin, but looks plausible.
     
  3. Joe Phillips

    Joe Phillips New Member

    Joined:
    Feb 20, 2011
    Messages:
    2
    Likes Received:
    0
    OK....I do not have an L zone in the outlined regedit directory? Adobe Flash 10 does not work in IE, Firefox, Google Chrome and although I can see the installs in control panel/programs for Adobe Flash Player 10 ver 10.0.12.36, Adobe Flash Player 10 ActiveX ver 10.2.161.23, and Adobe Flash Player 10 plugin ver 10.2.152.36 I cannot seem to find these programs anywhere else including when type them in the the windows program search box?????
     
  4. Palindrome

    Palindrome New Member

    Joined:
    Feb 10, 2011
    Messages:
    4
    Likes Received:
    0
    Microsoft Windows XP, Vista and 7 can be installed as 32 or 64-bit systems (but not both, unless you want boot nightmares). If you install the x64 platform, you have two IE browser modes, 32 and 64-bit. Adobe Flash Player plugin only supports the 32-bit mode and very few websites support 64-bit browsers at all.
    Same applies to Mozilla FireFox. Even if you can install the 4.x beta 64-bit version, Flash Player is not supported as a native 64-bit plugin.

    The general consensus and best advice is to use Windows 64-bit OS but have all common applications installed in the x86 (32-bit) mode for compatibility reasons. You will see in the Windows x64 folders that Microsoft created a compromized hybrid folder structure: %\Program Files, %\Program Files (x86), and %\Windows\SysWOW64.

    The same applies for all the OCX's ActiveX files. They must be in the correct folder and associated to the correct bit mode. The "L" registry control set is a corruption created by misplaced x86/x64 utilities and plugins usually by legacy installers.
     
  5. midirium

    midirium Senior Member

    Joined:
    Mar 15, 2011
    Messages:
    10
    Likes Received:
    0
    Snoggins, you're a genius. Your solution resolved my problem related to the displayed text that I was typing in Yahoo Messenger, which I couldn't see before this. I don't know if I'm still having a script problem or an ActiveX problem. At first, I was tracking this topic to fix my BitDefender interface, which appears to be broken because the message in the topic's title. I'm gonna verify if I still have a problem.
    PS: two days ago, I had some viruses that I've removed with my previous antivirus program, which I've now replaced with BitDefender, who still does not display its windows properly.
     
  6. sivap10

    sivap10 New Member

    Joined:
    Mar 23, 2011
    Messages:
    2
    Likes Received:
    0
    Thank You, Snoggins. The solution worked like charm.[​IMG]

    Thanks for Sharing[​IMG],

    --------------------------------------------------------------
    me on Windows 7 Enterprise 32 bit for AMD Athlon X4 635
    --------------------------------------------------------------
     
  7. Sky Walker

    Sky Walker New Member

    Joined:
    Apr 11, 2011
    Messages:
    2
    Likes Received:
    0
    Thank you very much for your good method to resolved the problem It's very great and let my scanner come to work again ^^


     
  8. xchange

    xchange New Member

    Joined:
    Apr 20, 2011
    Messages:
    2
    Likes Received:
    0
    i have same problem like the first people, andi i have attach the information below. please help me......:(
     

    Attached Files:

  9. nano2k

    nano2k New Member

    Joined:
    May 4, 2011
    Messages:
    2
    Likes Received:
    0
    Worked for me, thanks a lot!
     
  10. theanonymy

    theanonymy New Member

    Joined:
    May 28, 2011
    Messages:
    2
    Likes Received:
    0
    @ Snoggins:

    I've registered solely to tell you that you are a gentleman and a scholar! I'd kiss your hand, if you were close by.

    Literally tearing my hair out and losing sleep for 2 days over this stupid thing; thank you SO much Adobe! I believe you are right about that; it's the only thing that's been hounding me lately to update, grr! What is refreshing and enlightening, however, is that there seems to be NO way to 'enable' ActiveX once it's been 'disabled' in your services! I could not even type a single letter into command-prompt; any key shut 'er down immediately. Really, Microsoft? For all the troubleshooting, etc. in Win7, this seems a little out of place...

    ...er, sorry; likely the frustration of the past two days and nights; I've been obsessed like a woman possessed!

    Anyway. My psuedo-graphic was a perfect, tiny square....but same shiz, regardless. I'd actually noticed it there yesterday, and thought "wait, what?"...but did not see anything in my extensive searching online that indicated it was actually odd. Only when I'd typed in the entire error message now out of a last-ditch desperation attempt before killing myself did I come upon (yet another) thread on the same exact problem....and found YOU. Bless you.

    Thank you again. Muah! *glee*
     
  11. Sophia Gross

    Sophia Gross New Member

    Joined:
    Jul 2, 2011
    Messages:
    2
    Likes Received:
    0
    Thank you very much, Snoggins! Worked like a charm. Even though the "L" was a little rectangle here.
     
  12. justtosaythanx

    justtosaythanx New Member

    Joined:
    Jul 15, 2011
    Messages:
    2
    Likes Received:
    0
    hello!

    I have registered just to say thank you to 2 people.
    Firstly to you, worldwide genius Snoggins, for solved problem.
    And second to you Nathan Johnson, for uploading your video on howto solve problem.
    I am such a newbie, that i would die without your video!

    for all such amaters - watch his video (http://windows7forums.com/windows-7-support/52363-one-more-activex-controls-could-not-displayed-because-either-3.html) .
    here Snoggins's solution at the bottom of the page(
    http://windows7forums.com/windows-7-support/52363-one-more-activex-controls-could-not-displayed-because-either.html)
     
    #32 justtosaythanx, Jul 15, 2011
    Last edited: Jul 15, 2011
  13. razedafear

    razedafear New Member

    Joined:
    Mar 4, 2012
    Messages:
    2
    Likes Received:
    0
    I have the similar issue bt dont see this extra "L" in my regedit. i disbaled mallwabytes and avast made all setting to low in IE still no change, I get this error evertime i start streamtransport. i cannot stream video in that because of this, tried reinstalling it did t work.
    Plz Help
     

Share This Page

Loading...