Override "best driver installed"

Discussion in 'Windows 7 Hardware' started by duxdad, Dec 1, 2011.

  1. duxdad

    duxdad New Member

    Joined:
    Dec 1, 2011
    Messages:
    4
    Likes Received:
    0
    I am trying to upgrade my Atheros wireless driver but I get the "best driver is installed. I have uninstalled the device and driver, tried a manual driver install. Each time it tells me it installed the old driver and will not let me install the new drver. How can I stop the automatic the automatic install of the old driver.
    Thanks
     
  2. Elmer

    Elmer Extraordinary Member

    Joined:
    Mar 5, 2010
    Messages:
    3,873
    Likes Received:
    284
    Hi duxdad and Welcome to The Forum.

    GoTo Control Panel and set the view to Small Icons. Then select Device and Printers. When you open Device and Printers a yellow options bar will slowly drop down, click on it. Then click on Open device installation settings.

    In the new Window that opens select No, let me choose what to do and Never install driver software from Windows Update.

    You can tick the Replace generic device icons box if you wish.

    Finally Apply Settings.
     
    #2 Elmer, Dec 1, 2011
    Last edited: Dec 1, 2011
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    If you are certain that you have the latest version of the proper driver downloaded and extracted to a folder on your PC, try this.
    Click the start orb and type
    device manager
    into the search box and hit enter
    expand network adapters
    select then right click your Atheros wireless adapter and choose uninstall, answer yes to the prompt to remove the associated software/drivers
    Then right click the computer device at the very top of the device manager tree and choose
    Add legacy hardware
    Click next
    the select the radio button that says
    Install the hardware that I manually select from a list and then click next
    Scroll down and select Network Adapters and click next
    Click the Have Disk button
    And use the browse button to navigate to the folder where you have downloaded and extracted the drivers you want to install.
    Find the appropriate .inf file and double click it and complete the install process.
    And then do what Elmer has suggested regarding preventing the Windows Update Utility from installing unwanted drivers in the future.
     
    1 person likes this.
  4. duxdad

    duxdad New Member

    Joined:
    Dec 1, 2011
    Messages:
    4
    Likes Received:
    0
    Thanks all for the help.
    I ran into an unexpected problem. When I point to the folder containging the .inf file it does not pick/show the device. Idownloaded an earlier version and had the same problem. Is there any security setting I am missing?
    I am trying to install an upgraded driver for an Atheros AR5009 beyond what HP has
    Thanks
    P.s I did notice there are two .inf files, a 32 bit and 64 bit. Could that be confusing?
     
    #4 duxdad, Dec 8, 2011
    Last edited: Dec 8, 2011
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sounds like perhaps you have not extracted the archive file. Or perhaps you are not browsing deep enough into the extracted folders?

    I suppose it might be a bit confusing, you need to determine which file you need based on which version of Windows 7 (32 or 64 bit) you have installed. But if you can see the .inf files then just double click on the correct one.
    netathrx.inf =64 bit
    netathr.inf =32 bit
     

Share This Page

Loading...