PC not matching download speeds of other devices on WiFi

AnybodysGuess

New Member
Hello folks,

The machine in question - a Windows 10 Home PC desktop, (Version 20H2 (OS Build 19042.870)), virus scanned running on a Core i7 8086K with 32GB RAM and a GTX 1080ti - cannot seem to get remotely close to the download speeds of any of the others PC and devices on my home WiFi network.

The internet plan is capable of 800Mbs and every other device including phones, iPads and two other windows PC’s can happily and instantaneously achieve upwards of 500Mbps (depending on the usual variables) yet this one particular PC struggles to surpass even 100mbps sometimes. This is despite the fact that it shares a desk with another PC, is located 12 feet away from the router, line-of-sight of it, and the other PC smashes it on speed tests at the same time. Sometime it’s seems as though this particular PC is “throttled” because it will top out at a particular speed and stay at that speed during the test, as opposed to erratically increasing and decreasing (which it occasionally does). However, when connected via Ethernet to the router speeds are perfectly normal.

I have always noticed that the speed on this PC (2 1/2 years old) was a little lagging behind the others but it wasn’t until I upgraded my internet package that a realized the true extent of the problem. I intend for this machine to be the backbone of my new business that I’m setting up so this is the one I’m relying on.

I’ve have done/tried the following:

updated all drivers
run multiple virus scans with different antivirus software
disabled antivirus
disabled and re-enabled adapters
reset network settings
run tests from different test providers
run tests on different browsers
run tests on the ookla windows app
purchased several other USB wifi adapters of various shapes/sizes (all returning the same limited speeds)
moved the PC location and orientation
moved the router orientation
received a brand new router from the ISP
reinstalled windows (clean installation)
done a remote support session with manufacturer (CLX - tech admitted he wasn’t an expert in this field)
done a tech session with the ISP (comcast - limited value)
various other tinkerings per advice on the web

None of which have worked. I’m at a loss. This machine functions perfectly normally in all other regards, is lightning fast for what I use, has only limited software of my choice installed on it (no manufacturers bloat ware etc).

I am wondering if the machine is throttling itself of whether the router is doing it. If it is doing it itself what component could I consider replacing? if it’s the router what could be looked at there?

Really, sincerely appreciate any advice, hints, tips or suggestions. I’m reasonably fluent at performing basic computer maintenance but not super knowledgeable by any means (obviously).

Thanks in advance.
 
Last edited:

Neemobeer

Cyber Security Engineer
Staff member
How old is the PC? What type of wireless NIC is in the device?

You can also run the following and paste the output. You can remove SSID and Profile if you don't want to show your network name.

netsh wlan show interface
 

AnybodysGuess

New Member
Hey Neemobeer,

Thanks so much for the reply.

The PC is a late 2018 build. Its actually nearly 2 years newer than the other PC with which it cohabits the desk and which can get sometimes 5 times the download speed.

This morning a ran some further speed tests using the Ookla app. Here are the results:

The PC with the issue:

Ping = 16ms
Download = 11.80 Mbps
Upload = 23.98
Server = Comcast, Miami FL

The other PC without the issue:

Ping = 13ms
Download = 293.76 Mbps
Upload = 23.56 Mbps
Server = Comcast, Miami FL

Various other devices reporting 200 - 300 Mbps

As per your question here is what cmd came up with (p.s, "Wi-Fi 4" is just the particular USB I have hooked up at this time - they all get the same speed):

There is 1 interface on the system:

Name : Wi-Fi 4
Description : Realtek 8814AU Wireless LAN 802.11ac USB NIC
GUID : 7d78e9db-9733-46bf-be4d-3f059a95e300
Physical address : 1c:bf:ce:45:0a:ec
State : connected
SSID :
BSSID : ac:db:48:82:f5:1a
Network type : Infrastructure
Radio type : 802.11ac
Authentication : WPA2-Personal
Cipher : CCMP
Connection mode : Auto Connect
Channel : 44
Receive rate (Mbps) : 1300
Transmit rate (Mbps) : 1300
Signal : 100%
Profile :

Hosted network status : Not available

Many thanks
 
Last edited:

Neemobeer

Cyber Security Engineer
Staff member
Make sure metered connection is not enabled.

  1. Press [Windows key + i]
  2. "Network and Internet"
  3. Status
  4. "Data usage"
  5. "Enter limit"
  6. Make sure it says 0
and 1,2 then
  1. Wi-Fi
  2. Manage Known Networks
  3. Select your network SSID
  4. Properties
  5. Make sure "Set as metered connection" is off
 

AnybodysGuess

New Member
Hi Neemobeer,

Thanks for the suggestion. Metered connection data usage limit was set to "0" per the first step and metered connections were already set to "off' per the second step.

Incidentally a Comcast engineer visited today and tested the service and it is confirmed that I'm getting good service to the address so this officially rules out any shenanigans from a service point of view.
 

AnybodysGuess

New Member
No VPN ever on the machine. Didn’t know what Hyper-V was so I googled it and I’m 99% sure not. I certainly didn’t set it up and I’ve had a recent fresh installation of Windows do I guess I’d be more than aware if I had that configuration.
 

AnybodysGuess

New Member
Hey Neemobeer,

Thanks for sticking with this and being persistent - I appreciate it.

As far as I am aware there is no QoS. It’s the latest Comcast Xfinity gateway (tall white one) and it should be operating at default settings (whatever they are) because I personally have made no alterations. Presumably, to set up a QoS priority I would need to proactively do that myself as it wouldn’t come as standard, correct?

The same applies to traffic shaping - nothing installed on any machine or device to my knowledge, certainly none of my choosing.

The PC has had recent and clean install of W10 on it - a full wipe and start again install - and I haven’t downloaded or installed anything that, to my knowledge, requires heavy network use. It isn’t a “branded” PC and it didn’t come with any bloatware.

The security suite running is the standard embedded Microsoft suite (firewall, anti-virus etc) which is up to date. I have also fully disabled it during testing to see if that helps but it does not. I have also run, on previous occasions, Malwarebytes in the event there was malware that was not getting detected. Nothing found. Malwarebytes is not installed since the latest clean installation of W10.

Back to the gateway/router for a moment, this is the third gateway I have had from the ISP since starting service with them (the first one went bad after a few weeks - unrelated symptoms) and the problem PC has always been slower on all of them compared to all other devices.

Yesterday I only managed an average of 50mbs on the PC while other devices averaged 450mbps Including the older PC in the same location as this one.
 

Neemobeer

Cyber Security Engineer
Staff member
As a test try booting into Safe Mode w/networking and test. This should prevent most things from running that may slow down the connection.
 

AnybodysGuess

New Member
As a test try booting into Safe Mode w/networking and test. This should prevent most things from running that may slow down the connection.
I did try that. However it appears that safe mode with networking disables the WiFi adapter(s) or at least that’s the message I saw when trying to connect.
 

AnybodysGuess

New Member
Further to this issue I can report that after purchasing and installing new Wi-Fi card and uninstalling the original one I have gained a significant improvement - but it is by no means up there with the other devices including the older PC as I'm still seeing about 1/3 performance.

I did NOT install the Bluetooth drivers that came with the new card as I had read sometime ago that somebody had discovered a similar issue and it was found to be a conflict with that, or so they claimed.

One particularly odd thing is that my location services are screwed up. I had not really noticed this too much but after the new installation of windows recently (in which I deliberately did not enable location services during setup because I had read somewhere that too can slow download speeds) the clock was wrong and I could see it was on the wrong time zone. I have to manually set the time zone now beacue auto-detect thinks I'm somewhere else.

More odd was that my location - with location services fully enabled - on the map showed the PC to be in somebody's house in a different city in a different state. This got my attention a bit since I recall several of the speed tests picking this location for the server. I'm intrigued by this because if it were a random system induced lat/long location the chances of being placed at a particular house are remarkably slim so could there be a conflict of some sort.

I wonder if this is related to or part of the problem or maybe it is a common issue, I haven't researched it yet?
 

AnybodysGuess

New Member
Have you tried restarting the router if you are using any? Or maybe you should troubleshoot it to fix the problem.
Yes, wilfred24, I have - both of those countless times. I have had a Comcast engineer home visit, not to mention several phones calls with them and two remote diagnostic sessions with the original manufacturer. I think we can safely say the issue is not with the service itself since all the other connected devices are achieving the expected speeds.

Per my last post I seem to have had some degree of success with a new Wi-Fi PCIe card (whereas I had no success with several different USB adapters) but it is by no means a complete solution and I am still testing it in day-to-day performance.

Thanks guys for all the help. If anybody has a theory on the incorrect time and location issue - particularly if you suspect it might tie into my original problem - I'd be glad to hear.

Thanks,
 
Last edited:

bochane

Excellent Member
Open the task manager during an internet speedtest.
Is there a task using 100% of a resource (cpu, memory, diskload...)?
Or is it just 100% load of the network?
Or not even that, just doing nothing?
 
Last edited:
Top