Please help: file system corruption but run check disk takes me to system restore and restore right

#1
When I start up my computer it shows
NTFS volume label Acer C
can't run due to error in recently installed software (I haven't installed any software in a long time, I have however gotten a new Targus High Speed SD/SDHC/MMC Card Reader/writer, which the software auto installed by windows) the only other thing that I did new around the same time that this started was use a USB flash drive)
use system restore feature
file system corruption

windows detected file system corruption on Acer C you must check the disk for errors before it can be restored.
I ran a checkl on the hard drive and it came out fine (no problems were found on device or disk, it is ready to use)
Then I tried system restore but it tells me I must run disk check so I run disk check again but everytime I try to restore it won't allow me to.

I have a backup/recovery disk that I made right after upgrading to windows 7 and I tried to do a recovery from that and nothing happens
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.