Printer woes

#1
Hello, after reinstalling Windows 7 I have a problem getting my HP Photosmart 7150 printer, which previously worked fine, to install.
I have tried every which way including via Device Manager in the Control Panel, which reports that the printer is indeed installed and working
while, when I try to print a document, MSWord says "No printers are installed"
.

What to do? Please help as I am completely stumped :confused:
 


reghakr

Essential Member
#2
When you go to Start Printers & Devices, does it show up here?

From what I understand HP will not be releasing Windows 7 drivers until the RTM is released.
 


#3
Woe is me...

When you go to Start Printers & Devices, does it show up here?

From what I understand HP will not be releasing Windows 7 drivers until the RTM is released.
1) Yes, it does show up, but with a red exclamation point (!) helpfully indicating some non-specified error

2) Is that so, but before I reinstalled Win7 RC1 a few days ago following a hard-disk crash, the Vista driver worked just fine. Now, for some reason, Plug n' Play doesn't work as far as the printer (everything else works A-OK) and that's what messes things up.

I even tried a spare connection cable so as to exclude that as the problem. If the printer had an LPT1 port (which I don't think it has) I could go 'old skool' and attach it to the PC:s LPT port.
But...
...right now Im so sick of it I'll give myself a couple days off and not even think about it...thanks for your input tho REG HAKR! :cool:
 


reghakr

Essential Member
#4
Sometimes USB printers will choose the wrong port.

Right-click on the printer and choose properties, now click the Ports tab and make sure it's set to USB001.
 


#5
Sometimes USB printers will choose the wrong port.

Right-click on the printer and choose properties, now click the Ports tab and make sure it's set to USB001.
Right, thanks, I will try that but I won't get to it 'till tomorrow, about 24 hrs from now. I'll be in touch :)
 


#6
Hi, because of some other issues I have had to reinstall Windows 7 since last post, now the printer isn't even recognized (Windows found new...) when I plug it in for the first time since reinstalling on a reformatted partition.

So, it just gets better and better ;) I think I will have to hunt down some techie at Hewllett-Packard via chat and see what they have to say (as if I didn't know: buy a new printer...)
Bye for now :frown:
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.