Problem Installing Windows 7 RC on EFI disk with MBR

emuu

New Member
#1
I have a new Sony Vaio laptop running Vista x64. It's a Sony motherboard with an EFI setup using InsydeH2O software (in place of BIOS, as I understand it). My HDD is currently in 3 partitions (a Sony hidden restore partition, my C: drive and a D: data partition).

When I try to install W7 RC 7100 I am unable to load the new OS onto any of my partitions, with the following message "Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks." Has anyone else come across this issue?

I haven't come across GPT disks before. Reading around I see I can convert MBR disks to GPT, but I'm confused about where my InsydeH2O software resides and don't want to format that away if I can avoid it ... or is it located in flash memory somewhere on the motherboard like BIOS?

Any help greatly appreciated.
 


#2
I have a Sony Vaio VGN-Z36GD and am having the same problem. Have you found a fix?
 


emuu

New Member
#3
Not yet, but I know it can be done... have a look at http://windows7forums.com/windows-7...vaio-vista-64-bit-latest-64-bit-build-w7.html . I haven't heard back from TanMan, and I'm not brave enough to convert my HDD to GPT (which I think involves removing the Sony restore partition) without a bit of reassurance. Let me know if you make any progress.
 


Dirk

New Member
#4
I have a VGN-Z21Vn and encountered the same problem. Since I use this one for serius work, I will not delete the recovery partition.
Maybe there will be a solution soon.

Greets Dirk
 


#5
Same issue x64 EFI MBR and GPT

Hi all
Frustrating isnt it.
I have exactly the same issue since I have the same machine a Z series Vaio laptop, runnign vista buisness x64 seems they issue it with a system the Micrsoft arent going to be supporting in Windows 7 as they see it is "legacy" not bad for a brand new machine.
In trying to instal Windows 7 x64 as a clean instal I get
"Windows cannot be installed to this disk. The selected disk has an MBR partition table. On EFI systems, Windows can only be installed to GPT disks."

Here Microsoft say http://www.microsoft.com/taiwan/whdc/system/platform/64bit/64bitsystems.mspx
MBR Issues

MBR disks support only four partition table entries. If a user wants to create more partitions - a secondary structure - an extended partition is necessary. Extended partitions can be subdivided into one or more logical disks.
Only one extended partition can be present on any given drive, and the maximum number of logical drives is MAXULONG/4. All MBR disk partitions and logical drives must be cylinder-aligned, even on hardware RAID sets built from multiple different drives with no clear underlying physical geometry.
To protect GPT-partitioned disks from tools that only understand MBR - such as Windows Disk Administrator or Fdisk, which do not know how to properly access a GPT disk - each GPT disk has a Protective MBR, beginning in sector 0. This sector precedes the GPT partition table and contains one type 0xEE partition that spans the disk. The Protective MBR protects GPT disks from previously-released MBR disk tools such as FDISK or Windows Disk Administrator. These tools are not aware of GPT and do not know how to properly access a GPT disk.
Legacy software that does not know about GPT interprets only the Protective MBR when it accesses a GPT disk. These tools will view a GPT disk as having a single, encompassing (possibly unrecognized) partition by interpreting the Protective MBR, rather than mistaking the disk for one that is unpartitioned.

So heres hoping oneof us finds a workaround and ca post here to assist
All the best & Thanks

Found an asnwer to thisproblme at least for my machine so hope this helps you too
On this thread
http://forum.notebookreview.com/showthread.php?t=342562&page=5
They say as follows
You can force the Z to boot the Windows 7 setup disc in BIOS mode, versus EFI mode. Just hit ESC when booting up to take you into the EFI boot manager and select the DVD-DRIVE, versus the ACPI(....) string.

And this worked beutifully for me when I decided to dual boot, although it appears I wouldnt get tehe error if it was a clan instal either
My Machine a Sony Z Series VGN-Z36GD running Vista x64 and now running dual boot ith Windows 7 x 64
Thanks to the poster on the other forum Notebook Forums and Laptop Discussion - Powered by vBulletin for this solution
 


Last edited:

mcwc

New Member
#6
ascairns - thank you VERY much for posting this link to the solution. It worked great for me and it should work great for others in the same situation.

Once again - Thank You
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.