Processors Disabled"

Discussion in 'Windows 7 Hardware' started by seekermeister, Jul 26, 2013.

  1. seekermeister

    seekermeister Honorable Member

    Joined:
    May 29, 2009
    Messages:
    1,499
    Likes Received:
    85
    When I got to the Device Manager>Processors in my old Windows 7 installation, all 6 cores of my CPU have ! Marks on them, and the Properties of each has this statement listed:

    "A driver (service) for this device has been disabled. An alternate driver may be providing this functionality. (Code 32)"

    The drivers listed are all Microsoft signed and dated in a manner in which they appear to be native to Windows 7, and I do not remember ever attempting to install anything else. This problem has not occurred in the new W7 installation, so I'm guessing that there is nothing physically wrong with the CPU. Obviously the processors still work, or I wouldn't be able to boot to this system, but I'm wondering if this is the reason that the installation works much more sluggishly than the new installation?

    I have run Chkdsk and SFC, but neither report any problems at all, which it seems that they would if there was a problem with the installation. Running the automatic online update functions returns the result saying that the drivers are up to date. Anyone have any ideas of how to pursue this?
     
  2. Josephur

    Josephur Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Aug 3, 2010
    Messages:
    1,018
    Likes Received:
    125
    Try finding the chipset software for your particular motherboard, install it and see if that doesn't alleviate the problem.
     
    Mike likes this.
  3. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    If you have an Intel processor and chipset, get the Intel INF Update.

    If you use AMD you can get the chipset drivers here.
     
  4. seekermeister

    seekermeister Honorable Member

    Joined:
    May 29, 2009
    Messages:
    1,499
    Likes Received:
    85
    I have an AMD 1090T processor. I'm not sure that I ran that driver, so of course I shall, but one thing about those drivers that have always confused me is that regardless of which one is ran, it always displays a catalyst labeled interface, and then always displays an install wizard that says that it is going to install a graphics driver. Since my graphics cards are all Nvidia, of one kind or other, it is obvious that this driver isn't required, and may be harmful.

    I always close the installation when that wizard appears, and since it never says otherwise, I can only hope that it installed the other driver first. Is that a correct assumption?
     
  5. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Hi, these aren't Catalyst (video graphics) drivers. They're chipset drivers that usually offer extended support for your system like AHCI and USB. It should clear up some problems you may be having. There are other questions, like when did this problem start, have you installed anything new recently?

    If not, you may want to do a system restore and see if you still get the error you have now. Phenom II is relatively old, but if those chipset drivers are incompatible, the installer will let you know. There should be no question to install Catalyst drivers at all - that is not what these are for.

    Because your processor is an older model, I will be a bit surprised if this works for you. Make sure you click on the Windows 7 tab on that page before you download them. I'd see if that solves your problem. You shouldn't have to worry about Catalyst installation.
     
  6. seekermeister

    seekermeister Honorable Member

    Joined:
    May 29, 2009
    Messages:
    1,499
    Likes Received:
    85
    Okay, but if that is true, then why does the installation wizard only say that it is going to install a "graphics" driver, when I choose the one that only says that it is for the chipset, AHCI and USB, as shown in the screenshot below?
     

    Attached Files:

  7. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
    Not sure. I am using an Intel board here and cannot tell you off-hand. Give it a try and see what happens. Its not going to replace your video graphics card drivers if you're using NVIDIA. Similarly, NVIDIA motherboards have nForce chipset drivers and these are basically universal depending on your system. You could try getting the chipset drivers from your system manufacturer, but they may have stopped at some point updating them.
     

Share This Page

Loading...