Question regarding Nagle's algorithm.

Discussion in 'Windows 7 Help and Support' started by Redlines, May 9, 2009.

  1. Redlines

    Redlines New Member

    Joined:
    May 9, 2009
    Messages:
    6
    Likes Received:
    0
    I have Nagle's algorithm disabled in Windows XP in order to reduce my latency to certain games, can anyone guide me through disabling it in Windows 7? Thanks in advance. :)
     
  2. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    Welcome to Windows7forums.. :)

    I'm pretty sure this is what your looking for:

    SpeedGuide.net :: Windows Vista / 2008 Tweaks

    Scroll down about half way and you'll see the title Gaming Tweak - Disable Nagle's Algorithm

    NOTE: This covers Windows Vista and not Win 7 specifically but it should work for Win 7 as well since Vista and 7 are very similar "under the hood".. That being said, these tweaks are to be done AT YOUR OWN RISK! ;)
     
  3. Redlines

    Redlines New Member

    Joined:
    May 9, 2009
    Messages:
    6
    Likes Received:
    0
    Thanks for the warm welcome and the swift reply. I'll try this once I get home. Thanks again. :)
     
  4. Radenight

    Radenight New Member

    Joined:
    Nov 16, 2008
    Messages:
    4,525
    Likes Received:
    108
    No problem at all, Glad I could help! :) Hopefully it works out for you.. Be sure to post back and let us know how you made out.. ;)
     
  5. whoosh

    whoosh Cooler King
    Staff Member Premium Supporter

    Joined:
    Apr 15, 2009
    Messages:
    25,717
    Likes Received:
    380
    Welcome to the forum this way to :)

    Nagle's algorithm. Can seriously reduce latency in games . How about file transfers ? Do you disable it for normal day to day use or enable the algorithm ?
     
  6. Redlines

    Redlines New Member

    Joined:
    May 9, 2009
    Messages:
    6
    Likes Received:
    0
    Doesn't seem to work unfortunately, I created the TcpAckFrequency Dword value and set it to 1 and it didn't do anything. Another thing worth noting is that HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters doesnt seem to exist in vista or windows 7, so setting the TcpNoDelay value doesn't work. After googling a bit more it seems that Vista needed a hotfix in order to disable nagle's algorithm, perhaps Windows 7 is the same.
     

Share This Page

Loading...