Ralink RT61 PCI driver disappeared

Discussion in 'Windows 7 Networking' started by swordsusa, May 25, 2009.

  1. swordsusa

    swordsusa New Member

    Joined:
    May 25, 2009
    Messages:
    14
    Likes Received:
    0
    I had the Ralink RT61 driver and it was working well, it automatically downloaded with windows, I recently reformatted my computer though due to a virus and now it won't automatically download the right one. Every time it tries to download a driver for the wireless card it downloads a driver but not the right one so it doesn't work. error is that the device cannot start. I tried downloading the windows vista drivers but those either don't work or refuse to install saying that they only support the windows vista operating system... am in great need of drivers because there is no real way for me to keep my computer on a wire, i know they are out there because it worked for months earlier but not it doesn't work. running 7100 build.
     
  2. kevin from Chi-town

    Joined:
    Jan 11, 2009
    Messages:
    714
    Likes Received:
    8
    have you tryed updating through device manager? are you running 32 or 64 bit?
     
  3. swordsusa

    swordsusa New Member

    Joined:
    May 25, 2009
    Messages:
    14
    Likes Received:
    0
    reply

    I have tried updating, uninstalling, reinstalling, rolling back, and everything else from the device manager. running the 64bit version. can't run 32, core i7 processor.
     
  4. swordsusa

    swordsusa New Member

    Joined:
    May 25, 2009
    Messages:
    14
    Likes Received:
    0
    any ideas?

    Anybody got any ideas? done several clean installs and the driver software just doesn't work. Have done everything from control pannel and have downloaded drivers from website and used disc that came with the hardware. This wouldn't be nearly as confusing to me except that it did work until i reformatted...it just automatically downloaded drivers with the whosiewhatsie program. any ideas would be great, i had to buy a seperate USB drive but it kinda sucks and i would like to return it if possible...thanks
     

Share This Page

Loading...