Regedit won't run. Stuck with this for a couple of days now. Please Help.

#1
Just to be clear, it's not one of those usual things. I got Win 7 Home Premium.

CMD, Task Manager, all exe files and GPEdit works fine. Everything works fine actually - exept regedit just does not respond.

I have Nod32 and my PC is virus / malware free.

All I want is just access to registry editor.

Things I've tried already:

1. Tried just running as administrator (ofcourse)
2. Did sfc /scannow
3. A couple of different scripts to enable / disable regedit manually including the Symantec's script.
4. Changing Group Policy Settings (gpedit.msc of preventing access to registry editing tools)
5. CMD command "HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System" /t Reg_dword /v DisableRegistryTools /f /d 0 (ran as admin ofcourse)

No luck yet. Anyone have any ideas? Regedit just won't react. No errors, no pop ups, nothing. Silence.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#2
Have you tried to access it in safe mode?
 


#3
Yup, just did.

Tryed both with networking and without - same thing - no response. :(

Also, tryed creating new administrative account, also nothing.
 


Trouble

Noob Whisperer
#4
Have you tried running it directly from the Windows Folder, or.....
Have you tried running regedt32.exe directly from the C:\Windows\System32 folder?
 


#5
Yes, I did just now. Tried both Windows\System32 as regedt32.exe and Windows folder as regedit.exe

Still nothing :(
 


Trouble

Noob Whisperer
#6
Might be time to consider an in-place upgrade / repair as described here.
https://support.microsoft.com/en-us/kb/2255099
It's a pain, no doubt but a possible last resort if everything else that you've tried has failed.
It's generally non-destructive, so your programs, drivers and such should remain without issues, but....
I would perform a system image before proceeding.
 


Last edited:
#7
Oh my, this sounds like a last resort indeed. This is so frustrating :| Thanks for the help anyway
 


Trouble

Noob Whisperer
#8
Oh my, this sounds like a last resort indeed
Yep.... I believe I might have actually said as much.

Make a copy of regedit, then rename it to CopyReg (just so there is something prefixing the "reg" part.
See if that runs.
If it does, then....
you may not be as virus free as you might have hoped.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.