Remote Desktop Problems.

Discussion in 'Windows 7 Networking' started by Leturno, Jan 19, 2009.

  1. Leturno

    Leturno New Member

    Jan 19, 2009
    Likes Received:
    I can connect locally using Remote Desktop on my LAN from other computers, but not from work to my home PC. I have also tried connecting using my personal SprintPCS Broadband on one of my personal PCs, just to rule out problems with my network at work blocking necassary ports.

    I have enabled Remote Desktop allowing connections from any Remote Desktop 6.x client.
    I have ensured correct User Access Rights and Privelges.
    I have forwarded the appropriate ports on my router (3389).
    I have completely disabled all firewalls in attempts to find resolution.
    Port Scan shows no response on appropriate ports (3389).

    I have thoroughly researched this problem over the last two days and not found any working solutions. Any help would be greatly appreciated. Thanks.
  2. jimbo45

    jimbo45 New Member

    Jan 20, 2009
    Likes Received:
    Try the Simple things first.
    1) Some office (work) Lan's disable services such as RDP, FTP etc. First try and see if these services are blocked.
    2) if you have access to a public wireless lan such as in a hotel, wifi hotspot etc see if you can connect to your home computer through that. If you can then your office / work is blocking RDP
    3) can you PING your home computer -- you might need to set your home router to allow PING from outside (i.e the Internet).
    4) I assume that you either have a static IP address for your home computer or you are using a managed dynamic IP service such as no_ip etc.

    5) Change also the settings to allow RDP access from computers USING ANY VERSION OF RDP. Windows 7 might contain an "Unknown version" of RDP . I don't know but who always knows exactly what version of software is in a machine these days.

    Even if your work place IS blocking RDP you can still do it by a process known as Tunnelling. You need to download a free program called Putty and follow the documentation. Just Google for this as to set it up is more complicated that I've time for on this post.

    My "Gut feel" is that your work is blocking the RDP service via its firewall even though the port might be open.
    Sometimes another get around is to use the Web version of RDP (run it from your browser and point the address to your home computers IP use the :3389 for the port.

    If you have something like a "Mobile Connect" card try connecting via that also. If this works then it confirms your workplace is blocking the RDP service.
    #2 jimbo45, Jan 20, 2009
    Last edited: Jan 20, 2009
  3. psimmons1

    psimmons1 New Member

    Jun 13, 2009
    Likes Received:
    Try loggin in as COMPUTER NAME\USER NAME i.e petnet\peter this is how I got round the problem

Share This Page