Windows 10 Runtime Broker using high memory and cpu usage

#1
after upgrading to windows 10 my laptop fan always working fast ...
when i checked this issue, i see runtime broker in task manager with high resourse usage ...
when i click on end task, everything be normal... but runtime broker run itselft immediately ...
i googled this issue but i couldn't find a useful solution.
please help me to solve this issue ...


sorry for bad english :D
 


#2
Runtime broker can be disabled in Settings->System->Notifications & actions->Show me tips about Windows->Off
 


#3
Runtime broker can be disabled in Settings->System->Notifications & actions->Show me tips about Windows->Off
thanks dude ...
seems the problem has been solved! but i need to more tests ...
 


#4
You can also check if some default apps that you're not using are eating memory, I had the same problem so I used this 3 Clever PowerShell Functions After Upgrading to Windows 10. Also, I can see that my Runtime Broker isn't shut down but it's on 16MB which is not that much. We expect the next update to solve System/Runtime Broker eating CPU and memory.
 


#5
You can also check if some default apps that you're not using are eating memory, I had the same problem so I used this 3 Clever PowerShell Functions After Upgrading to Windows 10. Also, I can see that my Runtime Broker isn't shut down but it's on 16MB which is not that much. We expect the next update to solve System/Runtime Broker eating CPU and memory.
ops ... very useful link
runtime broker isn't shut down but it uses very low cpu usage (0%) and 4.5MB memory ...
 


#6
Yeah, just make sure you didn't disable apps from updating, certainly not Windows Store because it happened to me after I did this Store Cache - Clear in Windows 8, all the apps that I removed came back xD So basically, these links are answering current issues with Windows 10.
 


bochane

Honorable Member
#7
Here the same issue.

The Runtime Broker is consuming almost every CPU cycle and combines it with a sky high memory usage.
I switched of "Show me tips about Windows", rebooted and every thing seems to be normal, also the Runtime Broker is back to normal.
For a while

Found a mcagent running, removed all McAfee remains, but that was not the cause of the exploding Runtime Broker.
I have just the apps which come with Windows. I have 3 other PC's in almost the same configuration and almost the same programs installed, without Runtime broker trouble.

For now I have no idee how to find the cause.
I think I have to go back to W7

Henk
 


Last edited:

bochane

Honorable Member
#8
That was an easy one!

My wife uses Picasa. And she has a huge amount of photo's on our NAS, thousands!

As soon as she logged in and starting to use Picase, Picase started to rescan every directory and reported it back on the desktop.
I just had to remove the most of those directories from the Picasa search directories.

Happy W10 user again,
Henk
 


bochane

Honorable Member
#9
That was an easy one!

My wife uses Picasa. ........
Happy W10 user again,
Henk
Too early, did not work out. I am looking further into this:
- scan with Defender and Malwarebytes (I never had McAfee installed, but a mcagent was running...)
- check whether it it is only her account and not mine
- .....
 


Last edited:

bochane

Honorable Member
#10
After running scans, which in fact did find and isolated some malware, I tried again. And again after some time the Runtime broker went sky high up.

With my own account was nothing wrong.
Conclusion: the fail was local to the account, Windows was stil undammaged.

I backed up and removed completely that damaged account, than I recreated it, to be on the save side I used a different account name, followed by restoring the backuped data.
Job done, problem solved
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top