Services on startup... failing.

Discussion in 'Windows 7 Help and Support' started by hLVE, Dec 10, 2009.

  1. hLVE

    hLVE New Member

    Joined:
    Oct 8, 2009
    Messages:
    16
    Likes Received:
    0
    So I've recently noticed a problem with my Windows 7 x64 PC where whenever I rebooted, when it came back to the welcome screen it was staying there saying "Please wait," for a few minutes (not sure what it was doing, but it was doing it in safe mode too...) So I wanted to check my eventlog to see what the error was... because I was sure it was something that was probably looping over and over causing the please wait message.

    When I went into Eventvwr I got this error message when it began loading-

    "Event Log service is unavailable. Verify that the service is running"

    So, seeing that I immediately just thought to go in and enable my eventlog service, when I went in to services.msc to see what happened, I saw that it was "Starting..." and it was sitting there not moving at all.

    [​IMG]

    After seeing that, I checked its' dependencies and there are NONE! Though Task Scheduler, and Windows Event Collector both rely on this service to actually function. So because the Eventlog is not actually starting, I can't get my Task scheduler or my Windows Event Collector services to start.

    Event Collector
    (This one was a bit strange, because I don't have an HTTP Service that it's relying on to be able to start... but I don't recall ever even having an HTTP Service to begin with.)

    [​IMG]

    Event Collector

    [​IMG]

    ________________________________________________________________________


    So I'm without a clue what to do next!

    I've tried practically everything suggested from random people on Google (which is sometimes a bad idea, but I guess it's my normal way to approach things like this.)

    I'd LOVE to fix this problem (The problems opening the said services,) and I'd LOVE to fix the other problem that I first saw with the "Please wait" at the Welcome screen... because it never did that before.

    Below are the solutions that I've attempted. Nothing has cured this damn service problem, tell me what you think I should honestly try (and please don't say formatting. I can't afford that time lost... I mean, if I can't fix this, I'll have to but I'd really like to try any other possible method.

    ________________________________________________________________________

    Windows 7, I can 'Repair My System' ::I was excited that this could be my 'easy fix solution, and unfortunately it didn't really even help me. It said it couldn't find a problem with my PC when I tried repairing. I accessed the system based restore option (f8 before windows loaded.) When I tried loading from the CD to try to repair from that, it couldn't detect my Windows Installation to get into the repair screen, and it kept asking me to load the drivers for the sata drive... but I was able to actually browse my loaded windows directories to get the drive but couldn't find it. *Sigh
    ________________________________________________________________________
    SFC /Scannow ::
    Beginning verification phase of system scan. Verification 100% complete. Windows Resource Protection did not find any integrity violations.

    ________________________________________________________________________
    Rename These Folders (Auto-Creation At Boot) ::
    Saw that if I renamed the folders/files below, it'll recreate them at boot with the correct properties etc- ... this didn't do anything.

    ________________________________________________________________________

    System Restore? Why not
    ::

    Oh this was gorgeous when I tried this in safe mode. It pretty much just stayed at "Initializing Restore" for about an hour and a half before I was tired of waiting and just manually restarted my PC... This happened with every different restore date that it had available (which were only about 12 dates.) I didn't wait the entire hour and a half for the other dates, but after about 30-40 minutes I was tired of waiting... it shouldn't EVER take that long.
    ________________________________________________________________________

    Permissions For Registry Items ::
    Making sure the registry items below have proper permissions set for local service, administrators, system, and my username.
    [​IMG]

    ________________________________________________________________________


    Resetting The WMI Repository ::
    Stopped the WMI Service, and went to the windows\system32\WBEM\ and renamed the Repository folder... Rebooted and it didn't really change my error.
    ________________________________________________________________________

    Subinacl Reset Permissions ::
    Tried using subinacl to restore all orginal registry and Windows file/folder permissions... this didn't do anything but...
    ________________________________________________________________________

    A user called 'EventLog'
    ::
    Strangely enough, another post from some random forum on google suggested this...

    ________________________________________________________________________

    Winsock resetting? A lot said it worked! ::
    Netsh winsock reset, reboot, nothing at all. It seemed speed up my restart quite a bit but I was still unable to start the said services and STILL was my welcome screen on reboot taking a GOD awful long time.

    ________________________________________________________________________


     
  2. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    How about a restore point..

    Some dependency seems to be turned off, causing all these errors.
     
  3. tblount

    tblount New Member

    Joined:
    Sep 27, 2009
    Messages:
    3,537
    Likes Received:
    64
    First, you have done an amazing job of looking for solutions. If everyone made the kind of effort you have we probably wouldn't get more than 1 problem/question posted to answer per day.

    Here is my 2 cents

    Consider this page Event Viewer Service problem


    Nero and Nero have been caught causing this problem.
     
    #3 tblount, Dec 10, 2009
    Last edited: Dec 10, 2009

Share This Page

Loading...