Shared folder asks for password, despite no password being set.

Discussion in 'Windows 7 Networking' started by coatstorm, Jun 25, 2010.

  1. coatstorm

    coatstorm New Member

    Joined:
    Jun 25, 2010
    Messages:
    6
    Likes Received:
    0
    Hello all! I was hoping for a little bit of help with this problem. I've Googled for the last 45 minutes, tried a bunch of solutions, and searched this very forum, to no avail.

    I'm trying to share a folder on my computer (N:\TV, where N is an internal hard disk) on my local area network. Two media centers connect to this folder. Until this week, they connected just fine using no username or password. Suddenly, they want to know a password -- and even entering my Windows credentials (my user account being the only one on the machine), access is denied.

    • I've selected the folder I want to share, and viewed its properties. It's shared with Everyone for reading.
    • I can access the folder by opening \\Mycomputer\\TV in Explorer.
    • Network discovery is turned off.
    • File and printer sharing is turned on.
    • Password protected sharing is turned off.
    • All three machines are in the same workgroup.

    I'm out of ideas. If anyone could offer up a suggestion, it would be fantastic. Thanks!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Have you tried including the machine name hosting the share into the username box followed by a single backslash followed by the username and then the password for that user
    MachineNameHostingShare\UserNameOnThatMachine
    PasswordForThatUserOnThatMachine
     
  3. coatstorm

    coatstorm New Member

    Joined:
    Jun 25, 2010
    Messages:
    6
    Likes Received:
    0
    I just tried that. No luck, unfortunately. But thanks for the attempt. :)
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Sorry to hear that, that didn't work for you. I would highly recommend taking some time and downloading this document from Microsoft if you don't have a compatible version of Microsoft Word installed then use the .XPS version it should open with the built in XPS viewer in Windows 7. It does a better job covering most if not all aspects of sharing on Windows 7, with various client operating systems, then I could possibly include in a single post. It's pretty exhaustive, some 33 pages, but should help you overcome your issue and provides some alternative options which you may not have tried or even thought of. http://www.microsoft.com/downloads/details.aspx?FamilyID=80b1aa5d-1b5a-4447-8036-acc918ba7af2&displaylang=en
    Hope this helps
    Randy
     
  5. stpbby

    stpbby New Member

    Joined:
    Jun 23, 2010
    Messages:
    40
    Likes Received:
    0
    Try this...

    Control panel -> Folder options -> View -> uncheck "Use sharing wizard"

    Right click on the folder you want to share and go to properties --> sharing -> click advanced sharing

    Click the checkbox for "share this folder" (if this box is already checked, uncheck it and click apply and then re-check it and click apply, just to re-apply the settings)

    Click on permissions , you should see "everyone" listed, if you dont add "everyone", and choose the appropriate permissions

    Once you click apply, you should be able to browse to the folder without putting in a username or password
     
  6. coatstorm

    coatstorm New Member

    Joined:
    Jun 25, 2010
    Messages:
    6
    Likes Received:
    0
    No luck with either of those options. :(
     
  7. asasasasas

    asasasasas New Member

    Joined:
    Nov 29, 2012
    Messages:
    2
    Likes Received:
    0
    Security permissions.

    Apparently windows 7 has an annoyingly redundant permissions list that needs to be edited AS WELL AS setting advanced sharing permissions for a shared folder or drive. Both are tabs found in the properties menu. Under "security" and "sharing", respectively.

    After telling Windows that you want the folder shared with 'Everyone' in advanced sharing permissions. Click on the "security" tab of the properties menu. Click on the Edit button (obviously with admin rights). 'Everyone' will need to be listed in the section showing "Group or user names:". If 'Everyone' is not listed as a group you can add it by simply clicking the add button. A new window will open and you just type Everyone . Then click the "Check Names" button. This should recognize the user group 'Everyone' and underline it. Click "OK" You can now edit the permissions for the user group. Select 'Everyone' and adjust the Permissions list below it, checking the boxes that correspond with the sharing permissions.

    I hope I was able to explain what I did in a way that is easy to understand. I know this was a frustrating problem for me and I wish this info was easier to find.
     
    #7 asasasasas, Nov 29, 2012
    Last edited: Nov 29, 2012

Share This Page

Loading...