Shortcuts (.lnk) stopped working

#1
It began when my company's network suddenly wouldn't recognize my user/password to access the folders on the server. My network admin tried to reset my password and even created a new user for me. Inexplicably a new problem arose. Clicking icons on the desktop or the start menu stopped working. I found that opening the file location and clicking the .exe did work.

The problem remained when logging in as the local administrator.
I found that the problem occurs on all .LNK files.
System Restore to a month ago had no effect. Am I mistaken in believing that this proves that the problem isn't in the registry?
I did a full disk virus check using the ESET a/v software on the computer as well as with MalwareBytes. No effect.

Does anyone have any idea what to do? I'm out of ideas.
 


Trouble

Noob Whisperer
#2
The problem is generally associated with registry entries directly associated with the dot link (.lnk) file extension. Many people have reported successfully fixing the issue with the registry file that I've attached for your convience.
You need to extract the zip file which will produce one .reg file which you can double click and answer in the affirmative to the subsequent prompts.
As always whenever making any edits to the registry you should take steps to back it up, and manually create a restore point for safety sake.
Hope this helps
Randy
 


#3
I'm always amazed by people like you who are eager to aid strangers in need. Thanks. Unfortunately the fix didn't fix the problem. I checked the registry after logging off and on again and the changes in the file were there but it still doesn't work. I don't know if this helps, but when I try to run a .lnk from Total Commander I get the message: "Error executing program! (31)". There are no relevant messages in the event viewer, but apparently some error is returned when trying to run a link.

OK, so here's what I tried. I copied notepad.exe to c:\temp and created a link to it called c:\temp\notepad.lnk. Then I went into VB and created a console application consisting of the command shell("c:\temp\notepad.lnk"). Pressing > (debug run) returned FileNotFoundException. Changing lnk to exe opened a notepad window. What the heck is going on here?
 


Trouble

Noob Whisperer
#4
A stupid question I know, but I have to ask.
Did you reboot after you ran the .reg file that I included?
 


#5
I logged off and back on again, but just to be sure I'll do a shutdown and a cold boot now. Here goes...
 


#6
OK, so since the last post, I did a shutdown and cold boot (no change); I also went to safe mode (links work ok); disabled the a/v software (no change); and tried to find what tasks and services that are running in normal mode but stopped in safe mode could be causing the problem. I haven't had any luck yet. Any more suggestions?
 


Trouble

Noob Whisperer
#7
Sorry, been snowblowing....fun. Depends on your time to patience quotient. It can be a pain but you may be able to use the CleanBoot troubleshooting steps to zero in on the offending process.
If you create a brand new local user account with admin privledges, does that account inherit the same problem in normal mode?
Good luck to you and please keep us posted if you manage to resolve this issue. Others may have some more suggestions but I'm currently at a loss.
Randy
 


#8
No need to apologize. Thanks for trying.
 


#9
@Trouble - could you please re-post the registry file...?
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top