Windows 7 Sim City 4 Deluxe Edtion and Windows 7

Discussion in 'Windows Games' started by mas5707, Nov 20, 2009.

  1. frozz

    frozz New Member

    Joined:
    Mar 5, 2011
    Messages:
    2
    Likes Received:
    0
    I had problems with SimCity 4 on my Windows 7 64bit to. Solution was easy.

    1. Make a shortcut to simcity 4
    2. Right click on it and select Properties.
    3. Select the Compatibility tab and check Disable desktop composition (nothing more), then click on OK.
    4. Play :)
     
  2. tylerzie4

    tylerzie4 New Member

    Joined:
    Jul 23, 2011
    Messages:
    2
    Likes Received:
    0
    I got simcity to run on my VAIO laptop with few interruptions and rare crashes or freeze ups. One problem is that it would always lock up and freeze, making you restart the computer. I tweeked Windows to have the program run as administrator, disable visual themes, disable desktop composition, and disable display scaling on high DPI settings (all of these are the on the compatibility tab, to get to it, right click on the program, hit Properties, then click Compatibility). I also choose to run the compatibility for Windows 2000. (I tried Windows XP SP2 and SP3 compatibility mode with little to no success). After, the game did work better, but it kept on crashing too often. I then figured it may be the graphics card compatibility. I changed some settings with my graphics card (mostly from factory settings to what the application asks for settings), rebooted, and ran the game. The game ran so much better, I got about 3 hours in before another crash happened.
    Also, another tidbit is to lower the Shadow Effects in the Graphics Options within the game to "Low". I had less crashes when I did so. Also, try to keep the display in a natural resolution (such as 800x600 or 1024x768). My graphics card could easily handle keeping the native display over stretching it across my 1366x768 widescreen display. Yes the letterboxes on the sides do suck, but it's worth the full game experience with less crashes.
     
    #22 tylerzie4, Jul 23, 2011
    Last edited: Jul 23, 2011
  3. Chris Zuelsdorf

    Chris Zuelsdorf New Member

    Joined:
    Jun 1, 2012
    Messages:
    2
    Likes Received:
    0
    If you have Win 7 Professional, you could run Win XP mode... that would alleviate the compatibility problem!
     

Share This Page

Loading...