Windows 7 Sim City 4 Deluxe Edtion and Windows 7

I was wondering if there's anyway I could fix my problem. Right after I successfully install Sim City, the autorun loads up the game and I have a blast playing it. When I try to opem up the game to play everytime there after, nothing happens. When I insert the play disk, my computer recognizes it and 'thinks' for about 30 seconds, and nothing happens after that. When I open up My Computer and double click on the icon, absolutely nothing happens. I don't want to have to uninstall and reinstall it everytime I want to play it. Is there any settings I need to change or is Sim City even comparable with Windows 7. Any suggestions?

I should probably say that Windows 7 is 64 bit.


New Member
Unfortunately, SimCity4 (and SimCity 4 Deluxe) is not "fully" compatible with Windows 7. The errors you experience when attempting to run the game following installation are indicative of OS/game compatibility issues. Unfortunately running the game in "WinXP SP3 compatibility mode" will not yield any better results. This applies to both Windows 7 x86 and x64 versions of all releases.

There is quite a substantially extensive discussion on the compatibility issue at the forums of Maxis (game developer).

One reason why I kept WinXP on my laptop despite my employer's desire to upgrade my system to Win7 ... I like to have a go at the Sims while waiting for planes when flying around on business. :D

Last edited:
According to the windows compatibility center, Sim City is compatible with Windows 7.


New Member
Understood, but in reality SC4 really isn't "fully compatible".

The status of the game was set by Microsoft as "incompatible" throughout the Beta and RC period of Win 7 development and even until quite recently (before the official release this past October). The compatibility change on the Microsoft site was a rather recent change (occurred between late Sept and mid October). What's changed in the OS? Nothing really. The same version of the OS that went on sale Oct 22 was already available to MSDN subscribers since late August. So it's rather strange that Microsoft would change the compatibility while nothing's changed in the OS itself.

I've had the game for a long time and really enjoy it playing on XP. Tried the game on various versions of Windows 7 and have yet to enjoy a positive experience playing SC4... Tried so many possible methods; software configurations - game installation (plug-in/add-in incompatibility perhaps?), OS tweaking - administrator mode, compatibility mode, different OS versions (x86 v x64; Pro v. Ult); different hardware configurations ... Still get choppy play, crashes, game hanging, rebooting my system ... Weird.

Oddly enough, some folks out there experience no problems, yet the playing experience for the greater majority remains rather an elusive hit-or-miss proposition (mostly miss) and they contend with game crashes, graphics glitches, slowdowns, complete lack of responsiveness and other issues.

Not pleasant. :(

Been searching high and low for a solution to the various problems encountered when playing this game, but haven't found anything concrete yet.... unfortunately.

I heard by setting the game settings to run like Windows XP helps for some games. How would I go about doing this? Does this settings change apply for everything else, or just the game?


New Member
I heard by setting the game settings to run like Windows XP helps for some games. How would I go about doing this? Does this settings change apply for everything else, or just the game?
You don't really need VM (virtual machine) to run the game (that's a bit overkill)

You can try running the game in Windows XP compatibility mode using the following method:
- open windows explorer (either pinned to the taskbar or start/all programs/accessories/windows explorer)
- navigate to the location where you have SimCity installed, open the directory
- right-click the SimCity executable
- select properties
- select "compatibility" tab
- check the box "Run this program in compatibility mode for: "
- select Windows XP SP3 (or SP2) from the drop-down list
- on the same tab further down, check box (select option) "disable visual themes" (this disables aero which may conflict with certain software and/or games)
- on the same tab at the bottom, check the box "Run this program as an administrator"
- hit "Apply" & run the game

This method will allow you to execute the program (SimCity) in Windows XP compatibility mode.
By applying these settings to the SimCity executable, only that program will run in XP compatibility mode and the rest of your installed programs, indeed Windows 7 itself, will remain unaffected by the change.

Keep in mind there are no guarantees that the game will perform like it should though. Like I mentioned, I've tried this and numerous other methods to run the game but so far not much luck getting to run stable. Rather strange.

Hope this helps.

Last edited:
May have a solution

Hi, I too had several problems with Sim City 4 and in particular rush hour.
I could install sim city 4 and play (although it did quit if i over clicked) adn rush hour would freeze the computer forcing a reset.
I think i have finally found a solution.
1st install simcity 4 and run the program.
if you experience weird graphics with such as flickering, once on the region screen go to the graphics options, set the graphics to full/best and tick everything. set the resolution to 1280x1024. It will prompt that changes wont take effect until next time you start up. So exit out and start up. if all is good and no flickering etc. exit out of Sim City 4.
Next install rush hour. The game will then run and you shouldn't experience problems.
If you still have problems previous to rush hour installation, right click on the desktop icon and click compatibility. Disable visual themes and disable display scaling on high dpi settings and try to run again.
This is the fix that worked for me

I have the same problem. It sucks because I didn't search up on it before I bought it. I knew it was an old game, but would never have thought that it wouldn't work. But what is even worse is that I got the blue screen of death twice playing the game. I don't know why. Is it still win7 or maybe my graphics card?

I have the graphics set on high, highest resolution. Installed sc4 disc 1 and while installing it it said please insert disc 2 (probably the rush hour disc). I didn't get any options where I could wait with installing rush hour like the post above this, so can anyone help me? Is there anything I could do? No one posted that the solution post helped them, so the problems still out there for not only me? lol. I hope so. Is there anything I could do with windows settings (done compatibility mode), or contact windows, or something at all??

Appreciate any help! :)

Last edited:
There are 2 discs with SimCity 4 unless you got the dvd version. Rush Hour has only one disc.
When installing SimCity 4, if it asks you for disc 2, it does mean it needs disc 2 for simcity not rush hour.
If you downloaded this game, try finding simcity 4 disc 2 from where you downloaded from.
You need to install SimCity 4 completely (ie both discs) before you can install Rush Hour.

Simcity 4 has 2 discs (well my version has)
You need to properly install simcity 4 before you can install rush hour.
If you downloaded this from a torrent, search for Simcity 4 CD 2.

I have a legal version just bought it yesterday. I installed both cd's but it never came up with a choice to not intall rush hour. And it never said "installing rush hour". It just installed the whole game. I wish everyone with win 7 was experiencing the same problem, cause then EA would probably do something about it. New patch or something. I'm going to download windows xp mode. maybe that would help? :'(

It's ironic that I should hear that Sim City 4 is not "fully" compatible with Windows 7. I just thought I would add that Sim City 4 Deluxe Edition is the ONLY game I have been able to run on Windows 7 without any kind of problems. I have not been able to keep any other game running for very long without it crashing, despite the fact that they are supposedly fully compatible with Windows 7. But Sim City 4? No problems at all.

I believe that if the graphics options and effects are set too high the game will not load again. This is not as compatible since settings equivalent to cards and OSes several generations older are not possible. Resolution shouldn't matter much for real-time strategy. At least building draw speed needs to be lower. With care, the experience seems the same however.


Senior Member
Had this problem that when i started the game, it started but just went back to the desktop, pushed the game window, went in, but went back to the desktop after 1 sec.

My solution for that was to put -w in the shortcut. To do that, just make an shortcut on desktop, right click, properties, and click on shortcut tab, there you should see something called target: "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe". You should put -w behind that, like this "C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" -w push apply, then ok. then run the game. I also changed Compatibility to run this program in compatibility mode for win xp sp3, and disable visual themes.

The -w means that the game will run in window mode.
"C:\Program Files (x86)\Maxis\SimCity 4 Deluxe\Apps\SimCity 4.exe" depends on wich harddrive u installed it on.

I wonder if those 3 mods are needed, and for what, such as monitor resolution. I just realized that SimCity 4 Deluxe may be non-standard in having started from Disk 2 before. I need to click the start menu icon instead of the run.exe when the disk is inserted. Visually it is fine as is for me, but it might be better with compatibility?


Senior Member
as far as i can remember, it has always started from disc 2. If the game runs fine, there is no need to do anything rly. But on the other hand, i belive its safer to run in windows xp mode than not run compatibility at all. Since the game is kinda old. But i can run the game without compatibility set to xp, and i dont need to disable visual themes either. Only thing i need to do to run the game, is to force the game to run in window mode.

It appears a better option is to use software rendering (equivalent to Virtual PC), provided that the CPU is 2.4 GHz or higher. That is with details and texture at high and visual effects and sims at medium. There is some uncertainty about the system restore performance, which was great in Vista. This is probably due to hardware changes at restore points. It is best to shut down and restart, rather than use the on-board keyboard, after swapping keyboards or changing USB slots. Even an old MS Precision Pro game controller does not suffer such ambiguity in the host. Perhaps you sacrifice panning for more sims or effects.

I found that the solution to this problem is the same as for other older games which won't work properly under Windows 7 such as Master of Orion 2. If you disable Explorer before playing the game, it runs without issue; or at least I haven't had any problems with it thus far. Create a batch file (name it whatever you want, SimCity4.bat, etc just so long as you make sure to save it as a bat file, not txt or anything else) with the following lines

taskkill /F /IM Explorer.exe
Start explorer.exe

Place this batch file in the same directory as SimCity4.exe, (Note, you must rename Sim City 4.exe so that it does not contain any space ie SimCity4.exe) and edit the icon on the desktop so that the target points to this bat file instead of the game exe file. When you finish playing all you need to do is hit the space bar to start up Explorer again. I use this same batch file to run Age of Empires 2 Gold, MOO 2, and Pharaoh Gold. I have never had any problems with them since doing this. Before I started using this bat file, none of those games would work under Windows 7 either. The problem is tied to Aero and it's inability to properly handle colours resulting in a variety of graphical glitches and crashes. Killing Explorer before starting the game resolves these issues.

Well, I see you can't delete a post. Disregard what I said above. It does work for the games I listed, and I thought it was working without any issues with Sim City 4, but I just found an issue. While it prevents the video glitches and crashing, it also prevents the windmills from appearing correctly. They still work, but they only appear as white circles on the ground. I apologize for wasting everyone's time with this lapse on my part. I have never before run into a situation where this fix did not work.

Last edited:
There are 2 discs with SimCity 4 unless you got the dvd version. Rush Hour has only one disc.
When installing SimCity 4, if it asks you for disc 2, it does mean it needs disc 2 for simcity not rush hour.
If you downloaded this game, try finding simcity 4 disc 2 from where you downloaded from.
You need to install SimCity 4 completely (ie both discs) before you can install Rush Hour.
No, this is only true for the orginal game, SimCity 4 Deluxe Edition comes with Rush Hour bundled together on the original game ( still 2 discs )

So installing the Deluxe edition you have no option to install just SimCity 4 and then "upgrade" to Rush Hour, its all one shot during the 2 disc install, you get both products in Deluxe, so what you posted does not help the people, myself included, to attempt to fix this problem in Windows 7 32/64, it just does not work cause rush hour is installed right from the get go.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.