SMART Monitoring Not Detected - Windows 7 x64

Discussion in 'Windows 7 Help and Support' started by mbix59, May 12, 2009.

  1. mbix59

    mbix59 New Member

    Joined:
    May 12, 2009
    Messages:
    8
    Likes Received:
    0
    I like to keep an eye on my hard drive temperature, and I can in Windows XP, but on my dual-boot setup with Windows 7 x64 I have lost the ability to view temperatures. I've tried using Everest, Speed Fan and Active@ Disk Monitor and they all return the same result - that SMART detection is not available on my drives. My drives are SMART supported, and I have SMART monitoring enabled in my BIOS. I have tried running all programs with Administrator privelages, and my UAC settings are at default.

    Right now I'm placing the blame on my motherboard's Vista x64 drivers (no Win7 drivers available), but if at all possible I'd like to see if anybody has experienced this problem and come up with a solution. After several google searches I have come up empty handed.

    System specs below.
    Code:
    Computer:
          Computer Type                                     ACPI x64-based PC
          Operating System                                  Microsoft Windows Vista Ultimate
          OS Service Pack                                   -
          Internet Explorer                                 8.0.7100.0
          DirectX                                           DirectX 10.0
          Computer Name                                     MAGNI
          User Name                                         Marcus
          Logon Domain                                      Magni
          Date / Time                                       2009-05-12 / 05:10
    
        Motherboard:
          CPU Type                                          DualCore Intel Core 2 Duo E6550, 2333 MHz (7 x 333)
          Motherboard Name                                  ECS NF650iSLIT-A  (3 PCI, 2 PCI-E x1, 2 PCI-E x16, 4 DDR2 DIMM, Audio, Gigabit LAN)
          Motherboard Chipset                               nVIDIA nForce 650i SLI
          System Memory                                     2048 MB  (DDR2-800 DDR2 SDRAM)
          DIMM1: G Skill F2-6400CL5-2GBPQ                   2 GB DDR2-800 DDR2 SDRAM  (5-5-5-15 @ 400 MHz)  (4-4-4-10 @ 266 MHz)
          BIOS Type                                         Award (04/13/07)
          Communication Port                                Communications Port (COM1)
    
        Display:
          Video Adapter                                     NVIDIA GeForce 8600 GT  (512 MB)
          Video Adapter                                     NVIDIA GeForce 8600 GT  (512 MB)
          3D Accelerator                                    nVIDIA GeForce 8600 GT
          Monitor                                           Acer X191W  [19" LCD]  (L950B0293913)
    
        Multimedia:
          Audio Adapter                                     nVIDIA nForce 430i (MCP51) - High Definition Audio Controller
    
        Storage:
          IDE Controller                                    Standard Dual Channel PCI IDE Controller
          Storage Controller                                AML1O8XQ IDE Controller
          Storage Controller                                NVIDIA nForce Serial ATA Controller
          Storage Controller                                NVIDIA nForce Serial ATA Controller
          Disk Drive                                        Kingston FCR-HS219/1 USB Device
          Disk Drive                                        Kingston FCR-HS219/1 USB Device
          Disk Drive                                        Kingston FCR-HS219/1 USB Device
          Disk Drive                                        Kingston FCR-HS219/1 USB Device
          Disk Drive                                        WDC WD16 00AAJS-00WAA SCSI Disk Device  (149 GB)
          Disk Drive                                        WDC WD50 00AAKS-00H2B SCSI Disk Device  (465 GB)
          Optical Drive                                     OPSXKF 6VKT2VKLI SCSI CdRom Device
          SMART Hard Disks Status                           Unknown
     
    #1 mbix59, May 12, 2009
    Last edited: May 12, 2009
  2. eskimo

    eskimo New Member

    Joined:
    May 17, 2009
    Messages:
    10
    Likes Received:
    0
    same problem here ...
    I've tried Speedfan, Everest and a program called HDDLife and no one of these programs couldn't show me a S.M.A.R.T.
    HDDLife showed me an error message - No HDD with SMART. (all of my hdds have SMART)
    When I was on XP sp2, everything worked fine for me

    any solution?
     
  3. mbix59

    mbix59 New Member

    Joined:
    May 12, 2009
    Messages:
    8
    Likes Received:
    0
    Still haven't found a solution on my end.
     
  4. eskimo

    eskimo New Member

    Joined:
    May 17, 2009
    Messages:
    10
    Likes Received:
    0
    quite strange I think,
    I've only figured out, that Everest can show me SMART of my ext. usb Seagate disc, other SATA drives ... nothing.
     
  5. runc

    runc New Member

    Joined:
    May 29, 2009
    Messages:
    4
    Likes Received:
    0
    I'm getting the same thing. I'm using an Asus P5Q-E with the beta Windows 7 BIOS and drivers from the Asus support download website.

    S.M.A.R.T. monitoring apps just don't see either of my SATA drives.
     
  6. luckman212

    luckman212 New Member

    Joined:
    Jun 30, 2009
    Messages:
    14
    Likes Received:
    0
    I am having the same issue under Vista x64 (similar kernel to Win7 I guess). Nothing I have tried has allowed me to read S.M.A.R.T values. Doesn't matter if I am in SATA, AHCI, IDE, RAID mode etc etc. Tried all sorts of driver / software combinations without any luck. EVEREST, HWMonitor, SpeedFan, ActiveSmart, PC Probe II.

    If anyone figures this out, I would love to know- for now, I give up on the idea of monitoring my hard drives. :mad:
     
  7. runc

    runc New Member

    Joined:
    May 29, 2009
    Messages:
    4
    Likes Received:
    0
  8. luckman212

    luckman212 New Member

    Joined:
    Jun 30, 2009
    Messages:
    14
    Likes Received:
    0
    Yes I knew about that RAID issue. However I am not running my ICH10R in "RAID" mode-- it is in AHCI mode and I have just a single non-RAID disk attached to the SATA port. In the BIOS it shows up on the "main" page as a regular drive and even says "SMART enabled" in there, so I have no idea why it can't read the value. Starting to piss me off but I am just ignoring for now.
     
  9. soCram

    soCram New Member

    Joined:
    Sep 26, 2009
    Messages:
    4
    Likes Received:
    0
    Same for me and still waiting for a workaround... :(
     
  10. RoyG

    RoyG New Member

    Joined:
    Oct 14, 2009
    Messages:
    2
    Likes Received:
    0
    Run as Administrator

    Hi!

    I had the same problem with my Win7 x64, but then I tried to run the software with elevated privileges and then SpeedFan found my hard drive.

    --Roy
     
  11. soCram

    soCram New Member

    Joined:
    Sep 26, 2009
    Messages:
    4
    Likes Received:
    0
    That isn't working for me :(
     
  12. SatM

    SatM New Member

    Joined:
    Oct 16, 2009
    Messages:
    2
    Likes Received:
    0
    Thanks Roy !!!

    This is working fine (with SpeedFan 1.39, W7-64-RC) in motherboard Asus M3N-HT-DeLuxe, only, when you run as the user "Administrator" ("Administrador"), however, it doesn't work if you run with another user with administrator privileges.

    In addition, the only recognized hard disks are single ones (IDE or SATA), i.e. when they are not part of a RAID (in my case, a mirrored 750 GB is not detected).

    So, you will need to enable this "key" user in a console (cmd run with administrator privileges):

    net user administrator /active:yes
    (remember to create a password !!!)

    or (in spanish computer)

    net user administrador /active:yes

    A similar issue is happening with WMWare Server.
     
  13. Earthling

    Earthling New Member

    Joined:
    Feb 12, 2010
    Messages:
    10
    Likes Received:
    0
    No SMART data might indicate a AHCI driver problem

    I'm running Win7 64bit (since RTM version) on a Dell Dimension 9150:
    Pentium 4 3GHz, 945 Express Chipset, ICH7, 82801GH, Intel Matrix AHCI/RAID.
    I have 1 disk used only for the system & programmes and a seperate Data disk + other disks swapped in & out for various reasons.

    The 9150 was originally installed with VISTA and I had lots of problems running this system using RAID1, entirely down to problems with the Matrix drivers, so converted to running using JBOD using AHCI but also using Intel Matrix drivers. Both RAID & AHCI drivers have to be installed at initial installation on VISTA & Windows 7. If the Matrix drivers are NOT installed then the Windows default drivers mean that the disks run in ATA133 mode with reduced performance. Benchmarks shows upto a two thirds loss in throughput.

    I installed Windows 7 RTM using defaults drivers as Intel had not released Win7 64bit matrix drivers. This has worked fine with no problems or issues or, more importantly, any data loss. At this stage, all SMART data was readable .... using HDTune v2.55 under the "info" Tab the "Supported Features" area shows the boxes either ticked or empty & under the "Health" Tab was SMART data.

    Intel recently released version 8.9.0.1023 of the Matrix drivers that included support for 64bit Win7 AHCI. I re-installed Win7 using v8.9.0.1023on a a spare disk. All looked fine, benchmarks showed a considerable increase in disk performance right up to the point that the system disk failed. The only odd thing I noticed was that using HDTune under the info Tab the "Supported Features" area showed the boxes with a blue infil - i.e. no ticks or blanks, & under the "Health" Tab there was no SMART data - i.e. it could not read from the disk its SMART data. 5 disks later, all showing as dead or flaky (I had bought & returned one DOA WD 1TB black disk + another that failed after a Win7 + Matrix driver install). The only consistent thing about the disks was that HDTune always showed that the SMART data was not readable. I tried re-formatting the disks and installing in a machine not using Win7 or Matrix divers and HDTune showed the same problem. Eventually I tried deleting the MBR (I used Ultimate Boot CD v5.0RC1 but it could also be done from DOS using FDISK /MBR) - the disks were restored to normal functoning &, as long as I installed on a machine NOT using Matrix drivers, would format normally & all SMART data was readable.

    Sorry for the long winded explanation but it seems relevant in relation to SMART data not being read may indicate a fatal MBR problem that makes disks unreliable and prone to failure. I experimented with various Win7 configurations and whenever I use the Intel Matrix drivers at installation there are problems whenever I format a disk. If I attach an already formatted disk to a Win7/Matrix drv system, SMART data can be read. It seems that the problem occurs only if formatting a disk with the Matrix drivers installed.

    Anybody got any ideas why this is happening.

    Thanks to all who read/reply.
     
  14. luckman212

    luckman212 New Member

    Joined:
    Jun 30, 2009
    Messages:
    14
    Likes Received:
    0
    Just wanted to update this thread with some new info.
    Not sure 100% exactly what changed to enable this to start working, but as of today I have installed Intel RAID/AHCI driver v8.9.4.1004 and using CrystalDiskInfo v3.5.2 x64 version, I am now able to read the S.M.A.R.T data from my drives attached to the ICH10. :p
    I think it is the new Intel driver that allows this to work.

    [​IMG]
     
  15. Earthling

    Earthling New Member

    Joined:
    Feb 12, 2010
    Messages:
    10
    Likes Received:
    0
    Luckman thx for the response & information.

    I can't find v8.9.4.1004, could you please supply a download link.

    Thx.
     
  16. luckman212

    luckman212 New Member

    Joined:
    Jun 30, 2009
    Messages:
    14
    Likes Received:
    0
  17. Earthling

    Earthling New Member

    Joined:
    Feb 12, 2010
    Messages:
    10
    Likes Received:
    0
    Luckman,
    many thx ... got it. In a few days I'm going to do a clean install on a new disk & see it if this solves it. I'll post back here if I get anywhere with it.
     
  18. Earthling

    Earthling New Member

    Joined:
    Feb 12, 2010
    Messages:
    10
    Likes Received:
    0
    Hi,
    Luckman, I've done a clean install on an unpartitioned disk (deleted the MBR 1st) & using v8.9.4.1004 Intel drivers. unfortunately with with the same result as earlier. i.e. Win7 64bit installed OK but, on checking the disk, SMART data could not be read. Using a disk util SuperFDISK from the Ultimate Boot CD v5.0RC1 shows that the partitions are corrupted & only deleting the MBR will restore the disk. Any ideas?

    p.s. Ultimate Boot CD can be found here: Ultimate Boot CD :: View topic - UBCD V5.0RC1 available for download
     
  19. luckman212

    luckman212 New Member

    Joined:
    Jun 30, 2009
    Messages:
    14
    Likes Received:
    0
    hmm well not sure about the superFdisk.. never used that util myself but I would just stick with the built in CHKDSK for checking corruption. As for the smart still not working for you, I am not sure- I am running my ICH10R controller in "RAID" mode in the BIOS, and Port0-3="native". How are your bios settings?
     
  20. Earthling

    Earthling New Member

    Joined:
    Feb 12, 2010
    Messages:
    10
    Likes Received:
    0
    I don't think CHKDSK will show a Partition problem. BIOS is at defaults & I don't overclock. The Intel drivers worked with both XP & Vista (32bit). The problem started with Win7 64bit. Hey ho, hopefully a future Intel driver update will solve the problem. Thanks for your input.
     

Share This Page

Loading...