[SOLVED] [Windows 8] All USB Drivers Suddenly Disconnected, still happens after restart

#1
I am having trouble with my USB connections. They will all be working fine if the computer is idle, then when I start doing things all of the drivers get disconnected, and won't reconnect after unplugging and replugging them in. Restarts don't help, so I'm stumped. Help would be greatly appreciated.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
What devices do you have plugged into the ports, and if you have more than one, have you tried them one at a time?

Since we know nothing about your system, is it both USB 2 and 3 ports with the problems?
 


#3
Turns out my iPhone somehow messed up some of the ports. I erased all the devices from the registry, uninstalled all the root hubs, restarted, and everything was fine. Thanks for trying to help anyway!
 


#6
Turns out my iPhone somehow messed up some of the ports. I erased all the devices from the registry, uninstalled all the root hubs, restarted, and everything was fine. Thanks for trying to help anyway!

I just went through this with an ipod nano 4th gen....it dorked up my safely remove set up, it had an incessant load loop of being recognized and it wouldn't show up in "This PC" under windows 8.1 Pro after the loop issue. Went through same procedure and all is well. As Roberwav1 stated....Damn those apple devices....
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.