Sound not working despite multiple reboots.

Discussion in 'Windows 7 Help and Support' started by Nomad of Norad, Jul 3, 2016.

  1. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    This has been driving me insane for several weeks. I turn the machine on, and (after a really long time of it launching lots of things) I get the I-have-successfully-launched sounds, and then immediately after that the sound completely stops working.

    When the machine is still launching stuff, if I right-click the speaker symbol on the right in the Toolbar, select Playback Devices, then right-click on Speakers (which is checkboxed as the Default Device, there is also Realtek Digital Output, and on Realtek Digital Output(Optical) below that), and select Test, sometimes it will take a few moments where, if I right-click Speakers again, it will show Stop Testing for awhile, and then suddenly I get the test tones, AND a flurry of other I-have-launched-this-thing type sounds, related to other programs that are launching at startup. But then it sounds like the sound effect is stopped a fraction of a second before its supposed to.... and from that moment onward, no more sounds will play. if I then right click Speakers and select Test, I immediately get a dialog box saying "Failed to play test tone."

    Other times, when I (re)boot the machine, and at that same moment in the startup, I do the above Test, and immediately get "Failed to play test tone."

    I can reboot and reboot and reboot and reboot, and SOMEtimes I'll finally get a session where the sound stays ON the entire time... but typically it takes me 2 to 3 HOURS of this repeated reboot song and dance. Much of this is because I have to wait 20 or 30 minutes before it gets to the point where it attempts to play that I-have-successfully-launched-these-things sound, while a large flurry of various programs launch form startup.... some of which behave as if they're held up waiting for the sound-player mechanism to launch... and then crash.

    This is really, really, really frustrating because I'm trying to get the machine up to speed for a scheduled event I HAVE TO be at that HAS TO HAVE sound working. Sometimes its a voice-chat meetiing, sometimes its a music event in a virtual world, or some other thing where I need to have sound working... and I've turned the machine on 2 or 3 hours in advance of it so everything is already ready already.... except that in te last few weeks I've had to keep rebooting the machine for that entire 1 oe 3 hours, watching the time being eaten away as that scheduled time rushes up closer and closer and then sometimes just goes WOOOSH!!!!! right on over my head as I'm STILL stuck in reboot Hell.

    I've looked at several other solutions where someone else had the same issue I have, where they said go in and run THIS thing from CMD in Admin mode that checks to see if any of the installed components of Win7 are corrupted.... and it found everything was fine. I've reinstalled the drivers, as acquired from the Realtek website. I've tried to follow someone else's set of instructions that involved drilling down into Registry to check to see if certain things in there are missing and reinsert them, only to find either that the possibly-missing Registry entry in fact IS there like it's supposed to be... OR that the subfolder in Registry that I'm supposed to go to isn't where that instruction tells me it should be. There was even one that boiled down to "Go disable this device, then re-enable it."

    It ain't working, and its making me scream at my machine.

    This has been going on for weeks. When it started out, it was only doing this no-sound lunacy occasionally, and usually a reboot sorted it the first try, but now it's doing this no-sound lunacy the vast majority of the time.

    This is on Win7 Ultimate, 64bit, service pack 1, on an AMD FX 8320 Eight Core Processor, with 32GB ram.
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,830
    Likes Received:
    1,565
    Hi,
    have you checked what else is starting up with Windows as it might be causing the issue, a recently installed app perhaps? If you right click on the task bar, bring up the Task manager and look under start up.

    How are your audio drivers date wise? It's usually best to run the latest version and you can find the latest Realtek HD driver here:
    Realtek

    Lastly if you have made quite a few changes to the audio settings then try turning everything back to default settings.
     
  3. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,410
    Likes Received:
    363
    I would also try to boot into Safe mode and test audio. If it works immediately then it is as Kemical stated probably some program interfering
     
  4. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,791
    Likes Received:
    216
    If Safe Mode doesn't produce a better result, you might want to download the free Ubuntu Linux LiveCD and see if sound works there.
    Here's that link for you: ubuntu.com
    Ubuntu completely bypasses Windows and their subsequent funky driver issues. If your sound works properly with Ubuntu, then it's probably a windows repair and possibly a failed hard drive. 90% of windows7 audio problem come from failing hard drives or bad RAM sticks.o_O You might want to test those.

    If sound works under Ubuntu, and your hardware is ok, you are probably looking at a Windows7 in-place upgrade, reset, or complete windows reinstallation from Recovery Media. Fooling around with Registry hacks to fix audio problems in windows is notoriously unproductive.:wound: Both neemo and kemical have been able to fix some of these I've seen; and they are real experts, but they occasionally fail and come to find broken hardware was the problem.:bigtongue:

    Any computer that's running Win7 is 6 years old or older this year, and since desktop PC hard drives are only designed to last for 3 years; and laptop drives 2 years; if you haven't yet replaced the hard drive in that computer since you purchased it or built it, there's a 90% chance it is failing or has failed and is the real cause of your quirky audio failures.:down:

    And regardless of what troubleshooting your pursue in the course of trying to fix this problem, make sure you have BACKED UP ALL YOUR PERSONAL DATA TO EXTERNAL MEDIA BEFORE PROCEEDING IF YOU HAVEN'T ALREADY DONE SO!!

    Here's the 2 tests you need to run to test your hardware:

    RAM memory test:
    Memory Diagnostics

    HARD DRIVE test:
    Hard Drive Diagnostic Procedure

    Good luck to you,:encouragement:
    <<<BIGBEARJEDI>>>
     
    #4 BIGBEARJEDI, Jul 3, 2016
    Last edited: Jul 3, 2016
  5. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    --------------- SeaTools for Windows v1.4.0.2 ---------------
    11/18/2015 2:44:21 AM
    Model Number: ST31000333AS
    Serial Number: 9TE0YN72
    Firmware Revision: CC1F
    Short Generic - Started 11/18/2015 2:44:21 AM
    Short Generic - Pass 11/18/2015 2:48:54 AM
    Long Generic - Started 11/18/2015 2:49:16 AM
    Long Generic - Started 11/18/2015 5:56:45 PM
    Long Generic - Pass 11/18/2015 10:14:33 PM
    SMART - Started 7/3/2016 6:44:30 PM
    SMART - Pass 7/3/2016 6:44:35 PM
    Short DST - Started 7/3/2016 6:44:48 PM
    Short DST - FAIL 7/3/2016 6:52:54 PM
    SeaTools Test Code: 6BABD3EA
     
  6. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,791
    Likes Received:
    216
    Very good job on running SEATOOLS. :D It looks like there is a failure in the Short DST (Drive Self-Test), and that usually means there are bad sectors on the media undetected in the short and long generic tests.:waah: It turns out there is a long DST test as well, which your drive never gets to since it failed the Short DST. Combined with the fact that the drive is throwing out a Seagate error code, this tells me that drive is toast!:waah: Time to replace it!:waah:

    Here's a link with more information for you:
    SeaTool - short DST and long DST tests fail

    As I suspected, a failing hard drive is causing your audio problems, and you simply need to replace it with a brand new drive of equal or greater capacity. I recommend WD drives, and not just because I helped design them, IMO they are the best and longest lasting drives available on the market.:encouragement:

    You didn't respond to my question about whether you had replaced the hard drive in your computer since you purchased it or not--it's probably a moot point now, but it would help us to know that. My money is on it was never replaced.

    Were you also able to run the RAM memory test (MEMTEST) too? Even though we've found a failed component, the hard drive, it's not unusual to find BOTH failed RAM sticks as well as a failed hard drive in older computers.o_O You should run it to make sure your RAM sticks are all ok; make sure to run both short and long tests on MEMTEST as my link instructs. If all sticks pass, you are good to go with a new hard drive and perform a complete Win7 reinstallation from factory Recovery Media if you have it or can create it from your current setup. If not, the Recovery Media is available from $29.99 to $99.99 US from most major OEM computer makers. Once you know all your RAM is ok, and you put in a brand new hard drive and reinstall your Win7 to OOB (Out-Of-Box) condition; all should be fixed.:up:

    BBJ
     
  7. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    Uhm.... nope, haven't gotten past that short test.... I actually HAVE a same-capacity WD drive sitting here that I'd meant to use to clone my NAS drive to, and then never got around to because I'd lost track of my old Norton Ghost bootable CD, and Clonezilla was a little too primitive-looking an interface for my tastes so I plopped it all over onto an "I'll deal with this later" pile and then never got back to the pile. Anyway, I'm going to go clone the Win7 drive with WD's own, made-by-Acronis clone-things-to-a-new-drive utility, as described over here:

    How to Clone a Hard Drive/SSD | PC Gamer

    ...tho I had to go find the newer version on WDC's website because the one linked to on that article 404s, but it was trivially easy to find the new version there.

    As for the RAM on this machine, it's much newer than the old drive, since the whole MACHINE is way newer than that drive.
     
  8. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,791
    Likes Received:
    216
    Yes, Acronis TrueImage is licensed to WD and it works fine on Win7/8x/10; have tested on all platforms there.

    Let us know how it turns out!:teeth:
    BBJ
     
  9. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    Well, yesterday, I swapped out to the new, cloned drive. I started the machine with the new drive in place, and wasn't getting sound until I did the right-click-on-Speakers-and-select-Test thing, where it took several moments doing its Test, but then sound worked for the rest of the session that day.

    Today, I turned the machine on, then had to be out of the house for awhile to do some other stuff. Usually I turn the machine on a couple hours in advance of an event I need to be at online, because for a really long time (long enough ago that I don't remember when it started doing this), for a good 90 minutes or so, some task or tasks under the hood takes up extra resources away from foreground tasks. I have a lot of things set to autolaunch at startup, but when I look at Task Manager, I don't see anything showing an abnormally high amount of disk activity)...

    Anyway, I came back with a half hour before the event I was wanting to be at and.... NO SOUND. I've now rebooted the machine twice and its still not giving me sound. Doing the Test in Playback Devices gives me "Failed to play test tone."

    The only real difference between today and yesterday is, I had gone into msconfig and unchecked Discord and Slash from autolaunching, because I figured I'd need to do a lot of reboots and Discord in particular seemed to get STUCK at loading until the sound system came up, but also because it took awhile to launch and I figured it was best to get to the point where I could readily reboot earlier and quicker.

    This no-sound thing is gigantically frustrating, because there are A LOT of scheduled events I go to online that are built largely around SOUND. I've BEEN tempted to just say "Screw it!" and let my machine upgrade itself to Win10, figuring THAT would fix all the problems (because it would put a brand NEW system, dumping away whatever got borked in the process) but I've been puting that off till later because I'd then have to reconfigure a lot of programs and/or re-enter the register-with-the-mothership serial-numbers in a LOT of programs, or even have to reinstall some of them due to the existing install maybe not liking Win10, and THAT'S gonna be a huge hassle unto itself that I'd need to devote an entire day to... but I wanted to put it off a little longer while I nerved myself up for it.

    The problem is, if this sound thing is a PURELY SOFTWARE problem, it'd still be nice to solve it NOW, easily and quickly. But If this is masking some kind of HARDWARE PROBLEM, like a motherboard starting to go bad (except it's not that old a motherboard... maybe a couple years old if that), then I need to know about it NOW, before I put a huge amount of work into Windoze-related stuff.
     
  10. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,410
    Likes Received:
    363
    I would download a copy of Ubuntu and make a bootable USB and boot to that. If you still have no sound, then it's most likely a hardware issue.
     
  11. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    Yeah, but if this is some sort of intermitent issue, akin to a broken trace on the motherboard or something, how long do I wait while running the Ubunto disc to see if THAT one starts flip-flopping between sound working and not working? Or do I just assume Ubuntu sound-is-working == not-a-hardware-issue?

    Anyway, I've burned a fresh DVD-R of a ubuntu desktop iso I had on hand (my previous burned copy sprouted legs and walked behind a freaking shelf or something oO ) and will boot from that now.

    Editted to add: Incidentally, when shutting down from Windows, I have often gotten a Breakpoint Exception message dialog box pop up AFTER I've issued the shutdown command. I can't do a screen grab of it in Windows to capture it, of course, since it's in the middle of shutting down. I suppose I could try to cancel out of the shut down then paste it into Paint.net or something to save out the image, or grab a photo image of it with my smart-phone. Any idea what might be causing a Breakpoint Exception? It was doing that occasionally well before this sound issue came up.

    Edit2: Okay, I'm watching a YouTube video in Ubuntu, and there's sound. Not really LOUD sound, mind you, but sound. :D

    Edit3: Came back to Windows, went into msconfig, unchecked Discord from launching at startup. let it reboot for changes to take effect. Sound came up on next session. oO
     
    #11 Nomad of Norad, Jul 5, 2016
    Last edited: Jul 5, 2016
  12. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,791
    Likes Received:
    216
    It sounds like it's a Windows issue with that Discord app and possibly more. The Ubuntu test proves your audio chip on your Mobo is ok. :encouragement:

    I would consider either rebuilding your W7 from scratch (W7 reset or W7 installation from factory Recovery Discs or Partition), or just bite the bullet and do a W7-->W10 upgrade which involves reinstalling all your programs from scratch and reintegrating your restored data from backup media. You probably realize this is not a 10 min. deal; and when I do this it typically takes 2-3 weeks before you are back at 90% functional of where you are right now with that computer. Many people here and Clients have told me it can take up to 4 months to get everything working again. I have some Clients who have over 400 programs installed on their computers, and it can take forever to get every single one of them reinstalled *finding the media discs or usb or download license keys etc.* You know what's involved and it sounds like you've done it before as have most of us, and you're right to fight shy of doing it.:headache: :hide:

    At this point, you've got software issues, and you've proved your Mobo hardware and new hard drive are ok. If you can't do it this month, you might need to wait longer before you attack this, but keep in mind that there are a couple of issues that waiting will cause you to think about. The first is the July 29th 2016 Anniversary of the free W10; so if you didn't have your W10 Activated (due to the crashes you mentioned and other problems such as the audio), you will need to tackle that and we don't know exactly how it will work until we do a few. 2nd, if you build your W10 system via upgrade or clean install on or after Aug. 2nd 2016, that's the date Microsoft is going to release their Anniversary Update to W10. Doubtless there will be issues and incompatibilities there that can also cause you further delay and frustration. I suggest if there is anyway you can get the W10 upgrade build done BEFORE these 2 upcoming dates, you might want to do it. Getting your system working again with your audio problem fixed would be better to do than wait for after Aug. 2nd as if you wait and your audio stops working, you're going to be troubleshooting all over again and blaming those 2 events and updates for further failures. If you build it sooner, and take snapshot backup images and your sound fails after either the July 29th or August 2nd dates; you can just rollback via System Restore or Restored Backup Image prior to these 2 event-dates and get your system backup and running.:teeth:

    Another way to go would be if you need to wait past these dates to install, you can just buy a 2nd hard drive for your system and do the rebuild on the new hard drive post August 2nd. Ensure your issues such as sound and exception crashes have abated, and your good to go.:up: If after a few days or weeks of building the new W10 system on this new HDD something goes south, you can just pull that drive out, stick in your original HDD and be back up and running in a hour or so with the old build (no sound) to get you by for emergency access to your scheduled online events you to attend or running the various asundry programs you have all setup and configured for. When you get a couple of weeks of downtime, then you can stick that 2nd drive the new HDD back into your computer and do another complete rebuild of W10 and hopefully get it all working again. If that works, you can just stick the old HDD back in a drawer and just use it for emergencies if your new W10 build on new HDD ever goes out on you.;)

    BBJ
     
  13. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    Well, the main thing I was seeing.... which ultimately made me suspicious that it was some kind of weird deadlock going on with Discord, was that at a certain point in the startup, I'd see Discord starting to launch like normal, and it pops up its usual, small dark-grey pane with a random battle-cry sort of phrase and a message that it was checking up updates and was about to launch itself into the fray or something... and then it would give a message something about "Failed to connect for update, trying again..." And then it would act like it got the connection, and you'd see a way bigger grey pane come up in the monitor, where normally a second or so later the usual chatrooms display and interface arrives. But instead, that big grey rectangle just sat there, and sat there, and SAT there... for a really long time. This part of it would probably last for maybe 10 or 15 minutes, but I never really sat down and timed it. During this whole time, there were NO sounds being played by the entire system. Typically, well before this stage, in fact mostly as the start of the desktop is coming up for Windows, you'd hear the Windows fanfare noise (the series of tones of a raising pitch), but in this session that sound hadn't played YET, and it's now at the point where lots of launched-at-startup programs have begun opening their various windows. But, Discord is still stuck at that big grey rectangle. By this point, I've often right-clicked on the speaker-symbol on the lower right of the start bar to invoke the Playback Devices pane, and have then right-clicked on the Default Device at the top of that list of devices in order to click on Test... at which point that test seems to be taking awhile to kick in, too, because for a few moments after that, I can right-click that topmost item again and it shows Stop Test where the Test option was before.

    And then, at some point, suddenly BOOM! All at once the very delayed Windows startup fanfare plays, AND the Discord-has-launched fanfare plays, AND the Test tones from the Sound window plays.... ALL AT THE EXACT SAME TIME, and at that exact same instant Discord's window suddenly unfreezes from that big grey rectangle and actually swiftly opens into its normal chatrooms interface in that space. And then very often right on the heels of THAT.... the sound quits, and now right clicking the Default Device in the Sound pane under Playback devices and selecting Test yields an IMMEDIATE "Failed to play test tone" error. Which means that whatever the heck the deadlock was, coming OUT of it crashed the sound handler.

    Some web-searches tell me that a LOT of people have been having various sorts of sound screwinesses in Discord when they're using the Realtek drivers and sound cards, which is what I have on my machine. So, yeah, there is definitely some sort of deadlock going on between Realtek, or the general sound system of my machine, and Discord, at least on Windows 7.

    But in the end, I only REALLY noticed that THIS was the problem because I decided earlier that programs LIKE Discord were taking too long to get started on my machine, so that I'd want to defer them launching till later (I can still launch it from the pinned icons on my start bar at my leasure, and they launch fine) so that I went into msconfig and unchecked Discord and another late-launching app (Slack, I think it was) PURELY so I could get to the point where I could cleanly issue a reboot command from the Start button sooner, without having to WAIT for more of these programs to launch. And THEN noticed that the day I'd simply left them off the group that auto-launched at startup was ALSO the day I had little trouble with the sound not working. But that the next day, when I'd turned those two programs back ON in the auto-launch list, I was back to endless rebooting without getting the sound to work.... for reboot after reboot after frustrating reboot. And THEN I uncheckboxed ONLY Discord in msconfig and let the machine restart... and got sound back without trouble. And after THAT I did a web-search on Discord and sound-troubles, and found LOTS of ppl were having sound troubles with Discord if they had Realtek sound, tho not the SAME troubles I was having. (Mostly theirs was stuff like in-game voicechat behaving weird, and the like.)
     
    #13 Nomad of Norad, Jul 6, 2016
    Last edited: Jul 6, 2016
  14. Nomad of Norad

    Nomad of Norad Honorable Member

    Joined:
    Jan 9, 2009
    Messages:
    125
    Likes Received:
    0
    Okay, today fired up the machine again, and the sound worked this time, too. I think I've nailed it. Knock wood.
     

Share This Page

Loading...