Sudden loss of internet speed: 20Mb to 1Mb.

Discussion in 'Windows 7 Networking' started by codename47, Nov 4, 2009.

  1. codename47

    codename47 New Member

    Joined:
    Nov 4, 2009
    Messages:
    4
    Likes Received:
    0
    Hello i have installed windows 7 64-bit and, although i am not certain, i think i had good internet speed before i put the 64-bit version. Initially i decided not to use the 64-bit version because i couldnt get the driver of my external USB wi-fi card to be recognized.

    It's an SMC WUSB-G EZ Connect. SMC said their driver was supported by Vista 64 so i thought i wouldn't have any issues. I did. I could, however solve the problem by installing (bad install) the driver that came with the CD and then installing what i think is a previous version of the same driver in the same folder. Then i could get W7 to recognize i had a wi-fi conenction and therefore could connect myself to any wi-fi around.

    I think it was then that i started having ridiculously slow internet speeds. I didn't notice a lot because i have been having a pretty busy life and i just leave downloads going and then check them. When i started to notice i couldn't remember anymore when it started. Fact is that for a few weeks i was getting 1Mb of speed at most. Now after doing a few things in order to solve the issue i am getting 6Mb ( i have absolutely no knowledge of why). I did the speedtest twice today and both time i got good peeks reaching up to 12Mb but ending in 6Mb. I am going crazy about this.

    I'm paying for 20Mb and i can't use them. I share connection with my neighbour and he came here with his notebook and got 16Mb. So, i am assuming it's not the distance or anything. Also after these "experiments" i had going on in order to fix it it seems my wi-fi signal has gotten a little weaker. Now i normally have two sticks out of five at most times. I normally had at least 3 before these changes.

    From the experiments i tried i can remember these:
    - I ran that DOS command: "netsh int tcp set global autotuninglevel=disabled" obteaining the Ok. message.
    - I tried TCPOptizmier: gotten only worse and i think it was when my signal started to get weaker. Before deleting it i restored to windows default configs though.
    - Disaled IPv6
    -Disabled QoS


    Please don't tell me it's a driver related issue. Help me search for the other possible reasons because, the truth is, SMC support sucks, and although i have sent them quite a few e-mails they haven't answered. Please help me seek the reasons as to why this is happening.

    Very much appreciated,

    Henry

    PS: my notebook is in repair. It has a vista 32bit system. When i get it back ill run speedtest in order to compare.
     
  2. codename47

    codename47 New Member

    Joined:
    Nov 4, 2009
    Messages:
    4
    Likes Received:
    0
    Update

    I have done the speedtest a few more times and it continuesly changes. Today i even got a 15Mb which is pretty close to what i want. But then again at other times it went to 6, 3 and now its bac kto 1 again. Any help pelase?
     

Share This Page

Loading...