Trouble with Network Controller

Discussion in 'Windows 7 Networking' started by triplitz88, Apr 7, 2013.

  1. triplitz88

    triplitz88 New Member

    Joined:
    Apr 7, 2013
    Messages:
    2
    Likes Received:
    0
    Hello all,

    I'm new around here and I've got a problem with my networking.

    Relevant Hardware:
    Asus Sabertooth (first verson) 990FX Maim board.
    2x WD 7200RPM HDs
    Windows 7 Ult x64

    Background:
    I install 2 disk hard drives into my computer to set them up into a Raid 0.

    Now I got them installed and the the raid set up. But when I boot back into windows I find that the Realtek Network Controller is missing. After several days I finally learned that its actually a bug between Windows 7 and the Realtek Network Controller and a lot of people seem to be suffering from it. About the only method is to cut power to the PC for 10+ minutes.

    The gist was that Windows 7 put the network controller into a "Deep Sleep Mode" and the BIOS could not override this (in fact the BIOS said the controller was enabled when it really wasn't). Since it seems that the actually active BIOS and the one I actually flash are not exactly the same thing I'm thinking this issue is caused by Windows 7.

    Now I went ahead and installed Windows 7 on the Raid 0 setup to see if it was just OS specific. Turns out the device was still turned off and neither OS install could turn it back on.

    I did go to the Realtek website (the Asus drivers were out of date, although I tried them at least once anyways) and installed those drivers.

    When I reboot the computer, it says the device is there, if I try to reinstall the device it says that it doesn't exist again. The behavior is exactly the same no matter which boot I use.

    Now the entire rest of the system works perfectly and the actual port was at the far end of the board from where I was working.

    So right now I've tried both of my ethernet cables. Both work fine when I plug them into my laptop but not my desktop so I don't think those are the issue. I have taken some q-tips (no cleaner) and wiped off the contacts on the motherboard and the cable although this produced no change in behavior.

    What is very weird is that both the router and the mainboard have a small LED light that is supposed to light up when the cable is connected. When I hook up the cable, the router's LED is on and doing that rapid flash it seems to do when talking to a computer (and it does this continously) but the mainboard's port does not light up.

    On the Windows end, when the Device Manager says the Network Controller is working perfectly, the message is that its "Connected to a Unknown Network" and "No Network Access" (not internet, just network, seems to be different errors). If I unplug the cable from either end then it just says "Not Connected - No connections are available".

    Another thing I noticed (memory is a little blury after 5 days) is that when the Device Manager says that it cannot find the Network Controller the registry data for that controller (in the current control set) is also missing.

    And I apologize, this should have been written earlier, but unchecking the box's in the Controller's power options (so the OS couldn't turn it off) had no effect on the device disappearing.

    This last round I had windows auto-install a driver for the controller is and is coming back with the reboot for the time being.

    Problem:
    Windows cannot seem to connect to my router. Info above.


    Thats about all I can give you. I don't have any space on the mainboard to put a NIC card because all of the space is taken by 2 bricks (Radeon 6950 cards) so the port is all I've got.


    Can anyone help me? Thanks!
     

Share This Page

Loading...