Unable to install apps from store

#1
I am unable to install any apps from the store after installing W10 (upgrade from 8.1)
Download starts, then "acquiring license" comes up followed by "try again later" with an error code ; 0x803F7003.
Could it be anything to do with me being in Finland and having my region set to UK?

Any suggestions appreciated.
 


#2
Same problem here mate. Don't know what is the issue. I actually had similar problem before, and after changing region on my PC to USA the issue was fixed. It all worked great since today, when the error showed up again.
 


#3
Hi pspbricker,

The error is most likelely caused by a problem with the Windows Update service.
When you run the Windows Update Troubleshooter tool from Microsoft it will probably come up with the message "service registration is missing or corrupt". If so, you can simply resolve this by restarting the Windows Update service.
 


#4
I tried again this morning and I am now able to download. Just a bug I guess. Numerous people had the same problem - hope it's fixed for all now. Happy Windower.
 


#5
I can download too. Don't know did Microsoft fixed it, but i did what Schrodinger92 said. Actualy, I stopped and started Windows Update service this morning, because I got an error when trying to restart it. Now I can download anything from store. Thanks Schrodinger92, thanks Microsoft. :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.