Unable to read file on W7 machine from XP machine

Discussion in 'Windows 7 Networking' started by Howie9999, Aug 24, 2011.

  1. Howie9999

    Howie9999 New Member

    Joined:
    Aug 24, 2011
    Messages:
    4
    Likes Received:
    0
    [HR][/HR]I have a MYOB company file on my W7 machine - this is where I use MYOB Premier. I have shared the folder so that my XP machine can see it.

    I have MYOB Account Right Plus on my XP machine. I can see the MYOB company file from the XP machine in the share so seeing it is not a problem. However, when I use Account Right Plus to open the MYOB company file on the XP machine and try to open it to process with I get an error which says "Unable to open file; file may be locked or in use or access privileges may be incorrect". I have checked and the file is definitely not in use and can be seen from this XP machine.

    We have a workaround whereby we copy the company file from the folder on the W7 machine to a folder on the XP machine and we can successfully open it on XP using MYOB Account Right Plus. So it seems to be a network issue where the XP machine can see but can't use/read the company file on the W7 machine.

    As a last resort we could uninstall the software on the W7 machine and install on the XP machine to avoid the problem altogether, but if there is a solution, to keeping things where they are, this would be preferred.

    Hope someone can make some suggestions on how to resolve this.

    Thanks,
    Howie
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Howie:
    Hello and welcome to the forums.
    It's been a very long time since I've even looked at MYOB and honestly their support service might be a better source for an answer to your question as their may be some unique qualities of the software the require special tweaking, but I'll give it a shot.
    First make sure that the username and password that you are using on the XP machine is identical to a username and password that is also on the Win7 machine hosting the file.
    Then on the Win7 machine hosting the file right click the folder where the file is located and choose properties. Under the sharing tab make sure that you have Everyone = Full Control, then under the security tab set your granular permissions specific to what that specific user requires, like at least read and write, but more likely modify and possibly even full control (if opening the file creates a database style lock file and closing the file must delete the lock). You only need to grant these permission specifically to the user account that is coming across the network, if his local account has the proper access privledges then Windows Pass through authentication should take care of the rest. Don't change or adjust any of the default NTFS (security tab) permissions just add the additional user and set the permissions accordingly. Make sure when you set the security permissions that you check the box that says include subfolders and files.
    Hope this helps.
    Regards
    Randy
     
  3. Howie9999

    Howie9999 New Member

    Joined:
    Aug 24, 2011
    Messages:
    4
    Likes Received:
    0
    Thanks Randy, but I have a question... on the Security tab how do I know which user to set permissions on (ie, which user account that is coming across the network)?
    Thanks,
    Howie
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Howie;
    This stuff can get pretty boring and a bit confusing so feel free to scratch your head and say "What!!??" a few times.
    The username and password that is being used on the Windows XP machine. That same username and password needs to be on the Windows 7 machine (if not, add a new user) (you don't need to actually use the account it just has to be there with the appropriate permissions). Then that's the user you'll want to add (edit) to the access list (Group or user names) under the security tab for the folder that contains the file you are trying to open from the XP Machine.
    Access to shares are controlled by both the sharing tab, (share permissions are for control of users comming at you across the network), and the serurity tab, (ntfs permissions) are for locally logged on user, however they are automatically combined when you create a share on an ntfs volume and when combined the most restrictive is always applied. That's why I recommend setting share permissions to Everyone = Full Control and then using the security tab to adjust NTFS permissions explicitly and with more granular detail. This used to be Microsoft Best Practice, but I think they've changed it, but I still do it that way, it just seems a bit easier and a little less confusing to me.
    I might also recommend that you practice on a "Test Folder" just make a new folder add a text file to it and practice sharing it to your XP user, this accomplishes two things number one it's a safe way to practice with more nuanced security settings, (like if you find yourself having to break inheritance from a parent container and forget to copy (I think the call it "add" now) the already existing permissions you may find yourself locked out or the folder, this way no harm done, just blow it away and start over, likewise finding all the little check boxes under all the various advanced buttons to cascade permissions down through subcontainers and files can get confusing so this way you can relax and be a little more fearless in changing these settings. It will also give you a sense of having a template for setting up the actual folder that you're concerned with correctly, in that if your XP user can access your New Folder and open and edit and save the text file contained there in then it's likely that you'll be more confident that you have everything setup correctly in the real folder and it's not likely a permission issue generated by the OS if you continue to have problems but more likely a MYOB issue that needs to be tweaked.
    Good luck and keep us posted
    Regards
    Randy
     
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    There is a warning in the Users Manual (p.24) about the UAC in Vista. Since it seems the manual was written before Windows 7, the warning will also apply, but it mentions some folders may create problems when trying to open files. The Program Files folder is specifically mentioned, but have you tried storing the file in another place?

    This may not have been written to refer to networked folders, but it might apply.

    I do not remember XP, but does it have an option to add a network location and have you tried that?
     
    #5 Saltgrass, Aug 29, 2011
    Last edited: Aug 29, 2011

Share This Page

Loading...