USB drivers not loading correctly

Hello and thanks for attempting to help.

My USB drivers are only running at 1.0 (not 2.0). I have tried to uninstall the USB drivers multiple times and Windows 7 just reloads at 1.0. I have downloaded the Intel(R) Rapid Storage Technology drivers for Windows 7 x64.

I first noticed the problem as my USB devices (mouse, keyboard and printer) were not working properly. After contacting Logitech and Canon they suggested checking the USB ports and they were correct that they were not running at 2.0 speeds. I already contacted ASUS, the motherboard maker, and they immediately sent me to Windows. So, here I am.

Thanks for trying to help

Windows 7 x64
MOB: Asus P6X58D Premium
SSD: Intel 25-V (two) in Raid 0
Memory: Corsair 6 MB
Video: BFG Nvidia 260



Excellent Member
Microsoft Community Contributor
If you motherboard can handle it, check the Device Manager , USB Controllers and see if any Enhanced Host Controllers are shown. The USB drivers are with the chipset drivers.

Some folks don't update their chipset drivers, but I will if the MB manufacturer has Win 7 drivers. In some cases, the vanilla drivers will not handle any specialized devices. USB should not be that type since it is on just about all motherboards, but I do not know for sure.


Saltgrass is correct -- have you checked your chipset drivers?

Yes, under my device manager Enhanced Host Controllers are shown for 6 USB ports.

ie. Intel(R) ICH10 Family USB Enhanced Host Controller - 3A3A

The others are have a different number. Then, checking the USB Root Hub only two of the drivers are running at "High-Speed" = 2.0 and all the others are running at "Full-Speed" = 1.0



Also in the device manager is a "Other devices" which has a yellow !

It is a Universal Serial Bus (USB) Controller. I had plugged in an additional USB port to see if this would load correctly and it does not. So, the problem was present before this step.

Thanks again

Any other ideas?



Excellent Member
Microsoft Community Contributor
Is the external hub the only problem you are having? If you are still having mouse and keyboard problems, you might load drivers for them also if Win 7 did not pick it up. If the USB drivers were not installed properly, Win 7 may not have been able to determine which drivers to use. You might check Windows update to see if there is an optional update for your devices.

I notice you have SSD drives. Since I have no experience with them, I was just trying to think of a way they might be involved.

You do have legacy USB turned on or auto or something in the bios?

As far as the external USB hub, I assume it is plugged in to an external power supply. It is rated at 2.0 speed? Have you tried another USB port? Are you using ones built on the motherboard on the back or ones that have been connected to some front USB ports?

If you haven't already, I would unplug the USB hub, reboot and plug it in again.

I have only 2 of the USB hubs running at high speed also, so you seem to be right in line with what I show..

If nothing seems to work, I would try to download and boot to an Ubuntu Live Linux CD and run it for a while. If the USB devices do not work there, then I would probably start looking at a USB power problem on the motherboard. But if your mouse lights up, maybe it is not that.

Last edited:
Thanks for your suggestions.

The external USB is not the issue. I just tried one without resolution of the problem.

Any other suggestions on the cause of my USB ports running at only 1.0 speed?



Excellent Member
Microsoft Community Contributor
You say the Enhanced controllers are on 6 of your ports. Mine only shows on 2. Perhaps some of the controllers are using the wrong driver.

I would try uninstalling the yellow mark device and if that does not help after rebooting, then uninstall all the other USB devices. Let windows find them again.

My motherboard should have 6 devices running at "high-speed" 2.0 and 2 devices running at "super-speed" 3.0 (Asus P6X58D Premium Motherboard). Unfortunately, I have only 2 devices running at "high-speed" and 6 devices running at "full-speed" 1.0.

Today, I again uninstalled all the USB drives and let Windows 7 64 re-install on the reboot. The process went fine and stated that the drives were installed and when checking the USB ports they state they are running fine but, no change in the speed. I did this three times today without help.

Asus tells me it's not their motherboard it's the drivers fault.

What I have tried so far:

1) Unistalled the USB drivers and let the windows 7 64 re-install. I've done this atleast 10 times with the same result.

2) Updated the USB drivers through windows (microsoft) AND updated the 3.0 NEC drivers through Asus web sight.

3) Tried an additional external USB port with the same result.

4) Uninstalled (completely wiped) everything from the SSD and HDD and reinstalled windows and the drivers with the same results.

5) Purchased and installed a second uber power supply with the same results.

6) Contacted Logitech (mouse and keyboard supplier) with no help.

7) Thanks for all suggestions. I guess I'm down to "forcing" Asus to RMA the motherboard unless anyone else has a suggestion.


Excellent Member
Microsoft Community Contributor
I have downloaded your owner's manual the am currently checking some things.

There is a Enable USB functions, which I assume you have enabled.

The bios has an enable setting for the NEC 3.0 controller, which I assume you have enabled.

I also assume you have the 2.0 controller set to High Speed.

Only 2 ports on the back are USB 3/2.

I see a USB Firmware updater which says to make sure and remove any USB 3.0 devices from those ports prior to update.

The USB 3.0 controller driver, which I will assume gives you instructions as to how to install.

You have probably already done all of this, but what I would do is to restrict Windows from installing hardware updates.

I would then, if you have not already or already have the latest version, run the USB 3.0 firmware updater.

Reboot and install the Asus Chipset drivers, and then the NEC USB 3.0 driver.

I can't think of anything else, unless the motherboard is having a problem and the 3.0 controller is bad.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.