USB Mouse

Discussion in 'Windows 7 Hardware' started by imported_PcBoyGeorge, Jun 6, 2009.

  1. imported_PcBoyGeorge

    Joined:
    Jun 6, 2009
    Messages:
    62
    Likes Received:
    0
    Hi,

    I have a HP G60-115EM Laptop and i have a usb mouse and keyboard made by hd. I like to use them sometimes. But when i plug the usb device in for the wireless i get a message saying "HID Data has stopped working" then the mouse will not work but the keyboard will... Why?

    But the strange thing is. I have 3 usb ports on my laptop. One on the left and two on the right. If i plug the usb adapter in the left the hid data stops working but if i plug it in the 1st one on the right it doesn't and works ok???

    Why is this?
     
  2. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,849
    Likes Received:
    1,569
    Not entirely sure but pc's can be the same. If a device fails to work properly in say the front USB ports then you always try the ones at the back Does your mouse come with a driver? You could always check if there's an update if it does..

    On the question of USB ports and why some seem to differ I did in fact try to google for an answer but the nearest I got was this..

    Difference between front-panel and rear-panel USB ports - Hardware - HP Support Forums
     
  3. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
    Do you have a Microsoft Bluetooth Mouse 5000? HP has something wrong with the "HP Quick Play Buttons" Here read these two articles: PC Magazine Discussions - HID DATA has stopped working message (these below might have a better solution)
    http://forums.techarena.in/vista-hardware-devices/1023595.htm
     
  4. imported_PcBoyGeorge

    Joined:
    Jun 6, 2009
    Messages:
    62
    Likes Received:
    0
    I don't know the model. They just came with a desktop computer my dad got a few years ago.
    Ill try uploading a picture to show you. All i know is that it is hp make.

    Also i don't know about driver. It works with plug 'n' play. I just plug it in. It loads a driver or something then i get a HID Data message.

    Then i just plug it in and get the message any other time.

    Oh and also. I have 3 usb ports. 1 on the left. 2 on the right. But it only works on the one on the right closest to my screen. The one next to it dosent work.

    Here are some pics:

    Mouse from front:
    [​IMG]

    Mouse from back:
    [​IMG]

    Adapter to recieve mouse signal front:
    [​IMG]

    Back of mouse adapter:
    [​IMG]



    By the way im on vista. Im just using a mac theme.
     
  5. imported_PcBoyGeorge

    Joined:
    Jun 6, 2009
    Messages:
    62
    Likes Received:
    0
    Here are the other pictures i could not get in the other post:

    USB Port plugged in:
    [​IMG]

    Laptop:
    [​IMG]

    HID Message:
    [​IMG]
     
  6. Celestra

    Celestra Former Moderator

    Joined:
    Jan 15, 2008
    Messages:
    2,468
    Likes Received:
    14
    Hi! his is what HP says about that error: I think I'm right... (Can't always remove documents from HP Library, sorry about thumbnails)
     
  7. kemical

    kemical Windows Forum Admin
    Staff Member Premium Supporter Microsoft MVP

    Joined:
    Aug 28, 2007
    Messages:
    31,849
    Likes Received:
    1,569
    The only thing I would do in this instance is check HP's website for any updates. I'd also use this utility found here:

    http://www.lavalys.com/products.php?ps=UE&lang=en&page=1

    It's called Everest. It is a benchmarking and system information tool which also has a free version... You could give it a run and see what it say's...
     

Share This Page

Loading...