Video playback problem

#1
So my video playback in any player under windows 7 is very grainy
I've tried using the windows 7 drivers and attempted to use the windows vista drivers.

I've tried VLC, WMC, wm11, powerdvd...
Everything is the same.. Video plays back but you can see grain and it's distorted.

Happens with AVI files and mvk also...

I'm running an ati radeon 4590 with the latest drivers..

Any ideas?
 


#2
I'd suggest trying a different driver.... ;) I'm using a Radeon HD 4670 with the latest available Windows 7 driver and have no problems at all.. all media is crystal clear.. I am also using VLC media player for ALL my media needs... however, you might have better luck with the latest available Vista driver instead... ;) Worth a try anyway... It definitely sounds driver related...
 


#3
I installed vista on a dualboot and i'm getting the same problem. It must be a driver issue with this card.. I dunno. Watchable but not as good as it once was... I'm tempted to put the 9800gtx back in to see how that works
 


#4
Yeah it's definitely sounding like a driver issue... the 9800gtx should look fine.. but then again so should the 4590... ;) What driver did you use? The win 7 one or a vista one?
 


#5
I tried both.
What doesn't make sense is how it's happening in vista and windows 7

Mind you both are 64 bit.. I'm almost curious to reinstall vista to be 32 bit and try that now.

The wifes basic pentium 4 system with one of my old video cards in it works perfectly fine which bugs me now

Oh well.. see how it goes
 


cmn

New Member
#6
I tried both.
What doesn't make sense is how it's happening in vista and windows 7

Mind you both are 64 bit.. I'm almost curious to reinstall vista to be 32 bit and try that now.

The wifes basic pentium 4 system with one of my old video cards in it works perfectly fine which bugs me now

Oh well.. see how it goes
Just another thought based on the information that the monitor display problem described is seen in both VISTA and Windows 7 with the same Video card both with the best curently available drivers [and Direct X also current I presume ]in the same computer and same Monitor makes one to consider yet another possibilty. Could the problem be the Monitor?


What type ( CRT vs LCD)of Monitor you have? What color, resolution and refresh rate are set in that monitor?
  1. Right click blankspot on Desktop> Personalize
  2. Bottom left of the Personalization window click Display
  3. From the Left pane click Change display Settings
  4. Verify your current
    • Display : Monitor name
    • Resolution: Current screen resolution. Is this the best Resolution this Monitor can be set?> (refer Monitor Documentation) Adjust as needed by down arrowhead clickand pick
    • Orientation : Landscape Portrait etc Adjust as needed by down arrowhead clickand pick
  5. Click Advanced setting: button on the right side
  6. Click Monitor tab
    • Check Screen Refresh rate : LCDs usually 60Hertz (CRTs always prefer High RR LCDs usually low)
    • Check Colors: True Colors (32bit) : good Change if needed and apply OK
If this is not rectifying the problem Swap monitors between PCs and see .

Hope this helps.
 


#7
Not the monitor.. It only happen when I changed teh video card. Before this it was fine.

And it only happens when playing movies.. everything else is crystal clear..

Me thinks it is a driver problem.. and I don't think there has been a driver update since this card was released.

So for whatever reason vista is not doing it.. I'm not sure why it was before.. or perhaps the late hour I was working on it was at fault.

ATI driver at fault
thanks for the help
 


Last edited:
#8
I'm having the same problem with grainy video, I also get jagged edges with video playback.
I'm using a nVidia 8800GT card. I've also installed Windows 7 on another system, with 2x 7600GT cards in SLI, and have no problems here what so ever, with the same driver as on my 8800GT.

I've tried different drivers/settings, codecs, many different players, but it's all grainy/jaggy.
Even with max anti-alias i get jagged edges...

On the desktop or with games the picture is perfect, it's just video playback that has this problem.
 


#9
I have a similar problem

I opened up a new thread, but in my dispeare waiting for an answer, I will write in this thread, too. My screen is all black when playing a video (the same for my TV tuner). It has sound, but it does not disply anything. The only software that works is Win Media Player. I installed video codecs, but with no success. Any ideeas?
 


#10
Grainy Video Playback

I'm facing the same problem of grainy video playback. I have a nVidia 8800GT with 185.85 WHQL drivers (released just a couple of days ago) and all my movies and videos started looking very grainy and edgy on any media player (WMP12, VLC etc). Havent tried any games so far but the rest of the UI looks pretty good.
One thing that i'm not sure if you guys have noticed, the colors of videos look very rich and better on WMP12, as if the color depth is more that 32 bit. Every setting is set to default just as it was with Vista but somehow here it looks better. It doesnt happen with VLC though and the videos look the same in terms of colors.

I was wondering if it would be help to uninstall nVidia drivers and use the ones that Windows Update automatically installs...
 


#11
I was just curious if there is a fix yet? I read on a few websites that this is a known issue with ati drivers.. again 4890 has grainy video play\back.. One work around I found was in VLC changing video output to direct x output.. still not crystal clear but not as grainy
 


#12
I found a fix that works for me. It isn't perfect in alot of regards, but at least during playback the video quality looks identical to XP/Vista playback. I am using a Radeon HD 5850 and was getting the grainy playback in windows 7 using default drivers.

How to fix the grain:
- Install the Combined Community Codec Pack with Media Player Classic - Home Cinema. (CCCP - Combined Community Codec Pack). Just run the standard installation with default settings.
- Run Media Player Classic
- Press O for the options menu.
- Go to Playback -> Ouput and select "Overlay Mixer *" in the DirectShow Video setting. Leave the other settings default.
- If you are using subtitles you will need to do this:
- Go to External Filters (a little further down on the left).
- Click "Add Filter" and add the "DirectVobSub (auto-loading version)" filter.
- Select the filter and change the button on the right from "Set Merit:" to "Prefer"
- Everything will play smoothly now.

Note that windows will change to "Basic" mode instead of Aero while playing a video and will change back when you close the video. It's a bit annoying, but I find the switching back and forth between basic and arrow to be FAR less annoying then watching grainy video and subtitles. Hopefully ATI or Microsoft fixes this shortly so we don't have to use this method in the future.

Hope this helped someone!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.