Wierd usb problem

Discussion in 'Windows 7 Help and Support' started by djhalloween, Dec 3, 2009.

  1. djhalloween

    djhalloween New Member

    Joined:
    Dec 3, 2009
    Messages:
    4
    Likes Received:
    0
    I got a strange problem whit my usb ports. Every time i plug in a new device all usb ports stops working. I have reinsall drivers in safe mode. Nothing works, I have win7 ulti.
     
  2. Bubbalou

    Bubbalou New Member

    Joined:
    Oct 28, 2009
    Messages:
    92
    Likes Received:
    2
    Go to the manufacturer of your motherboard's site and download the latest Chip Set drivers and install them. You may have gotten a corrupted USB Hub driver etc. If their USB drivers are in a separate file then down load that one also.
    Reboot the machine and see if the USB ports work as they should.
     
  3. djhalloween

    djhalloween New Member

    Joined:
    Dec 3, 2009
    Messages:
    4
    Likes Received:
    0
    cant find any drivers. I have a acer aspire m5100 AMD Phenom X4 9500 Quad Core Processor 2.2GHz, 4GB
     
  4. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    I used a third party (DriverMax) to find drivers for my usb hubs. It was the only place that I could find them. You might try a third party to see if that will do the trick.
     
  5. Bubbalou

    Bubbalou New Member

    Joined:
    Oct 28, 2009
    Messages:
    92
    Likes Received:
    2

    I looked on the Acer support website. Your Laptop supports XP and Vista only. The 5220 and above support Windows 7.
     

Share This Page

Loading...