Wifi connectivity lost after sleep mode

Discussion in 'Windows 7 Networking' started by salilsurendran, Oct 17, 2010.

  1. salilsurendran

    salilsurendran New Member

    Joined:
    Oct 17, 2010
    Messages:
    8
    Likes Received:
    0
    Hello Friends,
    I have Windows 7 on a Dell Inspiron 1545. Most of the time when I put my laptop to sleep and restart it Wifi network connectivity is lost and I have to click the 'Wifi Signal' icon in the system taskbar and click on my network name and click connect to regain connectivity. I have gone to 'Power Management' tab and cleared 'Allow Windows to turn off this device to save power' option as suggested by most posts but it has done nothing to help me. But sometimes even after a long sleep the laptop immediately connects back to the network and sometimes even if I just close the lid and open it after a few seconds network connectivity is lost. Please help.
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First, since it's not clear from your post as to how you came to be running Windows 7 on this laptop (came pre-installed, upgraded, you performed a clean install) nor whether you are currently running 32bit or 64 bit Windows 7, then I would suggest you go here
    http://support.dell.com/support/downloads/index.aspx?c=us&cs=19&l=en&s=dhs
    plug in your service tag number and see what Dell might have available in the way of updates for drivers and utilities (chipset, wireless, bios, etc.) as it is generally considered a good idea to make sure that all these are as current as possible.
    Also does it seem to make any difference at all if the machine is running on battery as opposed to AC as to whether or not the problem occurs. There is one other place to look and possibly make an adjustment to how the wireless adapter behaves, you can make advanced settings changes within the power plan options changing its' "Power Saving Mode" to "Maximum Performance" as well as considering the bus architecture and adjusting the PCI Express, Link State Power Management settings to off. However; changing these settings might inhibit your laptops ability to enter sleep mode, so if changing them introduces more problems than are actually resolved you may need to change them back to their original state.
     
    #2 Trouble, Oct 19, 2010
    Last edited: Oct 19, 2010
  3. salilsurendran

    salilsurendran New Member

    Joined:
    Oct 17, 2010
    Messages:
    8
    Likes Received:
    0
    My 64 bit Windows 7 came pre-installed. I have already updated my drivers using the link you had given me. Changing it to maximum performance doesn't change anything. I will try to change the Link State Power Management if I can find it. What should I adjust in the PCI Express?
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    The PCI Express setting in the Advanced Settings for your power scheme options is where you should find "Link State Power Management" try adjusting the settings to "Off".

    EDIT: Does it seem to make any difference as to whether or not the laptop is on AC power or battery? Is the behavior the same?
     
    #4 Trouble, Oct 29, 2010
    Last edited: Oct 29, 2010

Share This Page

Loading...