Insider Preview Windows 10 Tecnical Preview 10041 random hangs.

Discussion in 'Windows 10 Help and Support' started by Optithanos, Apr 10, 2015.

  1. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Hello guys. I am a windows 10 user for 2 weeks now and everything is going on really well. However, when i installed the latest technical preview of Windows 10 (10041), something weird started to happen. Random hangs started to occur without a reason and it's really frustrating because I have to restart my computer and lose all my stuff. Any help would be appreciated.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You don't give us a lot of information to go on. You might check the Event Viewer to see if any error messages are showing up.

    These builds still quite a few bugs and things such as you are seeing are still happening. On several occasions, all I had to do was to click on the Start Button and the system would freeze...

    Let us know about your configuration and any particulars regarding when and how the freezes happen.
     
    Optithanos likes this.
  3. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Okay, so I run Windows on a 64x bit Desktop with the following specs:
    Intel Core i5-3330 3.00GHz
    4 GB RAM
    AMD Radeon 7700 HD

    Also, I read the issues of the newest build on the Windows Official Website, but I did not come across with my issue.

    Furthermore, the freezes happen randomly. One can occur while I am playing a game, or while I'm just on my browser. They can happen while my PC is on for 1 hour, or for 5 minutes.

    In the Event View I can see the "Critical Errors" under the "Windows" and "System" tab. Their description is showing the unexpected reboot I do whenever my PC hangs. It says: The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly and it's source is "Kernel-Power".
     
  4. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,532
    Likes Received:
    314
    If we can assume hardware is working then a freeze after only 5 mins tends to be a driver... is C drive a sata or ssd harddrive and what motherboard make/ model is it attached to?
     
    Optithanos likes this.
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Can you tell if the system is generating Dump files. Depending on if you have set it to create mini dump files, you may see a file called Memory.dmp in the Windows directory, or a file in a folder called minidump in the Windows directory.

    The memory.dmp file is fairly large, so using the minidump file would be best for attaching here. You also need to check the non-critical errors. Look for repeating errors and especially ones around the time of your problem showing up.

    As pointed out, there may be several causes for this, but AMD and Nvidia video adapters/drivers have been one frequent problem.
     
    Optithanos likes this.
  6. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Ussnorway, a hang after 5 minutes have never happened to me. I just said it to point out that the freezes are completely random. I don't know if it's possible to freeze after 5 minutes because it has not happened but it can occur in the future. The manufacturer of my motherboard is WIBTEK and the model is H61-M HDMI2. Also how can you see if your C driver is sata or ssd harddrive? :p.

    Saltgrass, I only see the Memory.dmp file in my Windows directory which is 438MB. Apparently, there is no file called "minidump" in my Windows directory.

    About the errors, a repeated error is "A timeout (30000 milliseconds) was reached while waiting for a transaction response from the WinDefend service." and it's source is Service Control Manager.
    Also there is a repeated Warning that says "The driver \Driver\WudfRd failed to load for the device SWD\WPDBUSENUM\_??_USBSTOR#Disk&Ven_Generic&Prod_STORAGE_DEVICE&Rev_9833#000000009833&0#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}." and it's source "Kernel-PnP"

    Thank you for your time everyone.
     
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I will have to do some research on the error messages, but do you have some sort of multi-function printer attached, or any USB devices beside your mouse and keyboard.

    The file name is not minidump, there may be a folder named minidump. But to make sure those are produced you can go to the Advanced System Settings, Advanced tab and Startup and Recovery. Use the Settings button and set the System Failure to a Small Memory Dump and it will set the correct directory.

    If you wanted to try to post the memory.dmp on your OneDrive and give a link to it, I might try to read the dump but I am not that good at doing so. Maybe one of the Admins will weigh in.
     
    Optithanos likes this.
  8. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Thank you for your time and help Saltgrass.
    Yes I have a multi-function printer attached, but I also have a webcam and another mouse. (I basically have 2 mouses).
    Also, there is no folder called minidump either. I did what you said and the directory it set is "%SystemRoot%\Minidump", but when i search for it in the directory search bar it says that there is no such directory.
    I am currently uploading the Memory.dmp file on my OneDrive account. Once it finishes uploading I will post it here.
     
  9. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The folder will only show up until after you experience a Blue Screen.

    The error message seems to be pointing at what Ussnorway was referring to, in that it appears to be some type of storage device. Some printers have card readers and you might try putting some media in that if it has one. You may also have an internal card reader. But the WPD seems to refer to Portable Devices.

    If you wanted to go into the Device Manager and look through your devices using the Properties and Details, the listing for Hardware ID might give you a clue as to which device it causing that error message. You may even have a section for WPD on the bottom of the listing.

    Using OneDrive and giving links needs you to be aware of security to make sure you don't expose any other files. It was a little bit of a learning curve for me and I was never really sure I did it correctly, so be careful. You could send me a private link if you aren't sure.
     
    #9 Saltgrass, Apr 11, 2015
    Last edited: Apr 11, 2015
    Optithanos likes this.
  10. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Okay, I will send you a private link for the file "Memory.dmp" I'm uploading, but it seems kind of weird to me the fact that when I had Windows 8, Windows 8.1 and the previous build of Windows 10, no problems such as this one occurred. I had no problem with any of the devices I used such as printers, microphones etc. Is the newest build capable of creating a problem like this in one of my devices? Also how are we sure that that WPD Error is causing the hangs?
    Thanks for your help in advance.
     
  11. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Update: Well, unfortunately my computer crashed again in the middle of the slow upload of my "Memory.dmp" file. Also, after this crash i checked my Windows directory and no folder named "Minidump" appeared.
     
  12. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    We aren't sure the WPD situation is the actual problem, it may be the result. A dump file may help with that.

    It seems in Windows 10, saying it worked in Windows 8.1 or even Windows 10 is not really relevant. Some changes are being made and the drivers you have or have been given for some devices my not function correctly.

    We can just wait for it to crash again. Otherwise, I can't think of anything else to check. Maybe try disconnecting the network connection to see if that helps.
     
    Optithanos likes this.
  13. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    What happens if the Minidump folder doesn't appear again, though?
     
  14. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You will have to keep watching the error messages and trying to track down whatever the problem happens to be, and there may even be more than one.

    For now, all I can suggest is to check Device manager and see if any drivers can be upgraded. Maybe check to see if a new Bios is available for your system. Unplug the extra mouse and Webcam. Basically run your system with minimum devices to see if it helps.

    Maybe someone else will have some ideas, so I will wait to see if you get another dump file.
     
    Optithanos likes this.
  15. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Alright, thanks for your time and help.
     
  16. bochane

    bochane Honorable Member

    Joined:
    Oct 18, 2012
    Messages:
    643
    Likes Received:
    47
    I too expienced hangs in 10041, and I found in the Application Error Log entries of WDM just before the moment of the hang. In my case updating to 10049 solved it. If you find these log entries also, you may try updating also.....
    Just a wild guess
     
  17. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    I will definitely try updating bochane. Thanks for letting me know that a newer build has been released.
     
  18. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Okay, for some reason the update of the newest build (10049) which should be named fbl_impressive 10049 Enterprise (I think) does not appear in the Windows Update. Is there any other possible ways of getting it?
     
  19. Optithanos

    Optithanos New Member

    Joined:
    Apr 10, 2015
    Messages:
    13
    Likes Received:
    0
    Ah nevermind it appeared.
     

Share This Page

Loading...