Windows 7 "Completing Installation"

Discussion in 'Windows 7 Installation' started by opiuman, Jan 12, 2009.

  1. opiuman

    opiuman New Member

    Joined:
    Jan 12, 2009
    Messages:
    2
    Likes Received:
    0
    Using a working DVD with the image (since it was able to be installed on my dad's computer) it works fine on my system until it restarts after completing the first phase of the installation. After it restarts and goes to the screen with Starting Services and the screen after where it says Completing Installation. At this point it seems to take forever, is this normal or is something terribly wrong? Everyone else has mentioned that its really fast to install so I'm wondering what's going on.

    During this phase my mouse doesn't work (USB) but my keyboard still does (PS2), After awhile theres no more HD access and the DVD drive even stop spinning so it's like its not even doing anything.

    EDIT: After resetting and reformatting the drive when it restarts and it says Starting Windows it BSODs into a screen with no error. Previously this happened to me with the error being an "UNMOUNTABLE_BOOT_DRIVE" or something similar. I am beginning to suspect that this is due to a HD failure since before retiring this HD, it had serious data corruption issues and hangs.
     
    #1 opiuman, Jan 12, 2009
    Last edited: Jan 12, 2009
  2. RichardB

    RichardB New Member

    Joined:
    Jan 13, 2009
    Messages:
    2
    Likes Received:
    0
    Hi, I'm in a similar situation. I'm trying to install the beta into MS Virtual PC 2007 on a Vista Ultimate HP laptop. Got to the same point as you last night and it just hung for hours at 'completing installation'. I left it going overnight but unfortunately Windows Update on Vista rebooted my machine without it ever completing!

    I started it off again this morning so am hopeful when I get home tonight that it will have progressed. I read this blog last night so am hopeful that it'll complete eventually.

    Installing Windows 7 Beta How To and Problems Report In Depth | New Gadget, Hardware and Software Reviews
     
  3. Boxcutter

    Boxcutter New Member

    Joined:
    Sep 26, 2009
    Messages:
    2
    Likes Received:
    0
    I also had this problem and tried a bunch of things to solve it.

    I finally solved it by reconnecting the harddrive I was installing Windows on FROM the orange sata port on the motherboard TO the purple one. I have Gigabyte 965P-S3 motherboard. This may work for some of you (you may have to set the sata emulation to AHCI instead of IDE in bios as well, but try it without that first).
     

Share This Page

Loading...