Windows 7 computer connects to network for about a minute

#1
I can connect to the network on every try -- but the connection only lasts about a minute, and then the connection is lost. Using a Netgear USB adaptor and Netgear router. (Three other computers work fine on the network -- an iMac, an HP laptop and a Lenovo laptop.) None of the other computers drops off the network. The Lenovo laptop, wihich works just fine is located right at the computer that doesn't stay connected, so it's not a range problem. Ideas appreciated.
 


helpifIcan

Fantastic Member
#2
Even though other PC's work it still could be a router issue.
1. delete the connection on the PC and see if this helps. (if you have not already tried.)
2 Reboot the router/modem which ever you have, if modem be aware it may have a battery and disconnecting the power will not work, you will have to find and press the reset button
 


#3
Even though other PC's work it still could be a router issue.
1. delete the connection on the PC and see if this helps. (if you have not already tried.)
2 Reboot the router/modem which ever you have, if modem be aware it may have a battery and disconnecting the power will not work, you will have to find and press the reset button

I appreciate your reply. As you guessed, I have rebooted the router (not a modem) several times. There are no other PCs using the router; the other users are two iPads and an iMac. I have turned off the wi-fi connection on all three of those and the PC in question still connects, and then dis-connects after a short time. I'm sort of at the end of ideas. But I thank you for your thoughts and the time you took to express them.
 


patcooke

Microsoft MVP
Staff member
Premium Supporter
Microsoft MVP
#4
Check your IP configuration (could be as simple as DHCP allocation set to a very short time):

Command prompt and enter the command

ipconfig /all
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.