Windows 8.1/10 sleep problem

Discussion in 'Windows 10 Help and Support' started by TheTud69, May 29, 2016.

  1. William B

    William B Active Member

    Joined:
    May 14, 2016
    Messages:
    146
    Likes Received:
    32
    Not sure if you have the N56JN (very impressive laptop BTW) but I found few things that may be of interest to you. One, there are 3 BIOS versions out there for it.201, 202, and 203 here. The BIOS descriptions (fixes) are as follows_

    BIOS 201
    Update NV VBIOS.

    BIOS 202
    Support Foxccon wifi combo card (T77Z371).

    BIOS 203
    Update NV VBIOS


    So you may want to check what BIOS you are currently using. I also found a utility that supposedly goes with a W10 install, and it is likely already included with your W8.1 restore media. It's called "ATK" found here. Description of said is as follows_

    ATKPackage (For Windows 10 Upgrade)
    ATKPackage includes ATKACPI driver and hotkey-related utilities.
    To avoid displaying OSD abnormally due to compatibility issue after upgrade to Windows 10, please update ATKPackage to v1.0.0038 or above.


    Now if I had this problem the first thing I would do is take note of the BIOS version, and see if I was updated to the latest one, because two of them have the "NV" fix, which I assune they are referencing the nVidia GPU solution the notebook has, and yes if the original GPU solution (via GPU BIOS) was not working properly in it's default state it could interfere with coming out of sleep mode properly. Two of the BIOS versions seem to address that.
     
    holdum333 likes this.
  2. davehc

    davehc Microsoft MVP
    Premium Supporter Microsoft MVP

    Joined:
    May 1, 2008
    Messages:
    5,116
    Likes Received:
    301
    Power4gear has given similar problems for some time. Try
    1. See if the option to turn off the HD is there. If so check that it does not.
    2. Disable, or remove, the Power4 gear facility. - You may need to have a look in, and set up, the Windows 10 power options.
     
    kemical likes this.
  3. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,778
    Likes Received:
    214
    WilliamB makes a very good point about the BIOS needing to be upgraded. If you would have answered my Question about whether you ran the W10 COMPATIBILITY TEST, it often picks up BIOS deficiencies and will report them. Yes, you did a Clean Install on W10, but ignored this question. If you don't remember whether you did it or not, that's Ok. It sounds like another W10 install is in your near future anyway; you can run it on the next install. I would take WilliamB's suggestion of running the BIOS upgrade prior to another W10 install, just to eliminate that as a possibility. You should still run the COMPATIBILITY TEST even after the BIOS upgrade is done, just to make sure that hardware (mainly your Motherboard) can then run on W10 without problems.

    You still haven't tested the Hard Drive, and that's something else you should do, especially since failed hard drives are the #1 cause of laptop failures. Here's the link to do that:
    Hard Drive Diagnostic Procedure
    This is a comprehensive guide for pretty much any brand of hard drive you might have in your laptop. If possible, you should download and run SEATOOLS and run both the short and the long tests. Unless you have drive brands stated that won't run with SEATOOLS such as certain Toshiba & Fujitsu drives, if SEATOOLS returns errors on either test, your hard drive has failed and must be replaced!:waah:

    Running the windows repair tools we have given you, such as MEMTEST & SFC (System File Checker), as well as testing your hard drive find and resolve about 90% of laptop failures. That's why we suggest you run both.

    You also didn't answer the question about the Warranty situation on your laptop. We must assume then that it is out of warranty or you simply haven't explored that problem. Answering the basic troubleshooting questions we ask is really a must here in order for us to better help you.

    On the ASUS website as WilliamB shows this laptop does have OS support for W10 64bit; so if a Clean Install of W10 caused this problem, that's not likely since it also occurred on a Clean Install of 8.1. Since you purchased this laptop and took off DOS and installed 8.1, it has this problem. If you do take the time to do the BIOS upgrade, COMPATIBILITY TEST, and the Hard Drive test and the problem persists, I expect that laptop was defective from Day One. It also appears that if you bought the laptop with DOS installed on it, ASUS does not sell new laptops this way, so it's also possible that the person or company you bought it from knew about this problem and tried to hide it by REMOVING Windows from the hard drive and replacing it with DOS. This is a common thing scammers do on the Internet to hide hardware problems in laptops. How legit is the person or company you bought this laptop from? Did you purchase this on the Internet or from a Brick-and-Mortar physical store? Did you ever contact them after this sleep problem started?

    The last thing I would suggest that if you do the above, and the problems persists, you can change out the hard drive entirely to eliminate that component from causing any kind of problem. You can even use a used hard drive from another laptop, but it's best to buy a brand new one for this test. They are usually under $100 on ebay. If this is done, then almost certainly your Motherboard is bonked, and if you can't get satisfaction from the place you purchased it at, you will be left with a very expensive Motherboard replacement; $275-$450 US.

    <<<BBJ>>>
     
  4. TheTud69

    TheTud69 New Member

    Joined:
    May 29, 2016
    Messages:
    15
    Likes Received:
    0
    Sorry for being inactive for such a long time but I had some problems.
    The pc is still under warranty, but I didn't consider that option yet because I thought i may be called an idiot for this not being a real problem with the pc, or just have some messed up settings.
    I must admit I didn't run compatibility test for windows 10, beacause last time i did it, it just checked if my actual apps had versions compatible with W10(on another computer)
    Also when i bought the lapotop, the sleep function was working fine, so i don't know if it had the problem since day one. The company i bought the laptop from is a trusted one, and I've never contacted them after the sleep problem started. It was a physical store btw.


    I don't know if Power4gear is the problem since the laptop doesn't even have a sleep option without it installed... And no, there is no option to disable HD, i will try removing Power4Gear and come back with the update


    I have the ATK package already installed, and I'm not sure about the BIOS update, beacause it worked in the past on windows 8.1, but something happened and stopped working. Also I'm afraid of this option beacause I've never did a BIOS update before and I heard I can get my laptop bricked, but if this is the problem, or it's a good thing to do anyways ill consider the update.

    Thank you for your time
     
  5. RichM

    RichM Active Member

    Joined:
    May 9, 2016
    Messages:
    321
    Likes Received:
    49
    The biggest concern is there not be any interruption to bios upgrade. No power failures and also be certain the bios upgrade is definitely for your laptop as those are the two things that can turn it into a doorstop.
     
  6. RichM

    RichM Active Member

    Joined:
    May 9, 2016
    Messages:
    321
    Likes Received:
    49
    Clean install is necessary as the upgrade must have caused this.
     
  7. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,778
    Likes Received:
    214
    Well, you'll never know unless you call the Company who sold the laptop to you and exercise your warranty right. Do you you wish to keep from appearing to look like an idiot for messing up an obscure setting that you couldn't figure out how to solve, or to pay several hundred dollars to only get stuck with a broken-from-the-factory laptop?? Especially since you indeed have a warranty in place.

    BBJ

    Sent from my VS986 using Windows Forums mobile app
     
  8. RichM

    RichM Active Member

    Joined:
    May 9, 2016
    Messages:
    321
    Likes Received:
    49
    Marc,
    Remember warranties on computers only cover hardware and this is a software issue and no pc maker has to guaranty upgradability.
    Still it wouldn't hurt to call and ask if there are known issues for the laptop with Windows 10 upgrades.
     
  9. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,382
    Likes Received:
    360
    If you are using a USB keyboard and mouse and would look in the power plan and disable the usb power off.
     
  10. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    Hi @Neemobeer Are you talking about here in the power plan. I'm sure W8.1 is different, but this is what my W10 looks like!
    Capture50.JPG
     
  11. TheTud69

    TheTud69 New Member

    Joined:
    May 29, 2016
    Messages:
    15
    Likes Received:
    0
    It seems it's a hardware problem...
    I booted a live Ubuntu from a disc to see if the problem persists(if the live Ubuntu would enter sleep normally).
    It didn't... same thing, instead of normal resuming it just reboots, even though it's able to "wake up" by pressing a key.

    Ok so win 8.1 win 10 and live Ubuntu cant sleep on this pc means its something related to memory or HDD? If so, how do I know exactly which part is faulty? Run memtest86(for RAM I guess) and what? Or just use the warranty? But the sad part is it will take a few weeks until they send it back... xD
     
  12. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    Hi my 2 cents! It is my understanding that Ubuntu runs on RAM. If that is true, then I would suspect the RAM is causing your issue.
    IMHO I would run memtest86 and see what it comes up with. Then you can use the warranty;):up:
     
  13. RichM

    RichM Active Member

    Joined:
    May 9, 2016
    Messages:
    321
    Likes Received:
    49
    Sorry Ubuntu doesn't run on ram, it runs on cd or dvd or by installation. The ony way it could run on ram is if you remove the live-cd
    and I am not aware you can do that with Ubuntu. What running Ubuntu does show is that the issue is a Windows issue either a driver that will not shut down in power management and the most common are soundcard, ethernet or also an external hard drive maybe. And also because this is Windows 10 that adds in the common incompatibility with Nvidia drivers. Since this is likely an upgrade to Windows 10 and that is where the problem started, more than likely its an issue with the upgrade and might be another reason to return to Windows 8.1 or do a clean install to Windows 10.
     
  14. TheTud69

    TheTud69 New Member

    Joined:
    May 29, 2016
    Messages:
    15
    Likes Received:
    0
    I did run memtest86 and it said there are no errors. And its not about incompatibility(I'm not sure though) because NONE of windows 8.1/windows 10/Ubuntu enters sleep properly. But I'm 100% sure it worked on Win 8.1 and Ubuntu before the problem first appeared. So I think its hardware related.
    Also returning to windows 8.1 wont solve the problem since the same sleep thing happens no matter what OS I'm using.

    I'd be glad to know how to test the other parts, because memory seems ok

    What I didn't check is if Live Ubuntu is supposed to sleep and resume on it's own, and yes, removing the disc will kind of crash Live Ubuntu.
     
  15. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
  16. BIGBEARJEDI

    BIGBEARJEDI Honorable Member
    Premium Supporter

    Joined:
    Jan 28, 2013
    Messages:
    1,778
    Likes Received:
    214
    >>>Rich, maybe you didn't follow this entire thread. The PC was sold to the OP with DOS and without a proper OS such as Windows or Linux. This is illegal according to the folks I've spoken with at both ASUS and Microsoft!:noway: OEM computers cannot and should not be sold without a proper OS. I'll say it again, when folks in either stores or the Internet sell a laptop without Windows or Linux installed they are violating about a half dozen intellectual property laws. Also, people who sell laptops like this usually do so to cover something up, since if you install either Windows or Linux, a hardware problem is almost always found. Therefore they are usually covering up that fact by REMOVING the OS to hide the fact that the laptop has a hardware failure (most likely the Motherboard). You haven't been around that long on this forum, but we've seen several of these here before. The fact that the OP states that since he had the laptop he never had a problem until he installed Win8.1. The problem then occurred. He then tried a clean install of W10; the problem persisted. He then tried Ubuntu; again the problem persisted. The OEM manufacturer has a responsibility to ensure that the computer hardware works properly with an OS when it leaves the factory. If someone, and in this case the someone is the scammer that sold the OP this laptop--physically REMOVED Windows or Linux that came installed by ASUS, to hide the fact that the hardware has failures, surely the warranty with ASUS will allow the reinstallation of the Windows or Linux software that came with that laptop serialized as properly licensed by the manufacturer. If it's Windows; removing Windows (any version) that is shipped with a COA license sticker or a BIOS tag violates several agreements between ASUS and Microsoft as I said. I know this for a fact. As I've been through several of these laptops bought from bogus sellers on the Internet for customers, and specifically with ASUS models.
    Don't mean to slam you bro', but in this case if the OP exercises his warranty and returns the laptop to ASUS, they will test and reinstall with the OS that's licensed to that laptop serial number. If they see any hardware failures including the software sleep problem, they are constrained to fix it prior to resending it to the OP after repair.:encouragement: In this case, any problems with RAM, Hard Drive, GPU/CPU, Motherboard or PSU, or batteries would have to get fixed by ASUS as part of the repair process.:encouragement:<<<


    BBJ
     
    holdum333 likes this.
  17. RichM

    RichM Active Member

    Joined:
    May 9, 2016
    Messages:
    321
    Likes Received:
    49
    Hi Marc, I am not familiar with such laws but that certainly sounds logical, but truth be known I have never heard of anything like this.
    By all means if you all have history on this kind of thing then by all means let me step back and let the user go to Asus. With hardware issues and Asus, they don't easily sell or provide components so that is probably the only recourse and I am anxious to see how this pans out then.
     
  18. Neemobeer

    Neemobeer Windows Forum Team
    Staff Member

    Joined:
    Jul 4, 2015
    Messages:
    2,382
    Likes Received:
    360
    Yes the selective suspend. The setting is the same from Windows 7 - Windows 10 yup @holdum333


    Power management has always been a bit wonky in Linux and I've seen programs causes problems with shutting down and reboot etc such as docky.

    Most hardware, especially peripherals only support D0 and D4 (Off and On respectively) and during sleep will enter an off state. If you are using a usb mouse and keyboard and your usb hubs hit D0 then you might not be able to come out of sleep unless your BIOS/UEFI support a hardware level wake on usb.
     
    #38 Neemobeer, Jun 3, 2016
    Last edited: Jun 3, 2016
  19. holdum333

    holdum333 Banned

    Joined:
    Mar 27, 2016
    Messages:
    1,244
    Likes Received:
    147
    Hi friend ! Is your reply for me??
     
  20. TheTud69

    TheTud69 New Member

    Joined:
    May 29, 2016
    Messages:
    15
    Likes Received:
    0
    I think I have been a little unclear, so this is EXACTLY what I did with the laptop, also I forgot to mention it has an etiquette on which is written OS: FREE DOS, so there was no scam

    - Bought pc with FREE DOS
    - Installed Linux Mint 17(I didn't have a windows media at that time)
    - Installed Linux Ubuntu
    - Installed Windows 8.1
    Sleep working fine on all of these...
    - Install Windows Insider Preview 10 ==== HERE SLEEP STOPPED WORKING
    I noticed sleep wouldn't work, and I thought its OS's fault since it was just a BETA version
    - Installed AGAIN windows 8.1 BUT sleep STILL NOT WORKING(I thought Microsoft saved my WIN 10 settings to their cloud server and used them as I installed W8.1, and that was the problem)
    - Installed windows 8.1 WITHOUT entering account details
    - Installed windows 10 ----- Here I am now still trying to find a solution

    NOTE: All installs are clean and wiped HDD completely every time

    Also:
    Memtest86 - No errors
    SEATOOLS - S.M.A.R.T test(no errors) - short fix all(no errors) - long fix(I'm running it right now, and seems to take decades)
    Speccy - Piriform - says everything is good, all HDD functions read, write etc - Working fine

    I have no idea. I don't know which part may be broken.
     

Share This Page

Loading...