Windows Store and VWAHost.exe running at startup background, how do I disable it?!

Discussion in 'Windows 8 Help and Support' started by BLaZiNgSPEED, Aug 3, 2016.

  1. BLaZiNgSPEED

    BLaZiNgSPEED New Member

    Joined:
    Aug 3, 2016
    Messages:
    5
    Likes Received:
    1
    I have Windows 8.1 Pro installed upgraded recently from Windows 7.

    Unfortunately I have a problem with the Store app constantly running at startup and it does not go away unless I manually Terminate it from the Task Manager.

    It seems to be ingrained with my Microsoft Account. Because even after a Reformat and reinstall of Windows. It seems like Microsoft just reverts the settings back to how they were as if I did not reformat my PC.

    Even when I set the Windows Store Service (WSService) to Disabled from the regedit Controlset and set it to 4. It still bloody comes back at startup even when the Services displays as Disabled.

    What the **** am I supposed to do? How do I bloody stop this thing from running at startup?!?!?!
    I checked on my dads PC Windows 8.1 and it doesn't happen to him. It only happens on my PC...

    On top of that there is this thing caled VWAHost.exe which chews up 60+ MB RAM in the background despite saying Suspended. Obviously this is associated to the Store App. Because if I terminate the Store manually then VWAHost.exe will then exit.

    I have tried for a number of hours now to find a solution to this problem and I am completely out of sorts. Even with a full windows reinstall of 8.1 the problem still persists! It seems like it is loaded from my Microsoft Account.

    How do I solve this problem so that the Store Service does not keep launching in the background on start up? It doesn't even quit by itself. I uninstalled all the Store Apps but the issue still continues! Hence why I registered on these forums to ask from help. If someone more experienced knows the solution to this...
     
  2. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,532
    Likes Received:
    314
    correct.

    VWAHost.exe
    this is the shell which windows uses to run an app on a desktop system... any app will turn this service on.

    the windows store should be on all the time when you have logged in using a Microsoft id... yes you can hack it but its a very very bad idea and will cause you issues that can't be easy fixed without a call to Microsoft so I don't recommend it.

    the correct why to trim your system is to disable app from the task manager "start" tab.
    Screenshot (26).

    then tell the Microsoft store not to update apps in the background... also tell one drive to piss off (the steps are different with different 8.1 or 8.1.1 builds) and tell your Microsoft id account what settings you like it to sync for you.
    Screenshot (24).
     
    BIGBEARJEDI likes this.
  3. BLaZiNgSPEED

    BLaZiNgSPEED New Member

    Joined:
    Aug 3, 2016
    Messages:
    5
    Likes Received:
    1
    To be honest. This never happened before. There is also a dllhost.exe that stays running in the background as well. This was also not there before the reformat and re-installation of windows.

    I have made an experiment with a fresh Windows Live account but this issue still persists. Start-up is disabled including OneDrive.

    However, I noticed that if I go to msconfig and start up using the Diagnostic Startup option then this does not happen on Boot. So obviously there must be something that is triggering the Store to open at startup.

    I don't want to fully disable the Store. I just don't want it to launch at startup. This is not a normal behaviour. It shouldn't happen.
    Is there any way to set this to Manual only and not Manual (Trigger)? All the other applications I have disabled such as the live tiles for weather, news, mail, etc. I have previously even uninstalled them. But the Store app still runs in the background processes.
     
  4. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,532
    Likes Received:
    314
    so we are on the same page... you disabled the store auto app updates and this is 8.1.1 ?

    Screenshot (27). Screenshot (28).
     
  5. BLaZiNgSPEED

    BLaZiNgSPEED New Member

    Joined:
    Aug 3, 2016
    Messages:
    5
    Likes Received:
    1
    Yes, I did that but Store still opens. Does it open for you on Reboot?
    I even followed another instruction from www.neowin.net/forum/topic/1205121-disable-the-windows-store-in-windows-8-and-windows-81/
    I tried to disable it by changing the values to 4 with regedit. But on reboot the Store app still opens in the background despite the fact that on Services list it remains as Disabled and not running there. It's very bizarre. So I reverted back the value to the original number 3 since it made absolutely no difference.
     
  6. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,532
    Likes Received:
    314
    There are several questions here;

    Does my store app run on start up = no

    The store process runs because I have my store app 'pinned' to the task bar

    The act of 'pinning' something to your task bar tells the system to allow a very very small % to be set aside so that that software can boot faster... This is irrelevant with modern systems and "from memory" was a stop gap patch added to Vista or early W7 because they are so much slower than XP and Microsoft had a lot of trouble getting people to migrate away from it.

    That guide is for w8 or w8.1 which uses the same (back ground) store process however 8.1.1 has a different version of store and the steps to disable it by registry edit would need different keys... The original author of the guide correctly warns people to make a backup and there are plenty of later posts pointing out the dangers so its a case of "at your own risk" but I would not have done that.

    The difference between 8.1 and 8.1.1 can cause the store app to sometimes lock up (because the animation at store start was incompatible with some of the default "out dated" graphics drivers) from the task bar and this error has been patched by Microsoft updates... If this sounds like your issue i.e, the store app itself refuses to open from the task bar, then your options are allow Microsoft to update the system to a higher build or (better) replace the crap drivers with ones direct from the g-cards maker.

    I recommend, you press [windows key]+[x] and the [t] to open the task bar... Goto app usage and press the 'delete history' link then *shutdown the system and reboot it to confirm the store app is in deed running after your preferences changes.

    Screenshot (30).

    *Note, a system restart is different to a system shutdown in modern systems and offen skimps some of the maintenance.
     
    #6 ussnorway, Aug 5, 2016
    Last edited: Aug 5, 2016
  7. BLaZiNgSPEED

    BLaZiNgSPEED New Member

    Joined:
    Aug 3, 2016
    Messages:
    5
    Likes Received:
    1
    This is exactly what I have done! But it still starts. It still shows in App History memory usage.
    For some reason I believe there must be a glitch in the system. The only thing I noticed that would stop it from running at startup is if I rename the WinStore folder to Disable or anything else. But this isn't a proper solution. So I returned the name back.

    To give you an idea I can show you an example [​IMG]
    So this is the reality! Disable the store even by regedit. It just gives an illusion in the Services that the store is disabled and not running. But it is constantly running in the Background processes and never exits unless I terminate it. I have no idea what to do...
     
  8. BLaZiNgSPEED

    BLaZiNgSPEED New Member

    Joined:
    Aug 3, 2016
    Messages:
    5
    Likes Received:
    1
    I can confirm that after a 4 hour Windows Update the issue has been resolved!
    The Windows Store App no longer starts up at boot. It was definitely a bug. Still wonder what caused it. I had installed 207 updates so not sure which of the update(s) fixed the issue.

    However, while this issue has been fixed. I feel like the memory usage has increased. Before at idle RAM usage was under 500 MB (13%) now is 570-600 MB (15%). So I can see an average increase of 50-100 MB more RAM being used after the Windows Update. Not a big deal. Still less than Windows 7.
     
    ussnorway likes this.
  9. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,532
    Likes Received:
    314
    thanks for getting back to us... its always noce to know how things worked out.

    p.s, yes windows 8.1 uses more ram (and is slower) than windows 8 ... adding more ram to the system is good but the returns start to drop as you go into higher build numbers.
     
    BLaZiNgSPEED likes this.

Share This Page

Loading...