Windows Vista Ultimate and ASUS Computer Update Problem

#1
I have an old CM1630-05 PC that had Vista Ultimate installed. The computer is pretty old but works fine and is plenty fast for me. The HD was starting to die so I got a new one and copied the old HD to the new one. I upgraded to SP1 and it seemed to work fine. It starts up fine but when I try to update Windows, it doesn't let me. It gives me the error 8024A000. I've tried using MS's Update Fix It but it can't install Powershell. I've tried to use WindowsUpdateDiagnostic.diagcab from command line and that won't work, either because it refuses to connect to the Microsoft Support Server. I also tried to reset Windows Update through a long process and still no luck. So here I am with a computer that doesn't work with a new HD but everything works fine with the old dying HD. I'm sure there is a simple solution that I'm overlooking. Please help...

Thanks,

JackHammer
 


#3
Hi Jack,
I found a link with a number of solutions let us know if they help any:
Thank you very much. I tried the first solution and it worked! I tried something similar that was on the Microsoft site. The one on the Microsoft site had a long list of .dll files but they didn't have the /s switch after. When I ran them, many of them were not found and it didn't work in the end. But this one you provided worked and even solved the Powershell installation problem.

Thanks again!

JackHammer
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#4
Hi Jack,
that's great and much thanks for updating your thread. Hope all goes well but if an issue does re-appear then of course do post back.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.