Album art in WMP library won't load

#1
WMP is showing music library at opening, but it won't load any album art. It's a bit complicated to explain the problem exactly, so I will post some screenshots that you can get what I'm saying.

1) I open WMP, and at it's set to Library => Musc => All music, but it wont' load any album art. I see album name, artist, and everything else, but no album art. I tried to wait, but even after hour or so everything's still same.

2) I go to album submenu (or any ohter), and than it shows album art normally.

3) After that, I go back to All music, and then I can see album art there, as well.

Any ideas why it won't load album art at opening?
 


Attachments

Saltgrass

Excellent Member
Microsoft Community Contributor
#2
Are the libraries on your local hard drive? Since it sounds like WMP can't see the art until after you point it in the right direction, I am wondering if it might be located on your network or somewhere else that is not tasked until you look at a specific area.

You might check to make sure the file location is indexed.
 


Last edited:
#3
Thank you for your answer.

My library is on local hard drive. I've changed its location from C disk to D, but it worked normally for few days after that, and this started to happen yesterday.

I've tried system restore, but it didn't help.

Windows media library trooubleshooter says that library is corrupted, so that corruption could be cause of the problem, but after applying fix in troubleshooter, problem still remains.
Also when I run troubleshooter again, everytime I get a message that library is corrupted.
 


#4
The problem is solved!

After system restore and troubleshooter didn't worked out, I've tried to restore columns in all music, and after that album art appeared. It's a bit strange because the only colums that I've hide were rating, composer, size and parental rating (album art column was checked all the time - it even can't be hidden, it's grayed out), but that was the solution.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#5
I understand you have the problem corrected. I would assume it started with moving the library to D: It gets a little confusing when the Library may not actually be the files, but a pointer to the files.

Anyway, glad it works now.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.