Insider Preview Anyone know what this means...

Discussion in 'Windows 10 Help and Support' started by MikeHawthorne, Feb 15, 2015.

  1. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi

    Bioshock Infinite which ran earlier today when I tested it, now shows this error when I try and launch it.
    I'm also having problems running The Elder Scrolls Online which worked earlier today.

    Since having the error show, I have run DXdiag and found no errors, and I've updated to the latest drivers for my Nvidia Geforce video card.

    This the message I get when I try and start Bioshock...

    [​IMG]

    Anyone have any idea how I fix this?

    I seem to be having more and more problems today.
    Things that worked earlier are not working now.

    Mike
     
  2. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,540
    Likes Received:
    318
    You will need to install direct x 11 Mike… just run the installer that came with the game again to do this.

    In all likelihood, what you currently have installed will be direct x 12 and Microsoft (in their wisdom) didn’t include the backwards compatible drivers.
     
  3. Mike

    Mike Windows Forum Admin
    Staff Member Premium Supporter

    Joined:
    Jul 22, 2005
    Messages:
    8,488
    Likes Received:
    783
  4. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Hi Guys.

    I thought that I was already running DX11, but I just ran DXDiag and see that I'm running DX10.

    I was running DX11 or 12 yesterday morning but somewhere in the process of reinstalling my games it must have gotten overwritten with the lower version.

    I'm surprised that it would do that, because when I tried to reinstall DX11, it said that software was already installed.
    But a few days ago when I looked it said I was running DX12.

    Several games that ran yesterday morning wouldn't open in the afternoon probably all for the same reason.

    I'm going to reinstall Bioshock and if it works I'll wait until the next update in a couple of weeks and do a clean install.
    If it doesn't work, then I'm going to refresh my computer again tomorrow morning and start over.

    I seemed to lose ground yesterday as I progressed.

    I know how to avoid the boot to Adminstrator thing now so I can get rid of the Admin screen coming up every time anyway.

    Things were working fine right after the refresh, and it doesn't take all that long, so I'll get everything setup, get just the games I want to play right now, and my basic software installed and wait for the update.

    Mike

    I ran the installer for the game which prompts Steam to run a verification scan.
    It clearly showed that it was installing DX and when I got done it shows that I have DX12 installed.

    When I got done it still gives the same message so I guess I'll quit messing with it and run Refresh again tomorrow.
     
    #4 MikeHawthorne, Feb 16, 2015
    Last edited: Feb 16, 2015
  5. ussnorway

    ussnorway Windows Forum Team
    Staff Member Premium Supporter

    Joined:
    May 22, 2012
    Messages:
    2,540
    Likes Received:
    318
    Fyi it's not just you... Microsoft doesn't know half as much about games as they think they do but they will get it fixed sooner or later.
     
  6. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,052
    Likes Received:
    303
    Whoo Hooo !!!

    I did refresh again this morning.
    My first stab at running Bioshock Infinite came up with more messages then it did before, all related to DX.

    Attempts to open The Elder Scrolls Online and Skyrim also failed.
    I was somewhat dispirited at this point, but I opened Steam and tried to run Bioshock Infinite from there.

    It came up with a screen that said performing first time setup.
    During this process I saw that it was installing DirectX.

    I'm happy to report that after this process completed, all of the games started working again.
    I've opened all of them several times and they all open up normally, this applies to the non Steam games that wouldn't run as well.

    So everything was related to DX but for some reason there was something happening in the Windows install that wouldn't let Steam correct it. The Refresh removed this and let everything get back to normal.

    I'm going to reinstall my basic software, i.e. CCleaner, Malwarebytes, etc. and then make a system image with everything working before I do any more, so I don't get into the condition I did yesterday where things quit working and I didn't have a backup.

    The Refresh process took 22 minutes from start to finish, but I'd like to see Microsoft add another option.

    How about these 3 options.

    Repair.
    Refresh.
    Restore.

    The Repair install function available with Windows 7 almost always fixed problems without forcing you to reinstall all of your software, just by restoring all the Windows files and setting while leaving registry entries related to your software.

    Anyway I'm happy to report that everything seems to be back to normal.

    Mike
     

Share This Page

Loading...